Hello.
I need to restrict traffic on port-channel's subinterface to 1200Mbs. I have created a port-channel and subinterfaces on it. Then i have set a policy. I used this documentation
But all egress traffic going through the only one interface in the channel, regardless of VLANs.
#show class-map
Class Map match-any class-default (id 0)
Match any
Class Map match-all OUT (id 1)
Match any
#show policy-map ACCESS_1200M_IN
Policy Map ACCESS_1200M_IN
Class class-default
police cir 1200000000 bc 37500000
conform-action transmit
exceed-action drop
#show interfaces port-channel 1
Port-channel1 is up, line protocol is up
Hardware is GEChannel, address is 2894.0fed.d0c0 (bia 2894.0fed.d0c0)
MTU 1500 bytes, BW 3000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 58/255, rxload 31/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
No. of active members in this channel: 3
Member 0 : GigabitEthernet0/0/0 , Full-duplex, 1000Mb/s
Member 1 : GigabitEthernet0/0/2 , Full-duplex, 1000Mb/s
Member 2 : GigabitEthernet0/0/3 , Full-duplex, 1000Mb/s
No. of PF_JUMBO supported members in this channel : 3
Last input 00:00:01, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/1125/0/0 (size/max/drops/flushes); Total output drops: 54432074
Queueing strategy: fifo
Output queue: 0/120 (size/max)
5 minute input rate 365999000 bits/sec, 100882 packets/sec
5 minute output rate 691864000 bits/sec, 102081 packets/sec
124657405555 packets input, 62680974313797 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 1054107 multicast, 0 pause input
141665558186 packets output, 117705126108053 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
#show runn interface GigabitEthernet0/0/0
Building configuration...
Current configuration : 175 bytes
!
interface GigabitEthernet0/0/0
no ip address
negotiation auto
service-policy output AGGREGATE_OUT
channel-group 1
end
#show runn interface GigabitEthernet0/0/2
Building configuration...
Current configuration : 175 bytes
!
interface GigabitEthernet0/0/2
no ip address
negotiation auto
service-policy output AGGREGATE_OUT
channel-group 1
end
#show runn interface GigabitEthernet0/0/3
Building configuration...
Current configuration : 170 bytes
!
interface GigabitEthernet0/0/3
no ip address
negotiation auto
service-policy output AGGREGATE_OUT
channel-group 1
end
#show policy-map AGGREGATE_OUT
Policy Map AGGREGATE_OUT
Class OUT service-fragment OUT
police cir 3000000000 bc 93750000
conform-action transmit
exceed-action drop
interface Port-channel1.1061
bandwidth 12000000
encapsulation dot1Q 1061
ip vrf forwarding internet
ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip verify unicast source reachable-via any allow-self-ping
ip flow ingress
service-policy input ACCESS_1200M_IN
service-policy output ACCESS_1200M_OUT_FRAGMENT
end
Thanks.