cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
4394
Views
0
Helpful
4
Replies
Arshad Khan
Beginner

Port Flapping with log "DTP-5-NONTRUNKPORTON"

Dear,

I have Cisco 1811 and Cisco 2960 interconnect with each other by TRUNK link. As time pass i recieving below log on cisco 1811 router.

DTP-5-NONTRUNKPORTON: Port Fa8 has become non-trunk

LINEPROTO-5-UPDOWN: Line protocol on Interface FastEtherne t8, changed state to down

LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to down

LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state to down

LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan300, changed state to down

LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan400, changed state to down

DTP-5-TRUNKPORTON: Port Fa8 has become dot1q trunk

LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to up

LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state to up

LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan300, changed state to up

LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan400, changed state to up

Line protocol on Interface FastEthernet8, changed state to up

These two devices interconnecting using fiber media connectors meaning pair of media connectors also present between these two devices.

Kindly help in this regards as soon as possible.

Regards,

Arshad Ahmed

4 REPLIES 4

Try to hard cord the port with switchport mode trunk command, before that can you share the config of the that port and also show interface <> details.

Try doing the changes at the Both the ends.

Dear Hemakumar,]

At both side SWITCHPORT MODE TRUNK command has been hard cord.

below is the output of show switchport command.

Name: Fa8

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Trunking VLANs Active: 1,100,200,300,400,550,850,998-999

Protected: false

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

Name: Gi0/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Administrative Native VLAN tagging: enabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk Native VLAN tagging: enabled

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk associations: none

Administrative private-vlan trunk mappings: none

Operational private-vlan: none

Trunking VLANs Enabled: 100,200,300,400

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Hi,

could you try  switchport nonegotiate on interface G0/1 of the switch

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Alessio Andreoli
Contributor

Actually you need to disable DTP on both the ends with the command that Alain was suggesting:

conf t

int g0/1

switch none

end

!

and on the opposite end of the cable:

conf t

int fastx/y

switch none

end

!

Make sure that the same native vlan is in place too.

Hope this helps

Alessio