cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
216
Views
0
Helpful
1
Replies

Possible to do a live reset on QoS engine on switch?

Epiccloud
Level 1
Level 1

After making a number of changes to the QoS engine on our core switch some of the police policies are now malfunctioning.

A policy that is supposed to limit bandwidth to 50 mb/s is only allowing .1 mb/s  while other policies work fine.

Hardware reboots have fixed this in the past, but I'm wondering if there is a command to reset the QoS engine without needing to reboot the hardware?   It's exceedingly difficult for us to tolerate a 10 minute reboot outage on these 3850's.

class-map match-any GOLD
 match access-group name GOLD_Customers
class-map match-any BRONZE
 match access-group name BRONZE_Customers
class-map match-any PLATINUM
 match access-group name PLATINUM_Customers
class-map match-any SILVER
 match access-group name SILVER_Customers
class-map match-any URANIUM
 match access-group name URANIUM_Customers
!
policy-map port_child_policy
 class non-client-nrt-class
  bandwidth remaining ratio 10
policy-map PoliceBandwidth
 class BRONZE
  police cir 10240000 bc 312500 conform-action transmit  exceed-action drop
 class SILVER
  police cir 25600000 bc 312500 conform-action transmit  exceed-action drop
 class PLATINUM
  police cir 102400000 bc 312500 conform-action transmit  exceed-action drop
 class URANIUM
  police cir 256000000 bc 312500 conform-action transmit  exceed-action drop
 class GOLD
  police cir 51200000 bc 312500 conform-action transmit  exceed-action drop
 class class-default
  police cir 10240000 bc 312500 conform-action transmit  exceed-action drop

interface Port-channel3
 description BACKHAULTOASREDGE01
 switchport access vlan 3
 switchport mode access
end

interface Port-channel4
 description BACKHAULTOASREDGE02
 switchport access vlan 4
 switchport mode access
end

interface GigabitEthernet1/0/1
 switchport access vlan 3
 switchport mode access
 channel-group 3 mode active
 service-policy input PoliceBandwidth
 service-policy output PoliceBandwidth

interface GigabitEthernet1/0/2
 switchport access vlan 4
 switchport mode access
 channel-group 4 mode active
 service-policy input PoliceBandwidth
 service-policy output PoliceBandwidth
end

interface GigabitEthernet2/0/1
 switchport access vlan 3
 switchport mode access
 channel-group 3 mode active
 service-policy input PoliceBandwidth
 service-policy output PoliceBandwidth

interface GigabitEthernet2/0/2
 switchport access vlan 4
 switchport mode access
 channel-group 4 mode active
 service-policy input PoliceBandwidth
 service-policy output PoliceBandwidth
end

1 Reply 1

Reza Sharifi
Hall of Fame
Hall of Fame

There is no command to reset the qos engine on a 3850.  You may want to try to clear the qos event and see if it helps.

clear qos event all

HTH

Review Cisco Networking for a $25 gift card