cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1196
Views
0
Helpful
5
Replies

priority queuing

Hi,

Following configuration done on the switch 3750 for a customer for their video network. i have to clarrify few point with this configuration.

1. Qos configuration done for muticast(decimal value 34) & unicast(decimal value 36) traffic ensure high priority on link (STM1) congestion. is it a right/ best configuration for to achive this ? any modication to be done ?

2. Once we apply the queue set on the STM1 interface does it restrict any outgoing bandwidth ? will it give the full 155 Mbps (STM1) for outgoing traffic?

============================================================================================================

mls qos srr-queue output dscp-map queue 1 threshold 1 34
mls qos srr-queue output dscp-map queue 2 threshold 1 16 18 20 22 25 32 36 38
mls qos srr-queue output dscp-map queue 2 threshold 2 24 26 48 56
mls qos srr-queue output dscp-map queue 3 threshold 1 0
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 3 10 12 14

mls qos queue-set output 2 threshold 1 100 100 100 400
mls qos queue-set output 2 threshold 2 70 80 50 400
mls qos queue-set output 2 threshold 3 40 60 50 100
mls qos queue-set output 2 threshold 4 40 60 50 100
mls qos queue-set output 2 buffers 60 20 10 10
mls qos


class-map match-all unicast_traffic
match access-group 101
class-map match-all multicast_traffic
match access-group 100
!
!
policy-map unicast_traffic
class unicast_traffic
  set dscp af42
policy-map multicast_traffic
class multicast_traffic
  set dscp af41

access-list 100 permit ip any 232.0.2.0 0.0.0.255
access-list 100 permit ip any 232.0.3.0 0.0.0.255
access-list 101 permit ip 10.20.2.0 0.0.0.255 10.203.200.0 0.0.0.255

interface GigabitEthernet1/0/25
description STM1_Link
no switchport
bandwidth 155500
ip address 192.168.24.2 255.255.255.252
ip pim query-interval 2
ip pim sparse-mode
ip igmp version 3
ip ospf network point-to-point
ip ospf cost 10
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 60
srr-queue bandwidth shape 0 28 28 28
queue-set 2
priority-queue out
mls qos trust dscp


interface GigabitEthernet2/0/1
switchport access vlan 100
switchport mode access
load-interval 60
spanning-tree portfast
service-policy input multicast_traffic

interface GigabitEthernet2/0/4
Switchport access vlan 200
switchport mode access
load-interval 60
spanning-tree portfast
service-policy input unicast_traffic

Thanks

1 Accepted Solution

Accepted Solutions

Hi Shibu,

1. Yes this is true, queue 1 in queue-set 2 will get 60% of the total buffer.

2. Queue-sets are templates for the egress queues on 2960s and 3750s. By default all interfaces follow queue set 1 but we can make them follow queue set 2 if needed.

All the values in both the queue sets are configurable.

Numbers against buffers are percentage of the total buffer on the egress of the interface for respective queue. Sum of these values has to be 100.

threshold1 and threshold2 are two WTD thresholds expressed as a percentage of the queue's allocated memory. The range is 1 to 400 percent.

Weighted tail drop (WTD) is used to manage the queue lengths and to provide drop precedences for different traffic classifications.

reserved-threshold is the amount of memory to be guaranteed (reserved) for the queue and expressed as a percentage of the allocated memory. The range is 1 to 100 percent.

maximum-threshold

Enable a queue in the full condition to obtain more buffers than are reserved for it. This is the maximum memory the queue can have before the packets are dropped. The range is 1 to 400 percent. The default configuration sets 400 percent as the maximum memory that all queues can have before packets are dropped.

For more information visit

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_25_sea/

command/reference/cli1.html#wp2144505

Hope this helps,

Shashank

P.S: Please rate the helpful post

View solution in original post

5 Replies 5

Shashank Singh
Cisco Employee
Cisco Employee

Hi Shibu,

The configuration looks fine but I have a few remarks:

"bandwidth 155500" command will not restrict the actual bandwidth on this interface to 155 mbps. This value is used as a metric for different protocols on the switch (like ospf in this case) but actual bandwidth will remain as 1gbps. To limit the bandwidth use either speed (supports 10,100,1000 only) or srr-queue bandwidth limit weight1. For more information, visit

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_25_see/command/reference/cli3.html#wp1947391

DSCP 34 (multicast) is mapped to queue1 which is the priority queue and DSCP 36 (unicast) is mapped to queue2. Apart from this you have configured priority queue out which means that as long as there is any traffic in queue1, no other traffic will be processed in any of the queues 2,3 & 4. This implies that as long as there is any multicast traffic (mapped to q1), it will eat up 100% of the resources. This implies that if you have a lot of multicast traffic on this interface, other queues can get starved.

srr-queue bandwidth shape command does not let the queues eat up into the bandwidth of other queues. This implies that each queue has a maximum value of available bandwidth above which packets are dropped into that queue, even if other queues are empty. This can be replaced by the srr-queue bandwidth share command which allows bandwidth sharing between  queues. This means that a queue which has crossed its allotted bandwidth can eat up into the bandwidth of an empty queue and still get its packets processed.

Hope this helps,

Shashank

Please rate if you found the content useful

Dear thanks for your reply...

Sorry for the late written reply.

1. Mean while the following line does it mean the queue  1 get only 60% ? is it?

mls qos queue-set output 2 buffers 60 20 10 10

2. Could you pl brief the following config regarding queue-set as well. thanks

STM-STACK-1#sh mls qos queue-set 1
Queueset: 1
Queue     :       1       2       3       4
----------------------------------------------
buffers   :      25      25      25      25
threshold1:     100     200     100     100
threshold2:     100     200     100     100
reserved  :      50      50      50      50
maximum   :     400     400     400     400


STM-STACK-1#sh mls qos queue-set 2
Queueset: 2
Queue     :       1       2       3       4
----------------------------------------------
buffers   :      60      20      10      10
threshold1:     100      70      40      40
threshold2:     100      80      60      60
reserved  :     100      50      50      50
maximum   :     400     400     100     100

thanks

Hi Shibu,

1. Yes this is true, queue 1 in queue-set 2 will get 60% of the total buffer.

2. Queue-sets are templates for the egress queues on 2960s and 3750s. By default all interfaces follow queue set 1 but we can make them follow queue set 2 if needed.

All the values in both the queue sets are configurable.

Numbers against buffers are percentage of the total buffer on the egress of the interface for respective queue. Sum of these values has to be 100.

threshold1 and threshold2 are two WTD thresholds expressed as a percentage of the queue's allocated memory. The range is 1 to 400 percent.

Weighted tail drop (WTD) is used to manage the queue lengths and to provide drop precedences for different traffic classifications.

reserved-threshold is the amount of memory to be guaranteed (reserved) for the queue and expressed as a percentage of the allocated memory. The range is 1 to 100 percent.

maximum-threshold

Enable a queue in the full condition to obtain more buffers than are reserved for it. This is the maximum memory the queue can have before the packets are dropped. The range is 1 to 400 percent. The default configuration sets 400 percent as the maximum memory that all queues can have before packets are dropped.

For more information visit

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_25_sea/

command/reference/cli1.html#wp2144505

Hope this helps,

Shashank

P.S: Please rate the helpful post

Dear...Thanks again.

Whats exactly the  line under interface configuration does...

srr-queue bandwidth shape 0 28 28 28

interface GigabitEthernet1/0/25
description STM1_Link
no switchport
bandwidth 155500
ip address 192.168.24.2 255.255.255.252
ip pim query-interval 2
ip pim sparse-mode
ip igmp version 3
ip ospf network point-to-point
ip ospf cost 10
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 60
srr-queue bandwidth shape 0 28 28 28
queue-set 2
priority-queue out
mls qos trust dscp

Hi,

srr-queue bandwidth shape 0 28 28 28 assigns the shaped weights and to enable bandwidth shaping on the four egress queues mapped to a port.

If you configure a shaped queue weight to 0 by using the srr-queue bandwidth shape interface configuration command, this queue participates in shared mode.

This means that:

Queue 1 will have 100% of the bandwidth as long as there is any packet in that queue, as this is a priority queue.

Queue 2 will get 100/28  = 3.57% of the bandwidth

Queue 3 will get 100/28  = 3.57% of the bandwidth

Queue 4 will get 100/28  = 3.57% of the bandwidth

For detailed information visit:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_25_see/command/reference/cli3.html#wp1947494

Hope this helps,

Shashank

P.S.Please rate helpful post.

Review Cisco Networking for a $25 gift card