cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
390
Views
0
Helpful
0
Replies
Highlighted
Beginner

Private VLAN uplinks 2960x

I'm trying to set one vlan as isolated ports on my edge switches for peer to peer security and where I have trouble is setting up the mapping for the uplink.

On the network side, I have vlan 200 with a dhcp server, firewall etc.  I will use 1200 as the isolated vlan,   On the uplink I need vlans 10,20,30 so I need to keep the uplink in trunk mode and not private-vlan promiscuous.    I am a bit lost as how I do the mapping with keeping my uplink as a standard trunk port...  I have tried on the vlan interface but that did not work. 

 

  

 

Here is a short version of what I am programming.

 

Primary Vlan = 200

Isolated Vlan = 1200

 

vlan 200

private-vlan primary
private-vlan association 1200

 

vlan 1200

private-vlan isolated

 

interface GigabitEthernet1/0/7
switchport private-vlan host-association 200 1200
switchport mode private-vlan host
spanning-tree portfast 
spanning-tree bpduguard enable

 

interface GigabitEthernet1/0/24

switchport trunk allowed vlan 10,20,30,200
switchport mode trunk
switchport nonegotiate
ip arp inspection trust
load-interval 30
ip dhcp snooping trust

 

interface Vlan200
no ip address
private-vlan mapping 1200

 

 

 

 

Any help would be wonderful

 

Thank you,

Alex.

 

0 REPLIES 0
Content for Community-Ad