11-22-2014 08:40 AM - edited 03-07-2019 09:37 PM
I have configured pbr on a 6500 that is not acting as I had expected. I need to change the next-hop address for traffic originating from vlan24 destined to the Internet. All other traffic should use the routing table on the 6500.
Below is the config that I have attempted.
ip access-list extended ACL-VLAN24-INTERNAL
permit ip 10.37.24.0 0.0.0.255 10.0.0.0 0.255.255.255
!
ip access-list extended ACL-VLAN24-EXTERNAL
permit ip 10.37.24.0 0.0.0.255 any
!
!
route-map RM-VLAN24 permit 10
match ip address ACL-VLAN24-INTERNAL
!
route-map RM-VLAN24 permit 20
match ip address ACL-VLAN24-EXTERNAL
set ip next-hop 10.250.251.100
!
!
interface Vlan24
ip address 10.37.24.254 255.255.255.0
ip policy route-map RM-VLAN24
Solved! Go to Solution.
11-22-2014 09:53 AM
Hi Jon,
for traffic destined to the Internet (only), you should use a 'set ip default next-hop' clause.
Useful link: Configuration Example: PBR using the set ip default next-hop and set ip next-hop commands
HTH
Rolf
11-22-2014 09:53 AM
Hi Jon,
for traffic destined to the Internet (only), you should use a 'set ip default next-hop' clause.
Useful link: Configuration Example: PBR using the set ip default next-hop and set ip next-hop commands
HTH
Rolf
11-22-2014 02:28 PM
Works like a champ. I think my thought process was that ip default next-hop was process switched so I was attempting to use other means. Oh well.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide