cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3355
Views
0
Helpful
3
Replies

Programming the Cisco 892

perryhs
Level 1
Level 1

Hi,

I have a question about a Cisco 892FSP router that I am trying to configure. The 892 has two WAN ports G8 and G9 along with seven LAN ports G0 to G7. It seems that the factory default configures the WAN ports L3 and the LAN ports to L2.

  1. I tried to use the “no switchport” on the LAN ports to convert them to L3, but the switch will not accept this command as is and reports it as an incomplete command. I discovered the answer to this in another post in the support community - that all the LAN ports are hardwired to L2.
  2. So, then I tried to get around this issue by configuring a VLAN and assigning a LAN port to it. Now here’s a curious thing: I used the same configuration (which appears at the end of this posting) in Packet Tracer, and it works fine there; however, it does not work on the router. I also get some strange responses from the router. I installed the Cisco Configuration Express Manager on the router. In the troubleshooting section, I can ping to the internet from the WAN port. When I connect to the router through the LAN port belonging to the VLAN using Express Manager, I can ping the internet from the VLAN; however, if I drop down to the DOS command line on the PC, I can only ping the LAN and WAN ports, but not anything outside of the router. I’m pretty sure the solution is simple and staring at me in the face, so if someone would be so kind and look at my configuration and tell me what kind of stupid thing I forgot to configure, I’d appreciate it.

 

datalab#show interfaces Vlan 10

 

Vlan10 is up, line protocol is up

  Hardware is EtherSVI, address is 70db.9887.bca8 (bia 70db.9887.bca8)

  Description: datalab network

  Internet address is 10.100.100.1/24

  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec, reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive not supported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:05, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     4071 packets input, 332960 bytes, 0 no buffer

     Received 336 broadcasts (43 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     6289 packets output, 6980203 bytes, 0 underruns

     0 output errors, 0 interface resets

     122 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

 

datalab#show interfaces switchport

 

Name: Gi0

Switchport: Enabled

Administrative Mode: static access

Operational Mode: down

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 10 (test)

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Trunking VLANs Active: none

Protected: false

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

 

datalab#show ip route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

 

S*    0.0.0.0/0 is directly connected is directly connected, GigabitEthernet8

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        10.100.100.0/24 is directly connected, Vlan10

L        10.100.100.1/32 is directly connected, Vlan10

      192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks

C        192.168.10.0/24 is directly connected, GigabitEthernet8

L        192.168.10.10/32 is directly connected, GigabitEthernet8

 

 

datalab#show running (excerpt)

 

interface GigabitEthernet0

 description datalab pc

 switchport access vlan 10

 no ip address

interface GigabitEthernet8

 description PrimaryWANDesc_

 ip address 192.168.10.10 255.255.255.0

 duplex auto

 speed auto

 media-type rj45

!

interface Vlan1

 no ip address

 ip nat inside

 ip virtual-reassembly in

 ip tcp adjust-mss 1412

 shutdown

!

interface Vlan10

 description datalab network

 ip address 10.100.100.1 255.255.255.0

 no ip redirects

 no ip proxy-arp

!

router rip

 version 2

 network 10.0.0.0

 network 192.168.10.0

 no auto-summary

!

ip forward-protocol nd

ip http server

no ip http secure-server

ip http path flash

!

ip nat inside source list nat-list interface GigabitEthernet8 overload

ip route 0.0.0.0 0.0.0.0 GigabitEthernet8

ip route 0.0.0.0 0.0.0.0 192.168.10.1

atalab#show vlan-switch

 

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Gi1, Gi2, Gi3, Gi4, Gi5, Gi6

                                                Gi7

10   test                             active    Gi0

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

 

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1    enet  100001     1500  -      -      -        -    -        1002   1003

10   enet  100010     1500  -      -      -        -    -        0      0

1002 fddi  101002     1500  -      -      -        -    -        1      1003

1003 tr    101003     1500  1005   0      -        -    srb      1      1002

1004 fdnet 101004     1500  -      -      1        ibm  -        0      0

1005 trnet 101005     1500  -      -      1        ibm  -        0      0

 

1 Accepted Solution

Accepted Solutions

Richard Burts
Hall of Fame
Hall of Fame

There may be multiple issues but the most obvious issue is about address translation. You do have a command to perform address translation, but there are several issues which prevent it from working.

ip nat inside source list nat-list interface GigabitEthernet8 overload

I do not see any access list named nat-list. I do not see any command on vlan 10 indentifying it as nat inside. I do not see any command on G8 identifying it as nat outside. Address these issues and let us know if the behavior changes.

 

I also note that your two static routes are redundant

ip route 0.0.0.0 0.0.0.0 GigabitEthernet8

ip route 0.0.0.0 0.0.0.0 192.168.10.1

The second one is better (assuming that the gateway is really at 192.168.10.1) and I suggest that you remove the first one.

 

HTH

 

Rick

 

HTH

Rick

View solution in original post

3 Replies 3

Richard Burts
Hall of Fame
Hall of Fame

There may be multiple issues but the most obvious issue is about address translation. You do have a command to perform address translation, but there are several issues which prevent it from working.

ip nat inside source list nat-list interface GigabitEthernet8 overload

I do not see any access list named nat-list. I do not see any command on vlan 10 indentifying it as nat inside. I do not see any command on G8 identifying it as nat outside. Address these issues and let us know if the behavior changes.

 

I also note that your two static routes are redundant

ip route 0.0.0.0 0.0.0.0 GigabitEthernet8

ip route 0.0.0.0 0.0.0.0 192.168.10.1

The second one is better (assuming that the gateway is really at 192.168.10.1) and I suggest that you remove the first one.

 

HTH

 

Rick

 

HTH

Rick

Thanks, that took care of the problem. I was lulled into thinking that the NAT took care of itself - why, I don't know. Steps taken:

1. Assigned nat inside and outside to the respective ports: Vlan10 and G0

2. Created ACL

3. Assigned ACL to Vlan10

 

Done

I am glad that my suggestions were helpful and that you now have it working. Thank you for marking this discussion as solved. This will help other readers in the forum to identify discussions which have helpful information.

 

HTH

 

Rick

HTH

Rick
Review Cisco Networking for a $25 gift card