cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
152
Views
0
Helpful
5
Replies
Beginner

pxe boot on a trunk port ?

Hello Guys,

 

 There’s anything special I need to do to get a bare-metal to pxe boot on a trunk port? I can’t get any machine to pxe boot, would appreciate your help if someone paste there configuration, although all server running flat vlan pxe boot fine with no issues. Thanks.

Hardware (Cisco N5K-C5596UP)

5 REPLIES 5
Highlighted
VIP Mentor

Re: pxe boot on a trunk port ?

Hi
all it needs on NX is the ip helper but its relay on NX
heres one of my PXE vlans , ips masked but the relay part is the PXE bit , thats all you setup on switch side


interface Vlan31
description xxxxxxxxxxxxx
no shutdown
no ip redirects
ip address 172.21.x.x/24
no ipv6 redirects
ip router eigrp 1
ip passive-interface eigrp 1
ip pim sparse-mode
hsrp 31
authentication text secret
preempt
priority 249
ip 172.21.x.x
ip dhcp relay address 172.21.x.x
ip dhcp relay address 172.21.x.x
ip dhcp relay address 172.21.x.x
ip dhcp relay address 172.21.x.x


Beginner

Re: pxe boot on a trunk port ?

Thanks for the reply but still not booting , I added---> ip dhcp relay address 10.200.210.4

Here's how my environment is setup

PXE server in trunk/port channel connected to a 5k and the client also is in trunk/port channel connected to the same 5k thanks all.

 

Server

interface Ethernet1/1
switchport mode trunk
switchport trunk native vlan 2610
channel-group 500 mode active

 

Client

interface Ethernet1/5
switchport mode trunk
switchport trunk native vlan 2610
channel-group 1 mode active

 

VIP Mentor

Re: pxe boot on a trunk port ?

Hi
Thats all that's required in terms of config on the Cisco side so the DHCP will need to be debugged or caught in a pcap as its trying to initiate the boot to see if the DHCP offers and request are going and coming through the vlan interface to get to the PXE server , the only job for the switch is to forward the replay form broadcast to uni cast into the next vlan to the specifically set PXE server
Beginner

Re: pxe boot on a trunk port ?

To me doesn't make sense why the client in flat vlan work but if I set the trunk don't work, I'm not an expert in Cisco but I think this configuration to pxe boot over the network should be something standard and simple to do, no one in this day's use DVDs or CDs to do install over the network. I'm referring  to data center. I will keep trying different configurations

VIP Mentor

Re: pxe boot on a trunk port ?

Hi

so it works on a flat network because its broadcasting , when you introduce another vlan a broadcast wont be sent through to prevent flooding by default , so the ip relay changes the broadcast to unicast packet and directs it specifically at the the PXE server IP address , thats how it connects

 

The fact you have done that config on switch side as its all that's required  and you know it works on flat vlan also rules out the server side , so the only part left to troubleshoot is whether the actual broadcast to unicast i happening as it crosses between vlans or if there is some irregular transfer of DHCP packets between source and destination when vlan is involved

 

Unfortunately the only way to check that is too see what is happening on the wire either by debug or by running a wire shark 

 

pxe should work fine on a trunk or an access port 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards