cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
221
Views
0
Helpful
2
Replies

QOS and Dual ISP link

nwekechampion
Level 3
Level 3

Hi all,

 

I am implementing a solution for a client that requires the use of two wan links, with the secondary one as backup and main as primary. I also need to implement QOS on 20mb link with 19 for data and 1mb for voice.

Please could anyone provide some help as to the best way to implement this?

 

Just finished my CCNA, but this is a bit out of my depth.

 

Thanks in advance.

2 Replies 2

Hello,

 

the solution depends on how you are connected to your ISPs: static routes, BGP, etc., do you (already) have that information ?

The QoS also depends on if you are using Cisco or non-Cisco IP phones, and on your platform (which router/switch)...post the 'show version' of the device.

HI George,

 

So sorry for my late reply.

The Primary link is going to go through PPPoE and the backup link via 4g.

I am trying to give voip priority queue at the egress port with 1mb and data lower priority with 19mb.

I have simulated two wan links in GNS3 to get this running. Please could you look at my config below and let me know how I can go about implementing this?

 

no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
ip dhcp excluded-address 10.0.0.1 10.0.0.10
!
ip dhcp pool LAN1
network 10.0.0.0 255.255.255.0
default-router 10.0.0.1
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
track 8 ip sla 1 reachability
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description Towards Customer LAN
ip address 10.0.0.1 255.255.255.0
ip nat inside
duplex full
!
interface POS1/0
description Primary Link to ISP1
ip address 200.55.60.2 255.255.255.0
ip nat outside
shutdown
!
interface FastEthernet2/0
no ip address
shutdown
duplex full
!
interface FastEthernet3/0
no ip address
shutdown
duplex full
!
interface POS4/0
description Backup Link to ISP2
ip address 201.55.60.2 255.255.255.252
ip nat outside
!
ip nat inside source route-map NAT_ISP1 interface POS1/0 overload
ip nat inside source route-map NAT_ISP2 interface POS4/0 overload
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 200.55.60.1 track 8
ip route 0.0.0.0 0.0.0.0 201.55.60.1 10
!
ip sla 1
icmp-echo 200.55.60.1 source-ip 200.55.60.2
ip sla schedule 1 life forever start-time now
access-list 101 permit ip 10.0.0.0 0.0.0.255 any
!
route-map NAT_ISP2 permit 10
match ip address 101
match interface POS4/0
!
route-map NAT_ISP1 permit 10
match ip address 101
match interface POS1/0
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end

 

Really looking forward to your reply.

Thanks again

Review Cisco Networking for a $25 gift card