01-10-2013 05:37 AM - edited 03-07-2019 11:01 AM
I created the configuration below to limit the bandwidth, but doesn't work, Could anyone help me ?
Qos - 3750
!
mls qos
mls qos map policed-dscp 10 to 8
!
class-map match-all Test
match access-group name ACL
!
policy-map QOS
description Limit 10M
set ip dscp af11
police 10000000 8192 exceed-action drop
!
ip access-list extended ACL
permit ip 10.112.11.0 0.0.0.127 host 10.112.0.55
permit ip 10.112.11.0 0.0.0.127 host 10.112.0.5
remark All traffic to SMS QoS Policy
remark -----------------------------------
!
interface GigabitEthernet1/0/48
mls qos trust dscp
service-policy input QOS
01-10-2013 06:06 AM
Hi,
It should be like this.
policy-map QOS
description Limit 10M
class TEST
set ip dscp af11
police 10000000 8192 exceed-action drop
01-10-2013 06:19 AM
Sorry, It was a fail in the my Copy/Paste. It has already in the configuration.
Correcting:
mls qos
mls qos map policed-dscp 10 to 8
!
class-map match-all Test
match access-group name ACL
!
policy-map QOS
description Limit 10M
class Test
set ip dscp af11
police 10000000 8192 exceed-action drop
!
ip access-list extended ACL
permit ip 10.112.11.0 0.0.0.127 host 10.112.0.55
permit ip 10.112.11.0 0.0.0.127 host 10.112.0.5
remark All traffic to SMS QoS Policy
remark -----------------------------------
!
interface GigabitEthernet1/0/48
mls qos trust dscp
service-policy input QOS
01-10-2013 06:47 AM
Hi,
remove the set ip dscp af11 and try.
01-10-2013 07:08 AM
Can you post the output of show policy-map interface gig1/0/48
01-10-2013 07:11 AM
GigabitEthernet1/0/48 (All statistics are in packets)
dscp: incoming
-------------------------------
0 - 4 : 2139799416 6760 3821267 597 23962222
5 - 9 : 0 1 0 0 0
10 - 14 : 389453 0 0 0 0
15 - 19 : 0 0 0 298277503 0
20 - 24 : 1082 0 0 0 53504963
25 - 29 : 0 791701 0 0 0
30 - 34 : 0 0 0 0 256
35 - 39 : 0 0 0 0 0
40 - 44 : 0 0 0 0 0
45 - 49 : 0 280919783 0 16939789 0
50 - 54 : 0 0 0 0 3
55 - 59 : 0 53030 0 0 0
60 - 64 : 0 0 0 0
dscp: outgoing
-------------------------------
0 - 4 : 2527356267 437 0 97 0
5 - 9 : 0 0 0 0 0
10 - 14 : 0 0 0 0 0
15 - 19 : 0 0 0 0 0
20 - 24 : 0 0 0 0 87594795
25 - 29 : 0 41434 0 0 0
30 - 34 : 0 0 18365688 0 0
35 - 39 : 0 0 0 0 0
40 - 44 : 13456011 0 0 0 0
45 - 49 : 0 307564669 0 17077336 0
50 - 54 : 0 0 0 0 0
55 - 59 : 0 0 0 0 0
60 - 64 : 0 0 0 0
cos: incoming
-------------------------------
0 - 4 : 2820303428 0 0 0 0
5 - 7 : 0 0 0
cos: outgoing
-------------------------------
0 - 4 : 2605164848 0 0 85068985 0
5 - 7 : 264277252 16952450 3
output queues enqueued:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 140557 0 0
queue 1: 321476578 47423233 60760425
queue 2: 0 0 0
queue 3: 278235 0 2606776078
output queues dropped:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 0 0 0
queue 1: 134617 210 0
queue 2: 0 0 0
queue 3: 0 0 17838
Policer: Inprofile: 0 OutofProfile: 0
01-10-2013 07:36 AM
Apparently show policy-map interface on a 3750 switch is not the same output as on a router. The reason for this is the packets are hardware switched.
Regarding your statistics I guess that maybe your acl is not correct.
If possible can you change
class-map match-all Test
match any
or at least verify the acl?
How are you testing btw? from? to?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide