02-10-2012 07:03 AM - edited 03-07-2019 04:51 AM
Hey guys, quick EIGRP question for ya. I am still brushing up on my EIGRP so my appologies if this is just a common sense question.
I have a hub and spoke network with DMVPN connectivity with 2 hubs (Hub A and Hub B) and approx. 60 spokes.
Each of these spokes only connects to Hub A (for now) via their local Tunnel0 interface however I have 1 spoke (Spoke X) which also connects to Hub B (simultaneously) over it's local Tunnel1 interface.
At the data center, Hub A and Hub B, each having it's own public interface, also connect to each other via a common switch (for failover reasons).
Hub B knows all of its routes to the spokes via Hub A i.e. through Hub B's interface (GigE0/2) connecting to the switch.
However there are 4-5 spoke routes it is learning via Spoke X since X connects to Hub B (as explained above).
How can I fix this without having to put a static route statement in Hub B to point it to GigE0/2 for those spokes?
Thanks in advance
Solved! Go to Solution.
02-10-2012 07:30 AM
if any routes are learned via spoke. you can configure the spoke as a "STUB NETWORK" so that it does not form a transit path for any of the routes.
-Vijay
02-10-2012 07:18 AM
Hi Ricky,
If I understood well you have 59 spokes connected to HUBA and 1 spoke connected to HUBA and HUBB
If this issue apears only to some spokes, I belive that you have some filtering in place on HubA to HubB or on B from A, or
some summarization of those spokes on HubA on the interface to Hub B or some metric offset set for this spokes.
Can you post "show ip eigrp topology SPOKE_LEARND_VIA_SPOKE_X" on HubB.
Also it would be helpfull to the the eigrp config of the Hubs with interface between the hubs config
Dan
02-10-2012 07:51 AM
Hi Dan, here you. Please let me know if you need more information. I just took over this position from a previous network engineer that left the company. Just tring to clean up the mess
______________________________________________________________________________
***HUB B IP route statement for INCORRECTLY learned route and the EIGRP top***
______________________________________________________________________________
HUB-B#sh ip route 172.18.2.1
Routing entry for 172.18.2.0/24
Known via "eigrp 1", distance 90, metric 17920256, type internal
Redistributing via nhrp, eigrp 1
Last update from 10.10.201.27 on Tunnel0, 11:30:06 ago
Routing Descriptor Blocks:
* 10.10.201.27, from 10.10.201.27, 11:30:06 ago, via Tunnel0
Route metric is 17920256, traffic share count is 1
Total delay is 600010 microseconds, minimum bandwidth is 1000 Kbit
Reliability 255/255, minimum MTU 1400 bytes
Loading 255/255, Hops 3
HUB-B#sh ip eigrp topology 172.18.2.0/24
EIGRP-IPv4 Topology Entry for AS(1)/ID(1.1.1.2) for 172.18.2.0/24
State is Passive, Query origin flag is 1, 4 Successor(s), FD is 17920256
Descriptor Blocks:
10.10.201.27 (Tunnel0), from 10.10.201.27, Send flag is 0x0
Composite metric is (17920256/15360256), route is Internal
Vector metric:
Minimum bandwidth is 1000 Kbit
Total delay is 600010 microseconds
Reliability is 255/255
Load is 255/255
Minimum MTU is 1400
Hop count is 3
!
!
!
!
!
______________________________________________________________________________
***HUB B IP route statement for a CORRECTLY learned route***
______________________________________________________________________________
HUB-B#sh ip route 172.18.24.1
Routing entry for 172.18.24.0/24
Known via "eigrp 1", distance 90, metric 2560512, type internal
Redistributing via nhrp, eigrp 1
Last update from 172.18.123.2 on GigabitEthernet0/2, 11:29:42 ago
Routing Descriptor Blocks:
* 172.18.123.2, from 172.18.123.2, 11:29:42 ago, via GigabitEthernet0/2
Route metric is 2560512, traffic share count is 1
Total delay is 50020 microseconds, minimum bandwidth is 2000 Kbit
Reliability 255/255, minimum MTU 1400 bytes
Loading 255/255, Hops 2
!
!
!
!
!
________________________________________
***HUB B EIGRP Config snippet***
________________________________________
!
interface Tunnel0
bandwidth 1000
ip address 10.10.201.1 255.255.255.0
no ip redirects
ip accounting output-packets
ip mtu 1400
no ip next-hop-self eigrp 1
ip nhrp authentication Trow!
ip nhrp map multicast dynamic
ip nhrp network-id 201
ip nhrp holdtime 600
no ip split-horizon eigrp 1
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 201
tunnel protection ipsec profile profile1
!
!
interface Tunnel2
ip address 10.10.202.1 255.255.255.0
no ip redirects
ip mtu 1400
no ip next-hop-self eigrp 1
ip nhrp authentication Trow!
ip nhrp map multicast dynamic
ip nhrp network-id 202
ip nhrp holdtime 600
ip nhrp registration no-unique
no ip split-horizon eigrp 1
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 202
tunnel protection ipsec profile profile2
!
!
interface GigabitEthernet0/0
description OUTSIDE
ip address ***.***.***.*** 255.255.255.240
ip access-group BLOCK in
no ip route-cache cef
no ip route-cache
duplex auto
speed auto
!
interface GigabitEthernet0/2
description Switch-G2/0/24
ip address 172.18.123.3 255.255.255.0
duplex auto
speed auto
standby 123 ip 172.18.123.1
standby 123 priority 90
!
!
!
router eigrp 1
network 1.1.1.2 0.0.0.0
network 10.10.201.0 0.0.0.255
network 10.10.202.0 0.0.0.255
network 172.18.123.0 0.0.0.255
redistribute static route-map STATIC-TO-EIGRP
!
ip forward-protocol nd
!
ip route 0.0.0.0 0.0.0.0 ***.***.***.***
ip route 172.18.120.0 255.255.255.0 172.18.123.250
ip route 172.18.121.0 255.255.255.0 172.18.123.250
ip route 172.18.122.0 255.255.255.0 172.18.123.250
!
ip access-list standard STATIC-TO-EIGRP
permit 172.18.120.0 0.0.0.255
permit 172.18.121.0 0.0.0.255
permit 172.18.122.0 0.0.0.255
!
access-list 23 permit 172.18.0.0 0.0.255.255
!
!
!
!
route-map STATIC-TO-EIGRP permit 10
match ip address STATIC-TO-EIGRP
!
!
!
!
!
!
________________________________________
***HUB A EIGRP Config snippet***
________________________________________
interface Tunnel0
bandwidth 2000
ip address 10.10.200.1 255.255.255.0
no ip redirects
ip accounting output-packets
ip mtu 1400
no ip next-hop-self eigrp 1
ip nhrp authentication Trow!
ip nhrp map multicast dynamic
ip nhrp network-id 200
ip nhrp holdtime 600
no ip split-horizon eigrp 1
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 200
tunnel protection ipsec profile Profile1
!
!
interface GigabitEthernet0/0
description OUTSIDE
ip address ***.***.***.*** 255.255.255.240
ip access-group BLOCK in
duplex auto
speed auto
!
!
interface GigabitEthernet0/1
description int
no ip address
shutdown
duplex auto
speed auto
!
!
interface GigabitEthernet0/2
description Switch-G1/0/24
ip address 172.18.123.2 255.255.255.0
duplex auto
speed auto
standby 123 ip 172.18.123.1
standby 123 priority 110
standby 123 preempt
standby 123 track 1 decrement 30
!
!
!
router eigrp 1
network 1.1.1.1 0.0.0.0
network 10.10.200.0 0.0.0.255
network 172.18.123.0 0.0.0.255
redistribute static route-map STATIC-TO-EIGRP
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 ***.***.***.***
ip route 10.0.10.0 255.255.255.0 172.18.123.250
ip route 10.10.5.0 255.255.255.0 172.18.123.250
ip route 10.102.154.0 255.255.255.0 172.18.123.250
ip route 172.18.0.0 255.255.255.0 172.18.123.250
ip route 172.18.4.0 255.255.255.0 172.18.23.250
ip route 172.18.10.0 255.255.255.0 10.10.200.19
ip route 172.18.11.0 255.255.255.0 172.18.123.250
ip route 172.18.70.0 255.255.255.0 172.18.123.250
ip route 172.18.120.0 255.255.255.0 172.18.123.250
ip route 172.18.121.0 255.255.255.0 172.18.123.250
ip route 172.18.122.0 255.255.255.0 172.18.123.250
ip route 172.18.168.0 255.255.255.0 172.18.123.250
ip route 192.168.2.0 255.255.255.0 172.18.123.250
ip route 192.168.220.0 255.255.255.0 172.18.123.4
ip route 192.168.254.0 255.255.255.0 172.18.123.250
!
ip access-list standard STATIC-TO-EIGRP
permit 172.18.120.0 0.0.0.255
permit 172.18.121.0 0.0.0.255
permit 172.18.122.0 0.0.0.255
permit 172.18.11.0 0.0.0.255
permit 10.102.154.0 0.0.0.255
permit 10.120.120.0 0.0.0.255
permit 192.168.254.0 0.0.0.255
permit 10.10.5.0 0.0.0.255
!
access-list 5 permit 172.18.120.0 0.0.0.255
access-list 23 permit 172.18.0.0 0.0.255.255
!
!
!
!
route-map STATIC-TO-EIGRP permit 10
match ip address STATIC-TO-EIGRP
!
02-10-2012 07:30 AM
if any routes are learned via spoke. you can configure the spoke as a "STUB NETWORK" so that it does not form a transit path for any of the routes.
-Vijay
02-10-2012 07:45 AM
Yes this is a very nice solution,Vijay
But if there is any fitering between A and B won't solve it.
Dan
02-10-2012 07:55 AM
Hi Vijay, if I add the Eigrp Stub command in the EIGRP portion of the config on a live router, that would've cause a connection drop would it?
02-10-2012 08:25 AM
Yes. When you configure the spoke as STUB, then the neighborship goes down and comes back..
If you dont want the neighborship, then we can filter the route using prefix list ..
May be Experts would have some more thoughts as I'm still learning ....
-Vijay.
02-10-2012 08:51 AM
Thanks Vijay. EIGRP Stub command seemed to have fixed the issue.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide