cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
734
Views
0
Helpful
5
Replies

Recommended IOS for update various switchs

martin.germano
Beginner
Beginner

Hi, i need to upgrade IOS for some switchs. So I need recomendations for IOS versions. Which one do you think that have less bug or are estable?

Cisco Catalyst 2960-24TT-L Switch

Cisco Catalyst 2960G-24TC-L Switch

Cisco Catalyst 3560G-24TS Switch

For example

In this post https://supportforums.cisco.com/message/4107813#4107813 Leo Laohoo recomended me 12.2(55)SE8 or 15.0(2)SE4 for 2960S-24TS-S.

I'm new in these things. It will help me a lot.

Thanks a lot

3 Accepted Solutions

Accepted Solutions

Marvin Rhoads
VIP Community Legend VIP Community Legend
VIP Community Legend

Leo's advice re the versions is good. 12.2(55)SE8 is a very solid release. 15.0(2)SE5 is out now so that offers a few more bug fixes.

If you don't need any of the features offered in 15.x, then the 12.2 train is a safer bet. Some older switches will not have 15.x versions developed and likewise some of the very newest switches will not have 12.x versions available.

To check which one applies to a specific switch, so to the model's software download page (i.e start here for Campus Access switches) and see which IOS is available for it. In your case it looks like all of the three models have the choice:

SwitchIOS

2960-24TT-L

either 12.2(55)SE8 or 15.0(2)SE5

2960G-24TC-L

either 12.2(55)SE8 or 15.0(2)SE5

3560G-24TS

either 12.2(55)SE8 or 15.0(2)SE5

Hope this helps.

View solution in original post

The "WITH WEB DEV" versions include the on-switch stand alone web server files. With that version, you can log into the switch with a browser and use the GUI for some basic tasks and status checks.

It's not necessary for either cli or Cisco Network Assistant (CNA) access. CNA does require the ip http server (or preferably secure-server) be active (i.e. configuration file line that turns on the service) as it communicates to the switch using that service. CNA does not require the full on-switch web server GUI that you get with the WEB DEV image.

View solution in original post

15.0(2)SE5 is a version I would NOT recommend.

I rolled back my test appliance from 15.0(2)SE5 to 15.0(2)SE4 after I saw a few Tracebacks materializing. 15.2(1)E or 15.2(1)E1 is no good either. So far, 12.2(55)SE8 is still my recommendation for the most stable IOS version and15.0(2)SE4 is close second.

Sent from Cisco Technical Support Nintendo App

View solution in original post

5 Replies 5

Marvin Rhoads
VIP Community Legend VIP Community Legend
VIP Community Legend

Leo's advice re the versions is good. 12.2(55)SE8 is a very solid release. 15.0(2)SE5 is out now so that offers a few more bug fixes.

If you don't need any of the features offered in 15.x, then the 12.2 train is a safer bet. Some older switches will not have 15.x versions developed and likewise some of the very newest switches will not have 12.x versions available.

To check which one applies to a specific switch, so to the model's software download page (i.e start here for Campus Access switches) and see which IOS is available for it. In your case it looks like all of the three models have the choice:

SwitchIOS

2960-24TT-L

either 12.2(55)SE8 or 15.0(2)SE5

2960G-24TC-L

either 12.2(55)SE8 or 15.0(2)SE5

3560G-24TS

either 12.2(55)SE8 or 15.0(2)SE5

Hope this helps.

Hi Marvin, thanks for helping.

I checked the 15.0(2)SE5 bug fixes. Maybe the best choice is the 12.2(55)SE8.

The last question : What is the diference of LAN BASE and LAN BASE WITH WEB DEV? I would like to use cli and CNA administration.

Thanks.

.

The "WITH WEB DEV" versions include the on-switch stand alone web server files. With that version, you can log into the switch with a browser and use the GUI for some basic tasks and status checks.

It's not necessary for either cli or Cisco Network Assistant (CNA) access. CNA does require the ip http server (or preferably secure-server) be active (i.e. configuration file line that turns on the service) as it communicates to the switch using that service. CNA does not require the full on-switch web server GUI that you get with the WEB DEV image.

Just in case i'll upgrade to "WITH WEB DEV" file.

Thanks again!

15.0(2)SE5 is a version I would NOT recommend.

I rolled back my test appliance from 15.0(2)SE5 to 15.0(2)SE4 after I saw a few Tracebacks materializing. 15.2(1)E or 15.2(1)E1 is no good either. So far, 12.2(55)SE8 is still my recommendation for the most stable IOS version and15.0(2)SE4 is close second.

Sent from Cisco Technical Support Nintendo App

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers