08-03-2017 07:10 PM - edited 03-08-2019 11:36 AM
Hi All,
I am trying to redistribute specific BGP and connected routes into EIGRP using route-map however it does not work. When I try to simply redistribute all BGP routes without any route-map then everything works fine.
The config of the device is as below:
R27(config-route-map)#do sho run | s router
router eigrp 1
redistribute bgp 300 route-map REDISTRIBUTE_TEN_ROUTE_MAP
passive-interface default
no passive-interface FastEthernet0/1
network 0.0.0.0
default-metric 100000 500 255 1 1500
auto-summary
router bgp 300
no synchronization
bgp log-neighbor-changes
bgp redistribute-internal
network 10.0.27.0
network 10.0.27.0 mask 255.255.255.0
network 10.0.73.0
network 10.0.73.0 mask 255.255.255.0
network 10.0.75.0
network 10.0.75.0 mask 255.255.255.0
neighbor 10.0.26.26 remote-as 300
neighbor 10.0.26.26 update-source Loopback0
neighbor 10.0.28.28 remote-as 300
neighbor 10.0.28.28 update-source Loopback0
neighbor 10.0.29.29 remote-as 300
neighbor 10.0.29.29 update-source Loopback0
ip prefix-list REDISTRIBUTE_TEN_NETWORK seq 5 permit 10.25.25.0/24
ip prefix-list REDISTRIBUTE_TEN_NETWORK seq 10 permit 10.0.26.0/24
ip prefix-list REDISTRIBUTE_TEN_NETWORK seq 15 permit 10.0.28.0/24
ip prefix-list REDISTRIBUTE_TEN_NETWORK seq 20 permit 10.0.29.0/24
ip prefix-list REDISTRIBUTE_TEN_NETWORK seq 25 permit 10.0.64.0/24
ip prefix-list REDISTRIBUTE_TEN_NETWORK seq 30 permit 10.0.65.0/24
ip prefix-list REDISTRIBUTE_TEN_NETWORK seq 35 permit 10.0.93.0/24
ip prefix-list REDISTRIBUTE_TEN_NETWORK seq 40 permit 10.0.81.0/24
ip prefix-list REDISTRIBUTE_TEN_NETWORK seq 45 permit 10.0.85.0/24
ip prefix-list REDISTRIBUTE_TEN_NETWORK seq 50 permit 10.0.195.0/24
access-list 10 permit 10.25.25.0 0.0.0.255
access-list 10 permit 10.0.26.0 0.0.0.255
access-list 10 permit 10.0.28.0 0.0.0.255
access-list 10 permit 10.0.29.0 0.0.0.255
access-list 10 permit 10.0.64.0 0.0.0.255
access-list 10 permit 10.0.65.0 0.0.0.255
access-list 10 permit 10.0.93.0 0.0.0.255
access-list 10 permit 10.0.81.0 0.0.0.255
access-list 10 permit 10.0.85.0 0.0.0.255
access-list 10 permit 10.0.195.0 0.0.0.255
no cdp log mismatch duplex
!
!
!
route-map REDISTRIBUTE_TEN_ROUTE_MAP permit 10
match ip address 10
I have tried changing the route-map from prefix-list to ACL but no change.
08-04-2017 04:52 AM
Are you trying to make this work in gns3 or real gear? did you try adding eigrp metrics? that's a must
08-04-2017 11:08 AM
Hi
Your config looks fine, are you able to see the subnets related to the ACL 10/Prefix-list into the BGP table? Show ip bgp
Also try instead the default metric:
router eigrp 1
redistribute bgp 300 route-map REDISTRIBUTE_TEN_ROUTE_MAP metric 100000 500 255 1 1500
08-04-2017 11:08 AM
I tried this in GNS3 using c7200 IOS 15.1 and it doesn't work. There is no issue with the config and for some reason in GNS3 it's not supported as far as 15.1 is concerned. I haven't tried with code 12 in GNS.
Same configuration works perfectly in Cisco virl. But you will just need to add eigrp metrics as Julio and myself stated.
08-04-2017 03:25 PM
My first attempt was with the metric then after that I tried the default metric thing.
The prefix-list/ACL has routes that is a combination of connected and BGP routes present in the routing table.
I also tried using only BGP routes in ACL/prefix-list but that did not help either.
08-04-2017 05:28 PM
I think cofee@0400 already made some tests under GNS3 and it was not working, it looks like a bug on that emulation platform. Your config should work fine.
Now if it is an iBGP router, you could try to configure under BGP the following command:
router bgp X
bgp redistribute-internal
08-05-2017 12:13 AM
Hello
Disable network summarization in Eigrp.
router eigrp 1
no auto-summary
res
Paul
08-04-2017 03:22 PM
I am using GNS3 and yeah already tried the EIGRP metric
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide