05-13-2011 11:15 PM - edited 03-06-2019 05:03 PM
Dear Gurus,
I have one cisco catalyst 3560 switch. I configured 5 vlans in the switch.
All vlans are communicating fine. Here i like to use one DHCP server.
I placed my DHCP(windows 2008) server in vlan-1 and all my hosts are placed in different vlans.
If all my hosts are trying to get ip address from DHCP servers, but they are unable to get it.
Hosts in vlan-1 are getting dhcp ip address from DHCP server.
For doing basic trouble shooting, i assingned static ip to the hosts in different vlan. then host is communicating to the DHCP sever.
Will you post me configuration for this scenario.
And also i am sending configuration for your reference:
10.91.89.10-----> is the DHCP server IP
Current configuration : 3352 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname CISCO-3750
!
enable password nipun
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
ip routing
!
ip dhcp-server 10.91.89.10
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
!
interface GigabitEthernet0/13
description Connectivity to MANAGEMENT vlan
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/14
description Connectivity to MANAGEMENT vlan
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/15
description Connectivity to CAD vlan
switchport access vlan 11
switchport mode access
!
interface GigabitEthernet0/16
description Connectivity to CAD vlan
switchport access vlan 11
switchport mode access
!
interface GigabitEthernet0/17
description Connectivity to GAS vlan
switchport access vlan 12
switchport mode access
!
interface GigabitEthernet0/18
description Connectivity to GAS vlan
switchport access vlan 12
switchport mode access
!
interface GigabitEthernet0/19
description Connectivity to ACCOUNTS/HR vlan
switchport access vlan 13
switchport mode access
!
interface GigabitEthernet0/20
description Connectivity to ACCOUNTS/HR vlan
switchport access vlan 13
switchport mode access
!
interface GigabitEthernet0/21
description Connectivity to WI-FI vlan
switchport access vlan 14
switchport mode access
!
interface GigabitEthernet0/22
description Connectivity to WI-FI vlan
switchport access vlan 14
switchport mode access
!
interface GigabitEthernet0/23
description Conncetivity to Virtual Machine Vlan
switchport access vlan 15
switchport mode access
!
interface GigabitEthernet0/24
description Conncetivity to Virtual Machine Vlan
switchport access vlan 15
switchport mode access
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface Vlan1
ip address 10.91.89.5 255.255.255.0
!
interface Vlan10
description MANAGEMENT vlan interface
ip address 10.91.90.1 255.255.255.0
ip helper-address 10.91.89.10
!
interface Vlan11
description CAD vlan interface
ip address 10.91.91.1 255.255.255.0
ip helper-address 10.91.89.10
!
interface Vlan12
description GAS vlan interface
ip address 10.91.92.1 255.255.255.0
!
interface Vlan13
description ACCOUNTS/HR vlan interface
ip address 10.91.93.1 255.255.255.0
ip helper-address 10.91.89.10
!
interface Vlan14
description WI-FI vlan interface
ip address 10.91.94.1 255.255.255.0
!
interface Vlan15
description Virtual Machines vlan interface
ip address 192.168.3.1 255.255.255.0
!
ip default-gateway 10.91.89.4
ip classless
ip route 0.0.0.0 0.0.0.0 10.91.89.4
ip route 0.0.0.0 0.0.0.0 Vlan1
ip http server
!
!
control-plane
!
!
line con 0
password nipun
line vty 0 4
password nipun
login
line vty 5 15
login
!
end
Looking for your help.....
Regards,
Janardhan
05-13-2011 11:38 PM
Hi,
Could you try again on a machine in Vlan 11 or Vlan 13 while sniffing the interface and post the pcap file and also take a look at the logs on your server.
Regards.
Alain.
05-13-2011 11:46 PM
Hi Alain,
Thanks for your prompt reply.....
How to get pcap file????? Because i dont know.
Regards,
Janardhan
On Sat, May 14, 2011 at 12:08 PM, cadetalain <
05-14-2011 12:42 AM
ok so the host is a windows machine I suppose?
just install wireshark and then sniff the correct interface( the one configured for dhcp) and then save the capture as a pcap file and post it here.
Regards.
Alain.
05-14-2011 01:21 AM
Hi Alain,
Currently i am in my office.. I will update you once i went to the client
location.
Will you post me the configuration as per my scenario. Meanwhile i will
cross check it once...
Regards,
Janardhan
On Sat, May 14, 2011 at 1:12 PM, cadetalain <
05-14-2011 01:49 AM
Your config looks good as you have ip helper-address on SVI interfaces of VLANs outside DHCP server subnet.
Are there switches in between or firewalls?
Regards.
Alain.
05-14-2011 02:01 AM
05-14-2011 02:22 AM
05-14-2011 03:19 AM
Where is your 2008 box there?
Regards.
Alain.
05-14-2011 04:03 AM
Hi Alain,
It is in vlan-1 and connected port which is belongs to vlan 1.
Reggards,
Janardhan
On Sat, May 14, 2011 at 3:50 PM, cadetalain <
05-14-2011 04:45 AM
Hi,
Where is the gateway configured on Windows 2008? CoreSwitch or ASA?
Edit: Try "debug ip udp" to see the packets forwarded to the server or not.
Toshi
05-15-2011 12:16 AM
HI Toshi,
Default-gateway of windows 2008 box is core switch( catalyst 3560) vlan-1
ip.
i dont have confusion regarding inter vlan routing because all my devices
are communicating if i assigned static lps.
Regards,
Janardhan
On Sat, May 14, 2011 at 5:15 PM, thotsaphon <
05-15-2011 02:18 AM
Hi,
Switch:
When clients are trying to get IP addresses from DHCP server. Please do "debug ip udp" on C3560 and post the output here.
DHCP Server:
Please turn off the personal firewall on the server,including firewall services on Windows server for testing.
Are you sure that you correctly configured dhcp scopes for vlan10 , vlan11 and vlan13 and they are already activated? Please capture the screen and post it here.
HTH,
Toshi
05-13-2011 11:43 PM
Hi Janardhan,
You have to verify things as follows:
1. Make sure that you already configured the dhcp pools for vlan10 , vlan11 and vlan13 on Windows 2008 server. And they are already activated. Just check it.
2. Please do the following steps on your switch.
switch(conf)#service dhcp
switch(conf)#no ip dhcp-server 10.91.89.10 , no need if you only want to do dhcp-relay
switch(conf)#no ip default-gateway 10.91.89.4 , no need if you already enabled "ip routing".
HTH,
Toshi
05-13-2011 11:59 PM
Hi Toshi,
switch(conf)#service dhcp
This is enabled by default and didn't see the no service dhcp in the posted running
no ip default-gateway 10.91.89.4 , no need if you already enabled "ip routing".
you're right it is not needed but it isn't used anyway and it surely is not the cause of the problem
Regards.
Alain.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide