cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
413
Views
13
Helpful
6
Replies
Shahzaib Khan
Beginner

Regarding Ether channel

Hi Friends,

I have some basic knowledge of making switch ports as 1 ethere channel. I just want to know something.

I have 4 cisco 2960 switches to which many users are connected. No vlans are the only default vlan 1 is there. Now I want to make ether channel on switch 1 whcih has 24 fast etherenet ports. Can I make port 1- 8 as one ether channel which are connected to users or i can only make ethere channel

of ports that are connectd to other switchs. If I can, how the other switchs will comnicate with the switch ports bundalled in the ether channel in switch 1. Please help me out.. Thanksss in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
Harish Balakrishnan
Enthusiast

Hello Shahzaib,

You can not make the port connected to normal PC user as ether channel ( Some storage/server supports ) and in your scenario you can only make etherchannel between your switches.

Once the ether channel is made, there will be another interface created called port-channel that will be having same properties like  access/trunk based on your configuration

Since you have to create the channel on both switches, they can identify the etherchannel and communicate each oher

Hope this helps

Haris

Please rate all helpful post!.

View solution in original post

6 REPLIES 6
Harish Balakrishnan
Enthusiast

Hello Shahzaib,

You can not make the port connected to normal PC user as ether channel ( Some storage/server supports ) and in your scenario you can only make etherchannel between your switches.

Once the ether channel is made, there will be another interface created called port-channel that will be having same properties like  access/trunk based on your configuration

Since you have to create the channel on both switches, they can identify the etherchannel and communicate each oher

Hope this helps

Haris

Please rate all helpful post!.

View solution in original post

Sandeep Choudhary
VIP Mentor

HI Shahzaib,

EtherChannel is a technology-leveraging,  standards-based Fast Ethernet used in parallel to provide the additional  bandwidth network backbones require today. It provides flexible,  scalable bandwidth with resiliency and load sharing across links for  switches, router interfaces and servers. Supports up to eight links per  channel.

You can take 8 ports, which are free.

for wt purpose you are creating Etherchannel:

see port channel and port  configration:

Switch# configure terminal 

Switch(config)# interface range gigabitethernet0/4 -5 

Switch(config-if-range)# switchport mode access

Switch(config-if-range)# switchport access vlan 10

Switch(config-if-range)# channel-group 5 mode desirable 

Switch(config-if-range)# end 

Switch# configure terminal 

Switch(config)# interface port-channel 5

Switch(config-if)# no switchport

Switch(config-if)# ip address 172.10.20.10 255.255.255.0

Switch(config-if)# end 

Regards

Please rate if it helps.

Hello Sandeep,

your configuration example is wrong you have mixed the configuration of a L2 port channel using PAGP, and the configuration of a OSI L3 port channel.

when configuring a L3 port channel member ports are configured with

no switchport

no ip address

for switch to switch bundles a L2 port channel is more appropriate

the use of LACP is recommmended ( channel-group X mode active)

Hope to help

Giuseppe

Hi Giuseppe,

Thanks for correcting me.

U deserved +5 points.

just check this, is it ok or :

interface Port-channel1

description *vvvvvvv*

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet2/0/1

Switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

ip dhcp snooping trust

!

interface GigabitEthernet2/0/2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

i hope this is ok.??

Thanks again

Hello Sandeep,

the port-channel interface is not configured manually, it is created by the switch automatically after having put the channel-group 1 mode active on member links.

A part from this the configuration is fine for a L2 port channel except for that ip dhcp snooping trust on one member link. gi2/0/1. member links need to be identical in configuration.

Later all changes to the list of permitted vlans for example are made on port channel interface

Hope to help

Giuseppe

Shahzaib Khan
Beginner

@ harish and sandeep...

Thank you very much for your help. so now i will make etherchannel between switches.. Thanks again both of you.