cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2590
Views
8
Helpful
2
Replies

Route Map - match & set

Hello All

I have a problem with understanding the below:

router eigrp 503

redistribute connected route-map connected-into-eigrp

redistribute static metric 1000000 50 255 1 1500 route-map static-into-eigrp

redistribute rip metric 1000000 50 255 1 1500 route-map RIP-TO-EIGRP

network 10.52.54.68 0.0.0.3

network 10.63.206.128 0.0.0.15

no auto-summary

!

router rip

version 2

redistribute eigrp 503 metric 4 route-map EIGRP-TO-RIP

passive-interface FastEthernet0/0/1

network 10.0.0.0

no auto-summary

!

ip access-list standard STATIBRIS-INTO-EIGRP

ip access-list standard connected-into-eigrp-deny

permit 192.168.1.96 0.0.0.31

ip access-list standard connected-into-eigrp-permit

permit 10.63.206.128 0.0.0.15

permit 10.52.54.68 0.0.0.3

ip access-list standard snmp-access

permit 198.142.244.0 0.0.0.255

permit 172.25.19.0 0.0.0.255

permit 203.202.141.0 0.0.0.63

permit 203.13.116.0 0.0.0.255

permit 161.43.223.0 0.0.0.127

ip access-list standard static-into-eigrp-permit

permit 10.52.48.0 0.0.3.255

permit 10.52.52.0 0.0.1.255

permit 10.52.55.0 0.0.0.255

permit 10.52.56.0 0.0.1.255

permit 10.52.58.0 0.0.0.255

permit 10.50.96.0 0.0.0.255

permit 10.52.54.0 0.0.0.31

permit 10.52.54.32 0.0.0.31

permit 10.50.64.0 0.0.0.63

permit 10.52.54.96 0.0.0.31

permit 10.50.104.128 0.0.0.127

ip access-list standard telnet-access

permit 198.142.244.0 0.0.0.255

permit 172.25.19.0 0.0.0.255

permit 10.63.206.128 0.0.0.15

!

access-list 1 permit 10.52.48.0 0.0.3.255

access-list 1 permit 10.52.52.0 0.0.1.255

access-list 1 permit 10.52.55.0 0.0.0.255

access-list 1 permit 10.52.56.0 0.0.1.255

access-list 1 permit 10.52.58.0 0.0.0.255

access-list 1 permit 10.50.96.0 0.0.0.255

access-list 1 permit 10.52.54.0 0.0.0.31

access-list 1 permit 10.52.54.32 0.0.0.31

access-list 1 permit 10.50.64.0 0.0.0.63

access-list 1 permit 10.52.54.96 0.0.0.31

access-list 1 permit 10.52.54.68 0.0.0.3

route-map connected-into-eigrp deny 10

match ip address connected-into-eigrp-deny

!

route-map connected-into-eigrp permit 100

match ip address connected-into-eigrp-permit

!

route-map EIGRP-TO-RIP deny 30

match tag 40

!

route-map EIGRP-TO-RIP permit 40

set tag 60

!

route-map RIP-TO-EIGRP deny 70

match tag 60

!

route-map RIP-TO-EIGRP permit 80

set tag 40

!

route-map static-into-eigrp permit 10

match ip address static-into-eigrp-permit

!

route-map static-into-eigrp deny 20

can someone pls explain wat is the purpose of the match & set used for the route maps? just seems so vague

thx in advance

2 Replies 2

John Blakley
VIP Alumni
VIP Alumni

According to your "route-map EIGRP-TO-RIP deny 30" clause, you're matching the tag of 40 and denying those routes from being redistributed. The tag of 40 is set somewhere else in the same manner as your RIP-TO-EIGRP route-map.  The line "redistribute eigrp 503 metric 4 route-map EIGRP-TO-RIP" under your RIP process says to redistribute eigrp process 503, but only those routes that match the route-map that you're calling. From earlier, the route map that's being used will deny routes matching tag40, and for those that don't match 40 will go to the next clause. The next clause "permit 40" sets the tag to 60. So for the routes that do get redistributed, you're setting a tag of 60 that will later be matched somewhere else.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***

bonillajose
Level 1
Level 1

Hello,

Divide and conquer is better, so I will start with your EIGRP process.


router eigrp 503
redistribute static metric 1000000 50 255 1 1500 route-map static-into-eigrp (1*)
redistribute rip metric 1000000 50 255 1 1500 route-map RIP-TO-EIGRP (2*)

(1*)
Here you are filtering which static routes from you router will get advertised from EIGRP. Routes prefixes that match the access list will be advertised post redistribution. Anything else, meaning no other static routes, will not be advertised by EIGRP post redistribution.

route-map static-into-eigrp permit 10
match ip address static-into-eigrp-permit
!
route-map static-into-eigrp deny 20

(2*)
Here you are filtering routes that come from RIP into EIGRP, in especial you are looking for a tag # 60 possibly marked by a previous redistribution process in your router or any other router in the network, what you want to do with it is avoid advertising those networks into EIGRP. But any other routes with no tag or with a tag different than 60 gets re-tagged with #40 and is advertised to the network by EIGRP post redistribution.

Keep in mind this from now on, any route with a tag of 40 means to you router, that it was learned by EIGRP through RIP.
!
route-map RIP-TO-EIGRP deny 70
match tag 60
!
route-map RIP-TO-EIGRP permit 80
set tag 40

==================================================================================================================

Now lets move to RIP.

router rip
version 2
redistribute eigrp 503 metric 4 route-map EIGRP-TO-RIP (3*)


(3*)
Here you are filtering all routes that come from EIGRP with a previously marked tag of 40. Guess what, you are avoiding that RIP learn from EIGRP what it already knows. Remember what I told you to keep in mind before.

Then all other routes with no tag or tag different than 40 are unknown for RIP so you want those to be learn and advertised by it, but you want to prevent those to be sent back to EIGRP because that routing process already know those networks, so you put the tag 60 on it.

Now remember in (2*) I said that you wanted to avoid advertising into EIGRP routes previously marked with that same tag, but I did not tell you the reason why, now you have the answer, those routes are already known by EIGRP so why do you want it to learn again those routes.

route-map EIGRP-TO-RIP deny 30
match tag 40
!
route-map EIGRP-TO-RIP permit 40
set tag 60


A final thought, when redistributing routes metrics are different for each routing process so, is inevitable to original metrics to get altered.

The main reason for those filters is to avoid routing loops and to avoid the corruption of the original metrics of both routing process. Which means each process gets to know all routes from each other but keep its original routes unaltered.

I hope you have now a better understanding of your router configuration.


*** Please rate all useful posts ***

Regards,

Jose Bonilla
Twitter @bonillajose
Sent from Cisco Technical Support iPad App

Review Cisco Networking for a $25 gift card