cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
679
Views
5
Helpful
5
Replies
Eric06523
Beginner

Routed port

Hello everyone,

   I'm just finishing the first cisco book for the ccna.  I'm working in the cisco packet tracer program and attempting to replicate the network setup at work.

 

I'm getting stuck with routed ports.  I won't explain the who network lay out but keep it simple.

 

We have an iscsi for our Nimble storage server.  This isci sits on our 240 lan.  On this switch vlan 1 has no ip address and we have one port configured as a routed port which connects to access port 1/0/2 on the core.

 

ISCSI port

interface GigabitEthernet0/22 
no switchport
ip address 10.10.240.240 255.255.255.0
spanning-tree portfast

 

default gateway 10.10.240.254

 

 

Core port:

interface GigabitEthernet1/0/2
description iSCSI-1Mgmt
switchport access vlan 240
switchport mode access
spanning-tree portfast

 

interface Vlan240
description MGMT
ip address 10.10.240.254 255.255.255.0
ip helper-address 10.10.247.220
ip helper-address 10.10.247.183

 

I'm having issues replicating this setup in cisco packet tracer.  First the switches get mismatch vlan errors which i understand because the isci ports are all on vlan 1 with no other vlan and the core port is on vlan 240.    In our production environment, there is no error with this setup.

 

2nd, if i place a pc on the isci switch in cisco packet tracer and give it a static address on the 240 network, i cannot ping the routed port nor ping the default gateway on the core switch.

 

From looking at this, it shouldn't work in production but it does.   Can a routed port connect to an access port  or do they both have to be routed ports on each switch?

 

additionally, in cisco packet tracer i did enable routing and also ospf.  However in the production isci, ospf is not enabled.  

 

The core switch is a 3750 and the isci

Thank you

Eric.

5 REPLIES 5
Georg Pauwen
VIP Expert

Hello,

 

your setup is a bit hard to understand. Best to post the zipped Packet Tracer project (.pkt) file.

Sorry.  I figured i might had explained it odd.  Thank you for your help.

 

In production, the isci port GigabitEthernet0/22  connects to core switch port gigabitEthernet1/0/2.   In cisco packet tracer i'm using isci port fa0/22 and connecting to core switch port 1/0/3... so theres no confusion.  

 

 

Thank you

Eric

Joseph W. Doherty
Hall of Fame Expert

"Can a routed port connect to an access port or do they both have to be routed ports on each switch?"

Yes (i.e. access<>routed ok) and no (i.e. both don't need to be routed ports), at least on real devices.  PT isn't always faithful simulation; cannot say how it might behave (which might also vary between versions of it).

BTW, STP doesn't run across routed ports (nor do you need the portfast command on the routed port).

Also the default-gateway isn't used with the routed port.  For that you would use a default route.  However, default gateway or default route shouldn't be needed when pinging between IPs within the same (sub)network.

Thx. Just tested this on extra physical hardware. The issue seems to be on the Iscsi switch. I can’t pass a ping through the routed port. I can’t even ping the routed port itself when I have a pc plugged into the same switch, which is odd since there is only vlan 1. They are on the same subnet as well.

I’m not sure what else to do to get that routed port to respond to pings or to pass traffic other then making it a no switch port, enabling ip routing and ospf.

Any thoughts on why the routed port would not respond to devices plugged into the same switch?

What’s odd is I can ping the routed port from the core switch and devices from a separate vlan.

Hi,

 

I checked your PT. Even if you configured the port Fa0/22 as routed interface, the interface is still switchport interface (you can see it when you run the command show int fa0/22 switchport.) Could it be a PT bug??

 

The easy way to fix it, is to change some of the interfaces configuration as follows:-

 

On ISCSI:

int fa0/22

 switchport

 switchport mode trunk

 switchport trunk encap dot1q

 switchport trunk allowed vlan 240

!

int fa0/16

 switchport mode access

 switchport access vlan 240

!

 

On Core1:

int gi1/0/3

 switchport mode trunk

 switchport trunk encap dot1q

 switchport trunk allowed vlan 240

!

 

HTH,
Meheretab