cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1585
Views
7
Helpful
7
Replies

Router 1811 Switch 2960 Trunking problem

Hello,

I Have a 1811 with 2 L3 Ports and a eight port L2 Switch connected to a Catalyst 2960 lanbase

I Use the Catalyst for 2 different things : 1 L3 Port of the router have 2 Sub interface connected to a trunk port on the catalyst and 2 other port are connected to 2 ISP Modems. This part is working well  1811 fa1.7 and fa1.42 connected to Catalyst fa0/24 trunk mode and fa 21 and 22 in switchport mode access to vlan 7 and 42

The switch part of the router and the catalyst are connected too (fa6 on router, fa0/12 on the catalyst).

Now I want to add a voice vlan( Vlan 22). I have used vtp (catalyst is server, router is client). Put the two interface in trunk mode and create SVI on both.

The problem is : I can't even ping on the voice vlan.

Can someone please have a look and explain me the problem ?

attached and here are the relevant config part :

Router 1811 :

no spanning-tree vlan 7
no spanning-tree vlan 42
vtp interface fa6
vtp mode client
vtp version 2


interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet1.7
description $FW_OUTSIDE$$ETH-WAN$
bandwidth 1024
bandwidth receive 18432
encapsulation dot1Q 7
ip vrf forwarding O2INFO
ip address 192.168.49.253 255.255.255.0
ip mtu 1440
ip flow ingress
ip virtual-reassembly in
zone-member security z-media
ip tcp adjust-mss 1300
no cdp enable
!
interface FastEthernet1.42
bandwidth 4096
encapsulation dot1Q 42
ip vrf forwarding O2INFO
ip address 10.34.3.1 255.255.255.252
ip mtu 1420
zone-member security z-media
ip tcp adjust-mss 1300
no cdp enable
service-policy output QoS
!


interface FastEthernet6
switchport trunk allowed vlan 1,22,1002-1005
switchport mode trunk
switchport voice vlan 22
no ip address
!

interface Vlan1
ip vrf receive O2INFO
ip address 192.168.34.253 255.255.255.0
ip mtu 1420
ip flow ingress
ip nat inside
ip virtual-reassembly in
zone-member security in-zone
ip tcp adjust-mss 1300
ip policy route-map Publication
service-policy input BRANCH-LAN-EDGE-IN
!
interface Vlan22
description interface Voix
ip address 192.168.35.253 255.255.255.0
ip nat inside
ip virtual-reassembly in
zone-member security in-zone
vlan-id dot1q 22
  exit-vlan-config
!

Catalyst 2960


vtp interface fa0/12
ip routing

!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 22 priority 4096
spanning-tree vlan 22 forward-time 10
spanning-tree vlan 22 max-age 14

!
interface FastEthernet0/12
switchport trunk allowed vlan 1,22,1002-1005
switchport mode trunk
switchport nonegotiate
switchport voice vlan 22
spanning-tree vlan 22 port-priority 48
!
!        
interface Vlan1
ip address 192.168.34.242 255.255.255.0
no ip route-cache cef
no ip route-cache
!
interface Vlan22
ip address 192.168.35.242 255.255.255.0
ip sticky-arp
no ip route-cache cef
no ip route-cache
!

On the router the show mac-address-table give this :

0021.d887.fd8e          Self         22     Vlan22     

04da.d27a.708c          Dynamic      22     FastEthernet6      

04da.d27a.70c1          Dynamic      22     FastEthernet6

But on the catalyst I have no mac address on vlan 22 only on Vlan 1

   1    0021.d887.fd8e    DYNAMIC     Fa0/12

   1    0021.d887.fd94    DYNAMIC     Fa0/12

But I have arp : Show arp

Internet  192.168.35.253        204   0021.d887.fd8e  ARPA   Vlan22          Router

Internet  192.168.35.242          -   04da.d27a.70c1  ARPA   Vlan22             Self

What Am I doing wrong ??

thanks in advance

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Master

Re:Router 1811 Switch 2960 Trunking problem

Thanks for posting back to the forum to inform us that you have solved the problem and what the problem was. This helps to make the forum more useful when people can read about a problem and can also read the solution to the problem.

HTH

Rick

7 REPLIES 7

Router 1811 Switch 2960 Trunking problem

I think that missed the next command:

switchport voice vlan dot1p

Explain: Instruct the switch port to use IEEE 802.1p priority tagging for voice traffic and to use the default native VLAN (VLAN 1) to carry all traffic. By default, the Cisco IP phone forwards the voice traffic with an IEEE 802.1p priority

of 5.

Best regards,

http://networkingcontrol.wordpress.com/ #CCNP CSCO11962956
Hall of Fame Master

Router 1811 Switch 2960 Trunking problem

In my limited experience with the 2960 I discovered that while it will allow you to configure multiple VLAN interfaces and to assign IP addresses on them (which I believe is quite unusual for a layer 2 switch) I found that having multiple VLAN interfaces with IP addresses created problems. I suggest removing interface vlan 22 from the 2960 - or at least removing the ip address from it. Give this a try and let us know if it helps.

HTH

Rick

Router 1811 Switch 2960 Trunking problem

Hello Alfredo,

The goal is to have 2 vlans. I use dscp on the WAN Part, but on the lan part I want a different vlan for voice. On a lot of switch and IPBX having a different vlan for voice make things easier...

thanks for taking time to have look

regards

Jean-Luc

Contributor

Re:Router 1811 Switch 2960 Trunking problem

Rick brings up a good point, however, I have been successful in the past with this type of configuration. I use it strictly for testing and not in normal production.

I believe the problem is the 'switchport voice vlan 22' configuration on the trunk ports. IIRC this has no effect on a trunk port, only in an access port. Try removing it from both the router and switch as it could be causing your problem.

Regards,
Mike


Sent from Cisco Technical Support Android App

Re:Router 1811 Switch 2960 Trunking problem

Hello,

I have already test with and without. No Changes. I done it again yet without any changes :

Then SVI are up/up but unable to ping from the switch to the router.

I agree it's only a test configuration.

After that I have a cisco switch plug into the catalyst and and hyper-V 2012 switch behind

What I want is a connexion between a virtual machine on hyper-v and the router.

I prefer to go step by step. If I am unable to ping from switch to router, no need to go further...

Regards

Jean-Luc

Re:Router 1811 Switch 2960 Trunking problem

I have cleaned the config and found and old local policy routing.

As soon as I correct the local policy routing , the trunk begins to work as expected.

Hall of Fame Master

Re:Router 1811 Switch 2960 Trunking problem

Thanks for posting back to the forum to inform us that you have solved the problem and what the problem was. This helps to make the forum more useful when people can read about a problem and can also read the solution to the problem.

HTH

Rick

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards