cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
424
Views
1
Helpful
3
Replies

Router cant ping vlan on switch

Mike McCotter
Level 1
Level 1

Hello,

I'm working in packet tracer and am running into an issue with pinging the SVI on my switch from my router. I know I'm missing a step but can't figure why the ping fails. Thanks for any suggestions.

Topology:

Router (g0/0) -----Switch (f0/5)

Router:

GigabitEthernet0/0.70 is up, line protocol is up (connected)

Hardware is PQUICC_FEC, address is 0001.9608.8601 (bia 0001.9608.8601)

Internet address is 172.17.70.1/24

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation 802.1Q Virtual LAN, Vlan ID 70

ARP type: ARPA, ARP Timeout 04:00:00,

Last clearing of "show interface" counters never

Switch:

Vlan70 is up, line protocol is up

Hardware is CPU Interface, address is 0060.3ea0.5701 (bia 0060.3ea0.5701)

Internet address is 172.17.70.10/24

MTU 1500 bytes, BW 100000 Kbit, DLY 1000000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 21:40:21, output never, output hang never

Last clearing of "show interface" counters never

Name: Fa0/5

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 70 (IT_Management)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: 36,60,70

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none

FastEthernet0/5 is up, line protocol is up (connected)

Hardware is Lance, address is 000a.4137.5405 (bia 000a.4137.5405)

BW 100000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:08, output 00:00:05, output hang never

Last clearing of "show interface" counters never

switch# sh run

Current configuration : 4178 bytes

!

version 15.0

no service timestamps log datetime msec

no service timestamps debug datetime msec

service password-encryption

!

hostname S2

!

ipv6 unicast-routing

!

!

no logging console

enable secret 5 $1$mERr$5uT8Pi1aj2EbvlGa5TSII0

!

!

!

ip ssh version 2

no ip domain-lookup

ip domain-name mccotter.final.com

!

username americanlarch secret 5 $1$mERr$7IGoEkf1mPlnB6R6v1A0c/

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

interface FastEthernet0/1

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/2

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/3

switchport access vlan 70

switchport mode access

switchport port-security

switchport port-security maximum 5

spanning-tree portfast

spanning-tree bpduguard enable

!

interface FastEthernet0/4

switchport access vlan 70

switchport mode access

switchport port-security

switchport port-security maximum 5

spanning-tree portfast

spanning-tree bpduguard enable

!

interface FastEthernet0/5

switchport trunk native vlan 70

switchport trunk allowed vlan 36,60,70

switchport mode trunk

!

interface FastEthernet0/6

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/7

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/8

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/9

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/10

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/11

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/12

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/13

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/14

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/15

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/16

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/17

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/18

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/19

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/20

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/21

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/22

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/23

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface FastEthernet0/24

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

shutdown

!

interface GigabitEthernet0/1

switchport trunk native vlan 70

switchport trunk allowed vlan 36,60,70

switchport mode trunk

!

interface GigabitEthernet0/2

switchport trunk native vlan 70

switchport trunk allowed vlan 36,60,70

switchport mode trunk

!

interface Vlan1

no ip address

shutdown

!

interface Vlan70

ip address 172.17.70.10 255.255.255.0

ipv6 address FE80::10 link-local

ipv6 address 2001:DB8:F:70::10/64

ipv6 enable

!

ip default-gateway 172.17.70.1

!

banner motd ^C Unauthorized access is prohibited! ^C

!

!

!

ipv6 route ::/0 2001:DB8:F:70::1

!

!

line con 0

password 7 08244D5D1D1C17191A0E010825282F

login

!

line vty 0 4

exec-timeout 15593 0

login local

transport input ssh

line vty 5 15

login

!

!

!

!

end

1 Accepted Solution

Accepted Solutions

Gopinath_Pigili
Spotlight
Spotlight

Hello Mike McCotter,

I thinnk ...this is because of Native vlan mismatch....According to your switch configuration output...I notieced vlan 70 is marked as Native vlan...

So, in  router also vlan 70 sould mark it native ...with the following commands:

Interface GigabitEthernet0/0.70 

encapsulation dot1q 70 native

I hope the above configuration will solve the issue....

Best regards
******* If This Helps, Please Rate *******

 

View solution in original post

3 Replies 3

Gopinath_Pigili
Spotlight
Spotlight

Hello Mike McCotter,

I thinnk ...this is because of Native vlan mismatch....According to your switch configuration output...I notieced vlan 70 is marked as Native vlan...

So, in  router also vlan 70 sould mark it native ...with the following commands:

Interface GigabitEthernet0/0.70 

encapsulation dot1q 70 native

I hope the above configuration will solve the issue....

Best regards
******* If This Helps, Please Rate *******

 

Mike McCotter
Level 1
Level 1

Thanks @Gopinath_Pigili that was what was missing. I appreciate your help.

Nice to hear that issue is resolved...!!

You are always welcome to the Cisco Community...!

Have a wonderful day..!!

Thanks

Review Cisco Networking for a $25 gift card