cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
877
Views
0
Helpful
7
Replies

Router not receiving DHCP requests from VLAN but gets them from other VLANs

bforgeron
Level 1
Level 1

We have a Cisco 3945 router which includes two etherchannel 24 port 3560 modules.  We have two uplinks, one directly to the router with stub network and another one without stub network on one of the 3560 modules.  We have interface vlans on our 3945 for each uplink and can move traffic for both networks as we'd expect.  We cannot however get DHCP REQUESTS to the router from any client on our VLAN 101.  We've confirmed using nmap that UDP ports 67 and 68 are open from clients to router as expected, clients are fully functional with static IP's and can communicate.  Running 'debug ip dhcp server packet detail' shows nothing for VLAN 101 when client are set for DHCP, but operates perfectly fine for clients on VLAN100.  We've tried restarting the DHCP service on the router.  We're at a loss, is this maybe a bug?  Is there anything else we could try?  

On the clients when running 'dhclient -v -r' to force a renewal we see the following:

dhclient

Below are some snippets of our config.

Cisco 3945 router - our DHCP server and Gateway for VLANs

ip dhcp excluded-address 10.23.144.1 10.23.144.111
ip dhcp excluded-address 10.54.66.1 10.54.66.5
!
ip dhcp pool dhcp-VLAN100
network 10.23.144.0 255.255.255.0
bootfile pxelinux.0
next-server 10.100.87.147
default-router 10.23.144.1
dns-server 10.23.144.3
!
ip dhcp pool dhcp-VLAN101
network 10.54.66.0 255.255.255.0
default-router 10.54.66.5
dns-server 10.23.144.3
!
ip dhcp update dns both
!
interface Vlan100
ip address 10.23.144.1 255.255.255.0
ip nat outside
ip virtual-reassembly in
!
interface Vlan101
ip address 10.54.66.5 255.255.255.0
ip nat outside
ip virtual-reassembly in
!

7 Replies 7

Jon Marshall
Hall of Fame
Hall of Fame

Is there any difference in the vlan configuration on your switches for vlans 100 and 101 ?

Jon

Jon, my man!  No differences other than their uplinks.  Using VTP across our switches and any interfaces with VLAN 100 also has 101.

I had a quick look at the previous thread the quick schematic you did suggested it was a private vlan.

Is it and if so is vlan 100 as well ?

I don't thnk that is actually the problem as when you give a client a static IP it works but a DHCP request should at least get to the router and your debug suggests it isn't,

Bit confusing this one :-)

Jon

Yes both of these VLANs are private and behind our 3945 router.  I agree it's confusing, in addition to the 101 and 100 VLANs we also have a couple other private VLANs that are no uplinked which also DHCP works fine for.  IOS is outdated on this router so we're wondering if this is a bug of some sort.

It could be I suppose.

You could try doing a packet capture I guess to see if the port connecting to the router is actually seeing the DHCP request but I can't see why it wouldn't to be honest.

Jon

We ended up power cycling the entire 3945 chassis for unrelated reasons and once it was back online DHCP for this new VLAN worked as originally expected.

Thanks for posting back to the forum to let us know that you have solved the issue and how you solved. This might serve as a reminder to many of us that when there is a problem and the config looks appropriate that quite a few times a reboot or power cycle may fix the issue.

HTH

Rick

HTH

Rick
Review Cisco Networking products for a $25 gift card