cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1757
Views
5
Helpful
10
Replies
cigalahgroup
Beginner

router on a stick cisco 2950

Hello,

I am trying to do a lab for Router on the stick but it fails. Here is the scenario.

I have 1841 router and 2950 24 port switch.

1841 Fe 0/0 is connected to switch on Fe 0/1

Switch hAS 2 Vlans namely vlan10 and vlan20

when I no shutdown on vlan10 then Vlan20 goes down with administratively shutdown state. At any given point of time I cannot have both the VLANS up and  running state.

Your help will be appreciated.

2 ACCEPTED SOLUTIONS

Accepted Solutions

Thanks to George. Let me draft how the problem was resolved.

 

My configurations was correct but the only thing I came to knew is 

I cannot have more than 1 vlan up and running 

if you have vlan10 and vlan 20 

you can only have an ip address to vlan10  up and running .if you try to give an ip to vlan 20  and make no shut down it will  automatically take down vlan 10.

 

This behaviour is due to layer 2 capabilities of switch.

 

Also I have to put the ip default-gateway command on the switch because router does all the routing for inter vlan

 

switch only forwards  PACKETS TO router.

 

View solution in original post

Hello,

 

indeed, management access and the ip default-gateway command are only required for communication between the switch and the router. Clients on Vlan 10 and Vlan 20 will be able to communicate regardless. 

 

The rest of your summary is correct.

 

Good luck with your studies...

View solution in original post

10 REPLIES 10
Reza Sharifi
Hall of Fame Expert

Hi,

You can't have more than one vlan on the 2950 and that is only for management.  So, you have to simply trunk port fa01 on the switch side and add vlan 10 and 20 to it. Than on the router on port fa0/0 you need to create 2 sub-interfaces (one for 10 and one for 20) and add IP to each sub-interface. see link

https://networklessons.com/cisco/ccna-routing-switching-icnd1-100-105/how-to-configure-router-on-a-stick

HTH

 

 

Jaderson Pessoa
VIP Engager

@cigalahgroup hello,

 

try it;

 

on router:

rt(config)interface g1/0/0.10

rt(config-if)encanpsulation dotq1 10

rt(config-if)ip address 192.168.1.1 255.255.255.0

 

rt(config)interface g1/0/0.20

rt(config-if)encanpsulation dotq1 20

rt(config-if)ip address 192.168.2.1 255.255.255.0

 

on switch:

sw(config)interface g0/24

sw(config-if) switchport mode trunk

sw(config-if) switchport mode trunk allowed vlan 10,20

 

sw(config) vlan 10

sw(config-vl) name admin

sw(config-vl) exit

 

sw(config) interface vlan 10

sw(config-if) ip address 192.168.1.2 255.255.255.0

 

sw(config) vlan 20

sw(config-vl) name user

sw(config-vl) exit

 

sw(config) ip default-gateway 192.168.1.1

 

and test connection.

 

Jaderson Pessoa
*** Rate All Helpful Responses ***

Here are my configurations

 

# conf t
(config)# vlan 10
(config-vlan)# exit
(config)# vlan 20
(config-vlan)# exit

(config)# interface FastEthernet1/0/1
(config-if)# description trunk-to-router-on-a-stick
(config-if)# switchport trunk encapsulation dot1q
(config-if)# switchport mode trunk
(config-if)# spanning-tree portfast trunk
(config-if)# exit

 

(config)# interface FastEthernet1/0/2
(config-if)# description connection-to-Sales
(config-if)# switchport mode access
(config-if)# switchport access vlan 10
(config-if)# exit

 

(config)# interface FastEthernet1/0/3
(config-if)# description connection-to-IT
(config-if)# switchport mode access
(config-if)# switchport access vlan 20
(config-if)# exit

 

Router Configuration

 


# conf t
(config)# interface fastethernet 0/0.10
(config-if)# encapsulation dot1q 10
(config-if)# ip address 10.10.10.2 255.255.255.0
(config-if)# exit
(config)# interface fastethernet 0/0.20
(config-if)# encapsulation dot1q 20
(config-if)# ip address 20.20.20.2 255.255.255.0
(config-if)# exit

 

My configurations are correct but still I have the same problem..

 

Hello,

 

on a side note, if this is a Packet Tracer file, post it here (ZIP the .pkt file first, otherwise the system won't let you upload it).

Also, just to be sure you have, check if interface FastEthernet0/0 on the router is not shut...

Thanks to George. Let me draft how the problem was resolved.

 

My configurations was correct but the only thing I came to knew is 

I cannot have more than 1 vlan up and running 

if you have vlan10 and vlan 20 

you can only have an ip address to vlan10  up and running .if you try to give an ip to vlan 20  and make no shut down it will  automatically take down vlan 10.

 

This behaviour is due to layer 2 capabilities of switch.

 

Also I have to put the ip default-gateway command on the switch because router does all the routing for inter vlan

 

switch only forwards  PACKETS TO router.

 

View solution in original post

Hello,

 

remote access would be a good idea...

Hello,

 

indeed, management access and the ip default-gateway command are only required for communication between the switch and the router. Clients on Vlan 10 and Vlan 20 will be able to communicate regardless. 

 

The rest of your summary is correct.

 

Good luck with your studies...

View solution in original post

Hello

As @Reza Sharifi  suggested twice the switch is only capable to allow 1 l3 svi so if you want intervlan routing as suggested by @Jaderson Pessoa you need change it so the router perfrom this action,



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

well.. this information was posted by Pauen and me. rs

Great that your problem was solved.

Good lucky.
Jaderson Pessoa
*** Rate All Helpful Responses ***