01-05-2011 07:30 AM - edited 03-06-2019 02:50 PM
Hello,
Cisco switches in Core and Dist layers, Procurves in access layer.
Core switch V1CS1 goes down, V2CS1 takes over as STP root.
The Ciscos are running PVRST+ and the Procurves RSTP.
When V2CS1 takes over as the new root, the Procurve switches only reply to proposals on VLAN1.
V2CS1 keeps transmitting proposals on fa0/1 and fa0/2 until the forward delay timer expires.
Fa0/1 and fa0/2 then go into LRN for 15 seconds, then FWD.
This is a terrible delay to have...
I have found one solution: MSTP. This gets <2s reconvergence. But this would involve a lot of reconfiguration work on the production network.
Does anyone have another idea?
Any thoughts are greatly appreciated.
Regards,
Malcolm
S2# sh run
Running configuration:
; J9088A Configuration Editor; Created on release #R.11.30
hostname "S2"
snmp-server community "public" Unrestricted vlan 1
name "DEFAULT_VLAN"
untagged 1-2,6-52
no ip address
no untagged 3-5
exit
vlan 110
name "VLAN110"
untagged 3
tagged 1-2
exit
vlan 220
name "VLAN220"
untagged 4-5
tagged 1-2
exit
spanning-tree
spanning-tree force-version RSTP-operation
S1# sh run
Running configuration:
; J9088A Configuration Editor; Created on release #R.11.30
hostname "S1"
snmp-server community "public" Unrestricted vlan 1
name "DEFAULT_VLAN"
untagged 1-2,4-52
no ip address
no untagged 3
exit
vlan 110
name "VLAN110"
untagged 3
tagged 1-2
exit
spanning-tree
spanning-tree force-version RSTP-operation
V1CS2
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
spanning-tree vlan 1-1024 priority 4096
!
vlan internal allocation policy ascending
vlan dot1q tag native
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
no ip address
!
interface Vlan110
ip address 192.168.110.3 255.255.255.0
!
interface Vlan220
ip address 192.168.220.3 255.255.255.0
V1CS1
spanning-tree mode rapid-pvst
spanning-tree logging
spanning-tree extend system-id
!
spanning-tree vlan 1-1024 priority 4096
!
vlan internal allocation policy ascending
vlan dot1q tag native
!
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
no ip address
!
interface Vlan110
ip address 192.168.110.2 255.255.255.0
!
interface Vlan220
ip address 192.168.220.2 255.255.255.0
!
V2CS1#
V2CS1#
V2CS1#
V2CS1#sh debug
Spanning Tree:
Spanning Tree event dump debugging is on
Spanning Tree snapshot debugging is on
Spanning Tree event debugging is on
V2CS1#
V2CS1#sh spann root
Root Hello Max Fwd
Vlan Root ID Cost Time Age Dly Root Port
---------------- -------------------- --------- ----- --- --- ------------
VLAN0001 4097 000a.f468.d380 4 2 20 15 Gi0/2
VLAN0110 4206 000a.f468.d380 4 2 20 15 Gi0/2
VLAN0220 4316 000a.f468.d380 4 2 20 15 Gi0/2
V2CS1#
V2CS1#
05:50:04: RSTP(1): updt roles, root port Gi0/2 going down
05:50:04: RSTP(1): we become the root bridge
05:50:04: RSTP(1): snapshot: Fa0/1->Desg.FWD Fa0/2->Desg.FWD Gi0/2->Root.DIS
05:50:04: RSTP(110): updt roles, root port Gi0/2 going down
05:50:04: RSTP(110): we become the root bridge
05:50:04: RSTP(110): snapshot: Fa0/1->Desg.FWD Fa0/2->Desg.FWD Gi0/2->Root.DIS
05:50:04: RSTP(220): updt roles, root port Gi0/2 going down
05:50:04: RSTP(220): we become the root bridge
05:50:04: RSTP(220): snapshot: Fa0/1->Desg.FWD Fa0/2->Desg.FWD Gi0/2->Root.DIS
05:50:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/2, changed state to down
05:50:06: %LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed state to down
V2CS1#
V2CS1#
V2CS1#
V2CS1#
V2CS1#
V2CS1#
05:52:11: %LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed state to up
05:52:12: RSTP(1): initializing port Gi0/2
05:52:12: RSTP(1): Gi0/2 is now designated
05:52:12: RSTP(110): initializing port Gi0/2
05:52:12: RSTP(110): Gi0/2 is now designated
05:52:12: RSTP(220): initializing port Gi0/2
05:52:12: RSTP(220): Gi0/2 is now designated
05:52:12: RSTP(1): transmitting a proposal on Gi0/2RSTP(1):
05:52:12: F:DP R:1001.0016.c88b.e600 C:0 B:1001.0016.c88b.e600 P:8032 A:0 T:14.2.F
05:52:12: RSTP(110): transmitting a proposal on Gi0/2RSTP(110):
05:52:12: F:DP R:106E.0016.c88b.e600 C:0 B:106E.0016.c88b.e600 P:8032 A:0 T:14.2.F
05:52:12: RSTP(220): transmitting a proposal on Gi0/2RSTP(220):
05:52:12: F:DP R:10DC.0016.c88b.e600 C:0 B:10DC.0016.c88b.e600 P:8032 A:0 T:14.2.F
05:52:12: RSTP(1): updt roles, received superior bpdu on Gi0/2
05:52:12: RSTP(1): Gi0/2
05:52:12: F:DP R:1001.000a.f468.d380 C:0 B:1001.000a.f468.d380 P:801A A:0 T:14.2.F
05:52:12: RSTP(1): Gi0/2 is now root port
05:52:12: RSTP(1): syncing port Fa0/1
05:52:12: RSTP(1): syncing port Fa0/2
05:52:12: RSTP(1): synced Gi0/2
05:52:12: RSTP(1): snapshot: Fa0/1->Desg.BLK Fa0/2->Desg.BLK Gi0/2->Root.FWD
05:52:12: RSTP(110): updt roles, received superior bpdu on Gi0/2
05:52:12: RSTP(110): Gi0/2
05:52:12: F:DP R:106E.000a.f468.d380 C:0 B:106E.000a.f468.d380 P:801A A:0 T:14.2.F
05:52:12: RSTP(110): Gi0/2 is now root port
05:52:12: RSTP(110): syncing port Fa0/1
05:52:12: RSTP(110): syncing port Fa0/2
05:52:12: RSTP(110): synced Gi0/2
05:52:12: RSTP(110): snapshot: Fa0/1->Desg.BLK Fa0/2->Desg.BLK Gi0/2->Root.FWD
05:52:12: RSTP(220): updt roles, received superior bpdu on Gi0/2
05:52:12: RSTP(220): Gi0/2
05:52:12: F:DP R:10DC.000a.f468.d380 C:0 B:10DC.000a.f468.d380 P:801A A:0 T:14.2.F
05:52:12: RSTP(220): Gi0/2 is now root port
05:52:12: RSTP(220): syncing port Fa0/1
05:52:12: RSTP(220): syncing port Fa0/2
05:52:12: RSTP(220): synced Gi0/2
05:52:12: RSTP(220): snapshot: Fa0/1->Desg.BLK Fa0/2->Desg.BLK Gi0/2->Root.FWD
05:52:12: RSTP(1): transmitting an agreement on Gi0/2 as a response to a proposalRSTP(1):
05:52:12: F:AgFLR R:1001.000a.f468.d380 C:0 B:1001.000a.f468.d380 P:801A A:0 T:14.2.F
05:52:12: RSTP(1): transmitting a proposal on Fa0/1RSTP(1):
05:52:12: F:DP R:1001.000a.f468.d380 C:4 B:1001.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:12: RSTP(1): transmitting a proposal on Fa0/2RSTP(1):
05:52:12: F:DP R:1001.000a.f468.d380 C:4 B:1001.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:12: RSTP(110): transmitting an agreement on Gi0/2 as a response to a proposalRSTP(110):
05:52:12: F:AgFLR R:106E.000a.f468.d380 C:0 B:106E.000a.f468.d380 P:801A A:0 T:14.2.F
05:52:12: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:12: F:DP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:12: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:12: F:DP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:12: RSTP(220): transmitting an agreement on Gi0/2 as a response to a proposalRSTP(220):
05:52:12: F:AgFLR R:10DC.000a.f468.d380 C:0 B:10DC.000a.f468.d380 P:801A A:0 T:14.2.F
05:52:12: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:12: F:DP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:12: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:12: F:DP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:12: RSTP(1): received an agreement on Fa0/1
05:52:12: RSTP(1): snapshot: Fa0/1->Desg.FWD Fa0/2->Desg.BLK Gi0/2->Root.FWD
05:52:12: RSTP(1): received an agreement on Fa0/2
05:52:12: RSTP(1): snapshot: Fa0/1->Desg.FWD Fa0/2->Desg.FWD Gi0/2->Root.FWD
05:52:12: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:12: F:DPTc R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:12: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:12: F:DPTc R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:12: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:12: F:DPTc R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:12: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:12: F:DPTc R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:12: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:12: F:DPTc R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:12: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:12: F:DPTc R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:13: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:13: F:DPTc R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:13: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:13: F:DPTc R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/2, changed state to up
05:52:14: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:14: F:DPTc R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:14: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:14: F:DPTc R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:15: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:15: F:DPTc R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:15: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:15: F:DPTc R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:16: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:16: F:DP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:16: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:16: F:DP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:17: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:17: F:DP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:17: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:17: F:DP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:18: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:18: F:DP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:18: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:18: F:DP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:19: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:19: F:DP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:19: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:19: F:DP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:20: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:20: F:DP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:20: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:20: F:DP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:21: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:21: F:DP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:21: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:21: F:DP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:22: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:22: F:DP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:22: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:22: F:DP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:23: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:23: F:DP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:23: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:23: F:DP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:24: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:24: F:DP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:24: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:24: F:DP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:25: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:25: F:DP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:25: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:25: F:DP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:26: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:26: F:DP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:26: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:26: F:DP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:27: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:27: F:DP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:27: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:27: F:DP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:27: RSTP(110): Fa0/1 fdwhile Expired
05:52:27: RSTP(110): snapshot: Fa0/1->Desg.LRN Fa0/2->Desg.BLK Gi0/2->Root.FWD
05:52:27: RSTP(110): Fa0/2 fdwhile Expired
05:52:27: RSTP(110): snapshot: Fa0/1->Desg.LRN Fa0/2->Desg.LRN Gi0/2->Root.FWD
05:52:27: RSTP(220): Fa0/1 fdwhile Expired
05:52:27: RSTP(220): snapshot: Fa0/1->Desg.LRN Fa0/2->Desg.BLK Gi0/2->Root.FWD
05:52:27: RSTP(220): Fa0/2 fdwhile Expired
05:52:27: RSTP(220): snapshot: Fa0/1->Desg.LRN Fa0/2->Desg.LRN Gi0/2->Root.FWD
05:52:28: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:28: F:LDP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:28: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:28: F:LDP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:29: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:29: F:LDP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:29: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:29: F:LDP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:30: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:30: F:LDP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:30: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:30: F:LDP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:31: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:31: F:LDP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:31: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:31: F:LDP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:32: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:32: F:LDP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:32: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:32: F:LDP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:33: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:33: F:LDP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:33: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:33: F:LDP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:34: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:34: F:LDP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:34: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:34: F:LDP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:35: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:35: F:LDP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:35: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:35: F:LDP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:36: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:36: F:LDP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:36: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:36: F:LDP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:37: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:37: F:LDP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:37: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:37: F:LDP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:38: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:38: F:LDP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:38: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:38: F:LDP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:39: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:39: F:LDP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:39: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:39: F:LDP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:40: RSTP(110): transmitting a proposal on Fa0/1RSTP(110):
05:52:40: F:LDP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:40: RSTP(110): transmitting a proposal on Fa0/2RSTP(110):
05:52:40: F:LDP R:106E.000a.f468.d380 C:4 B:106E.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:41: RSTP(220): transmitting a proposal on Fa0/1RSTP(220):
05:52:41: F:LDP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8001 A:100 T:14.2.F
05:52:41: RSTP(220): transmitting a proposal on Fa0/2RSTP(220):
05:52:41: F:LDP R:10DC.000a.f468.d380 C:4 B:10DC.0016.c88b.e600 P:8002 A:100 T:14.2.F
05:52:42: RSTP(110): Fa0/1 fdwhile Expired
05:52:42: RSTP(110): snapshot: Fa0/1->Desg.FWD Fa0/2->Desg.LRN Gi0/2->Root.FWD
05:52:42: RSTP(110): Fa0/2 fdwhile Expired
05:52:42: RSTP(110): snapshot: Fa0/1->Desg.FWD Fa0/2->Desg.FWD Gi0/2->Root.FWD
05:52:42: RSTP(220): Fa0/1 fdwhile Expired
05:52:42: RSTP(220): snapshot: Fa0/1->Desg.FWD Fa0/2->Desg.LRN Gi0/2->Root.FWD
05:52:42: RSTP(220): Fa0/2 fdwhile Expired
05:52:42: RSTP(220): snapshot: Fa0/1->Desg.FWD Fa0/2->Desg.FWD Gi0/2->Root.FWD
V2CS1#
Solved! Go to Solution.
01-05-2011 08:29 AM
Malcolm,
i had many happy hours and lot of fun with this ;-(
The only one longer term working way for HP Procurve, 3COM/H3C and Cisco Switches to cooperate is using MSTP .
Remember that you *must* create identical Istance Configuration.
You should assign VLAN (ranges) to those instances to be able to add vlans in the future without
Problems. On Cisco, those vlans must not exist, on HP, they must .
Changing the MST Instance configuration will interrupt service !
So create a bunch of vlans for the future; on HP, first increase the limit, reboot, then add more vlans.
remember that the VT100 vlan management is limited to the number of vlans,
so you should use the CLI for work.
just my $ 0.01
Juergen.
01-07-2011 12:34 AM
Hello Malcolm,
You have to know that cisco use a prioprietary implementation of STP and RSTP, which are Per-VLAN spanning tree. As the standard protocol don't define a vlan ID field in BPDU, cisco code it in lower bits of the priority field, and then if you have X vlans on a trunk link, it will send X BPDU
This is in case of the use of the extended system id (spanning-tree extend system-id), which is enabled by default, otherwise it will use different mac addresses for the switch, so it might be seen as multiple switches by non Per vlan STP switches.
Standard spanning tree breaks physical loops, whereas per vlan breaks logical loops, so it might lead to a situation where physical and logical topologies are not the same, but as the HP switch only think there's only physical it can cut L1 links or do not cut then leading to loops or network outage.
In the end, you might succeed making HP and CISCO STP working together, but the most effective and stable solution would be to use MSTP which is a standard implementation.
I hope this is clear for you
01-05-2011 08:29 AM
Malcolm,
i had many happy hours and lot of fun with this ;-(
The only one longer term working way for HP Procurve, 3COM/H3C and Cisco Switches to cooperate is using MSTP .
Remember that you *must* create identical Istance Configuration.
You should assign VLAN (ranges) to those instances to be able to add vlans in the future without
Problems. On Cisco, those vlans must not exist, on HP, they must .
Changing the MST Instance configuration will interrupt service !
So create a bunch of vlans for the future; on HP, first increase the limit, reboot, then add more vlans.
remember that the VT100 vlan management is limited to the number of vlans,
so you should use the CLI for work.
just my $ 0.01
Juergen.
01-06-2011 11:20 PM
Hi Jürgen,
great info, thanks, but how frustrating having to plan the VLAN ranges in advance or suffer a break! But I suspected this may be the only way...unless anyone knows anything else?
Regards,
Malcolm
01-07-2011 12:34 AM
Hello Malcolm,
You have to know that cisco use a prioprietary implementation of STP and RSTP, which are Per-VLAN spanning tree. As the standard protocol don't define a vlan ID field in BPDU, cisco code it in lower bits of the priority field, and then if you have X vlans on a trunk link, it will send X BPDU
This is in case of the use of the extended system id (spanning-tree extend system-id), which is enabled by default, otherwise it will use different mac addresses for the switch, so it might be seen as multiple switches by non Per vlan STP switches.
Standard spanning tree breaks physical loops, whereas per vlan breaks logical loops, so it might lead to a situation where physical and logical topologies are not the same, but as the HP switch only think there's only physical it can cut L1 links or do not cut then leading to loops or network outage.
In the end, you might succeed making HP and CISCO STP working together, but the most effective and stable solution would be to use MSTP which is a standard implementation.
I hope this is clear for you
01-07-2011 04:31 AM
Hi Bastien,
Thanks for the explanation - the Procurves don't respond to BPDUs with the extended system-ID used by PVST. I can't turn off extended system-id on my switches so I'll have to go with MSTP.
It's been an interesting exercise, thanks for your help, Bastien and Jürgen!
Regards,
Malcolm
02-02-2021 09:50 AM
I configured bpdufilter on trunk btw HP and Cisco and solve the issue temporary in migration phase from HP to Cisco. Not the best solution but works for me.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide