cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2921
Views
0
Helpful
63
Replies

Segment from PIX to segment on ASA

Tyler Woods
Level 1
Level 1

I need the following to happen:

Host at 12.x.x.134 to access host 10.50.2.32 on port 8888.

Host at 12.x.x.134 to access host 10.50 2.33 on port 1560.

I am at a complete loss on getting this accomplished. Have tried multiple configurations and nothing works. Ideally I would collapse this all to the ASA but I do not have the time to dedicate at the moment so I just need to get this working as it is. The ASA is under SMARTnet but CCO ID does not have permission to its serial number yet.

Any guidance on this would be greatly appreciated. Is below enough to go on?

ASA Interfaces

Ethernet0/0 outside 64.xx.xx.130 security-level   0 --> to RouterA via 2980

Ethernet0/1 inside  10.50.2.1    security-level 100 --> to 2980

Ethernet0/2 dmz1    10.10.10.2   security-level  50 --> to ASA e2

PIX

Ethernet0   outside 12.xx.xx.2   security-level   0 --> to RouterB via 2980

Ethernet1   dmz     12.x.x.129   security-level  50 --> to 2980

Ethernet2   dmz2    10.10.10.1   security-level  50 --> to PIX e0/2

63 Replies 63

Tyler

How easy is it to make config changes and/or do some debugging. The fact that the ASA dmz1 acl applied inbound has no hits suggests the pix is not sending the packets. So we can either -

1) apply an acl outbound on the dmz2 interface of the pix -

access-list dmz2_out permit ip host 12.10.100.134 host 10.50.2.33

access-list dmz2_out permit ip any any

this should not block any traffic we are just seeing if the first line gets a hit when you try and connect

or

2) we can debug the pix interface and see if the traffic is leaving the interface

Jon

access-list dmz2_out extended permit ip host 12.x.x.134 host 10.50.2.32

access-list dmz2_out extended permit ip host 12.x.x.134 host 10.50.2.33

access-list dmz2_out extended permit ip any any

access-group dmz2_out out interface dmz2

I put the above on the PIX and got some hit counts increased when they tested going to 10.50.2.33.

Debugging shouldn't be an issue. Just have never done it so will need to be very careful when I do it.

So you got hit counts when you tried the connection but still no hit counts on the ASA inbound acl on dmz1 ?

That doesn't make any sense if they are connected on the same network.

Jon

That is correct. No clue as well as you can see. Not sure what I am missing here.

Lets assume the issue is with the ASA for the moment. We may need to do a packet capture but is there any change of posting full ASA config (minus any public IP info) ?

Jon

Here it is sanitized fully I believe.

ASA Version 8.2(5)

!

interface Ethernet0/0

description Internet

nameif outside

security-level 0

ip address 64.x.x.130 255.255.255.240

!

interface Ethernet0/1

description inside

nameif inside

security-level 100

ip address 10.50.2.1 255.255.255.0

!

interface Ethernet0/2

nameif dmz1

security-level 50

ip address 10.10.10.2 255.255.255.0

!

interface Ethernet0/3

shutdown

no nameif

no security-level

no ip address

!

interface Management0/0

nameif management

security-level 100

ip address 192.168.1.1 255.255.255.0

management-only

!

ftp mode passive

dns server-group DefaultDNS

same-security-traffic permit inter-interface

same-security-traffic permit intra-interface

access-list icmp extended permit icmp any any

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 10.1.0.0 255.255.0.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 10.2.0.0 255.255.0.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 10.3.0.0 255.255.0.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 10.4.0.0 255.255.0.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 10.5.0.0 255.255.0.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 192.168.2.0 255.255.255.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 192.168.5.0 255.255.255.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 192.168.6.0 255.255.255.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 192.168.220.0 255.255.255.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 192.168.225.0 255.255.255.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 10.6.0.0 255.255.0.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 172.29.16.0 255.255.255.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 172.29.9.0 255.255.255.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 172.29.10.0 255.255.255.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 10.50.6.0 255.255.255.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 10.0.0.0 255.255.0.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 10.50.13.0 255.255.255.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 192.168.200.0 255.255.255.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 192.168.100.0 255.255.255.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 192.168.101.0 255.255.255.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 10.0.0.128 255.255.255.128

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 172.29.210.0 255.255.255.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 192.168.18.0 255.255.255.0

access-list nonat extended permit ip 10.50.2.0 255.255.255.0 172.29.15.0 255.255.255.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 10.1.0.0 255.255.0.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 10.2.0.0 255.255.0.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 10.3.0.0 255.255.0.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 10.4.0.0 255.255.0.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 10.5.0.0 255.255.0.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 192.168.2.0 255.255.255.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 192.168.5.0 255.255.255.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 192.168.6.0 255.255.255.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 192.168.220.0 255.255.255.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 192.168.225.0 255.255.255.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 10.6.0.0 255.255.0.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 172.29.16.0 255.255.255.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 172.29.9.0 255.255.255.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 172.29.10.0 255.255.255.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 10.50.6.0 255.255.255.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 10.0.0.0 255.255.0.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 10.50.13.0 255.255.255.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 192.168.200.0 255.255.255.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 192.168.100.0 255.255.255.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 10.0.0.128 255.255.255.128

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 172.29.210.0 255.255.255.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 192.168.18.0 255.255.255.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 172.29.15.0 255.255.255.0

access-list springfield-bvt extended permit ip 10.50.2.0 255.255.255.0 192.168.101.0 255.255.255.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 10.1.0.0 255.255.0.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 10.2.0.0 255.255.0.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 10.3.0.0 255.255.0.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 10.4.0.0 255.255.0.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 10.5.0.0 255.255.0.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 192.168.2.0 255.255.255.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 192.168.5.0 255.255.255.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 192.168.6.0 255.255.255.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 192.168.220.0 255.255.255.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 192.168.225.0 255.255.255.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 10.6.0.0 255.255.0.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 172.29.16.0 255.255.255.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 172.29.9.0 255.255.255.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 172.29.10.0 255.255.255.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 10.50.6.0 255.255.255.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 10.0.0.0 255.255.0.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 10.50.13.0 255.255.255.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 192.168.200.0 255.255.255.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 192.168.100.0 255.255.255.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 10.0.0.128 255.255.255.128

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 172.29.210.0 255.255.255.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 192.168.18.0 255.255.255.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 172.29.15.0 255.255.255.0

access-list NONAT extended permit ip 10.50.2.0 255.255.255.0 192.168.101.0 255.255.255.0

access-list tac extended permit ip host 10.50.2.164 host 192.168.18.31

access-list tac extended permit ip host 192.168.18.31 host 10.50.2.164

access-list DMZ2IN extended permit tcp host 12.x.x.130 host 12.y.x.130 eq ftp

access-list DMZ2IN extended permit tcp host 12.x.x.130 host 12.y.x.130 eq ftp-data

access-list DMZ2IN extended permit ip any any

access-list DMZ2IN extended permit tcp host 12.x.x.134 host 10.50.2.33 eq 1560

access-list DMZ2IN extended permit tcp host 12.x.x.134 host 10.50.2.32 eq 8888

pager lines 24

logging enable

logging buffer-size 1048576

logging buffered debugging

logging asdm informational

mtu outside 1500

mtu inside 1500

mtu dmz1 1500

mtu management 1500

no failover

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

nat-control

global (outside) 1 interface

global (dmz1) 1 interface

nat (inside) 0 access-list NONAT

nat (inside) 1 10.50.2.0 255.255.255.0

static (inside,dmz1) tcp 10.50.2.32 8888 10.50.2.32 8888 netmask 255.255.255.255

static (inside,dmz1) tcp 10.50.2.33 1560 10.50.2.33 1560 netmask 255.255.255.255

access-group DMZ2IN in interface dmz1

route outside 0.0.0.0 0.0.0.0 64.x.x.129 1

route dmz1 12.x.x.134 255.255.255.255 10.10.10.1 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

aaa authentication ssh console LOCAL

http server enable

http 192.168.1.0 255.255.255.0 management

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto ipsec transform-set esp-aes-sha esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set myset esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto map outside_dynmap 10 match address springfield-bvt

crypto map outside_dynmap 10 set peer 208.x.x.14

crypto map outside_dynmap 10 set transform-set ESP-3DES-MD5

crypto map outside_dynmap 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map outside_dynmap interface outside

crypto isakmp identity address

crypto isakmp enable outside

crypto isakmp policy 4

authentication pre-share

encryption 3des

hash md5

group 2

lifetime 86400

crypto isakmp policy 10

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

crypto isakmp policy 11

authentication pre-share

encryption aes

hash sha

group 2

lifetime 86400

crypto isakmp policy 12

authentication pre-share

encryption des

hash sha

group 2

lifetime 86400

crypto isakmp policy 13

authentication pre-share

encryption aes-256

hash sha

group 2

lifetime 86400

crypto isakmp nat-traversal 21

telnet 0.0.0.0 0.0.0.0 outside

telnet timeout 5

ssh 0.0.0.0 0.0.0.0 outside

ssh 0.0.0.0 0.0.0.0 inside

ssh timeout 30

console timeout 0

management-access inside

dhcpd address 192.168.1.2-192.168.1.254 management

dhcpd enable management

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

tunnel-group 208.x.x.14 type ipsec-l2l

tunnel-group 208.x.x.14 ipsec-attributes

pre-shared-key *****

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

  inspect icmp

  inspect pptp

  inspect ipsec-pass-thru

!

service-policy global_policy global

prompt hostname context

no call-home reporting anonymous

: end

Jon Marshall
Hall of Fame
Hall of Fame

Tyler

From the config -

access-list DMZ2IN extended permit tcp host 12.x.x.130 host 12.y.x.130 eq ftp

access-list DMZ2IN extended permit tcp host 12.x.x.130 host 12.y.x.130 eq ftp-data

access-list DMZ2IN extended permit ip any any

access-list DMZ2IN extended permit tcp host 12.x.x.134 host 10.50.2.33 eq 1560

access-list DMZ2IN extended permit tcp host 12.x.x.134 host 10.50.2.32 eq 8888

this is probably why we aren't seeing any hits because the lines for ports 1560 and 8888 are after the permit ip any any and will never be reached.  There is a good chance the packets are arriving and being allowed through on that interface. So lets assume they are.

global (dmz1) 1 interface

nat (inside) 1 10.50.2.0 255.255.255.0

static (inside,dmz1) tcp 10.50.2.32 8888 10.50.2.32 8888 netmask 255.255.255.255

static (inside,dmz1) tcp 10.50.2.33 1560 10.50.2.33 1560 netmask 255.255.255.255

we also have a conflict with our NAT statements. You are natting the 10.50.2.x addresses to IP of the dmz1 interface ie. 10.10.10.2. Do you know why this is being done ?

Jon

I show no hit counts on:

access-list DMZ2IN extended permit ip any any

I have no clue why that is being done nor understand the purpose.

The ports are defintely TCP and not UDP ?

Can you post the output of this command from the ASA -

sh xlate interface dmz1

Jon

1035 in use, 2086 most used

PAT Global 10.50.2.32(8888) Local 10.50.2.32(8888)

PAT Global 10.50.2.33(1560) Local 10.50.2.33(1560)

I have asked them about TCP vs UDP and will reply when I have an answer back.

What i would like to do is -

1) reorder DMZ2IN acl so the last 2 lines are before the permit ip any any

2) then clear those translations ie.

clear xlate global 10.50.2.32

clear xlate global 10.50.2.33

3) retry the connection and see

a) if the hit cnts increase on the pix

b) if you get any hit cnts on the DMZ2IN acl

trouble is i'm not sure why those global and NAT statements are there in the first place. It could be disruptive to traffic but i don't know what else is travelling between these two interfaces (if anything). What do you think ? 

If not we may have to do packet captures and these can be quite disruptive to the firewalls so its best done at a quiet time.

If you are happy to do the above can you first post -

sh xlate global 10.50.2.32

sh xlate global 10.50.2.33

from the ASA

Jon

DMZ2IN has been re-ordered.

Issued the clear commands.

Connections are still unsuccessful.

Hits increased on the PIX but not on the ASA.

Here are the results from those show commands:

show xlate global 10.50.2.32

508 in use, 2506 most used

PAT Global 10.50.2.32(8888) Local 10.50.2.32(8888)

show xlate global 10.50.2.33

565 in use, 2506 most used

PAT Global 10.50.2.33(1560) Local 10.50.2.33(1560)

As far as the global NATs go I am not knowledgeable enough to answer that. The ASA plugs in to device providing them access to the Internet via a fiber provider that I have no access to. My thoughts were they NAT the 10.50.2.0 to that outside interface for Internet access.

Okay, clear those translations -

clear xlate global 10.50.2.32

clear xlate global 10.50.2.33

as they only refer to the ports we are talking about.

Then can you post - sh xlate interface dmz1

and retry connection.

Jon

Cleared.

Tested and it doesn't work.

show xlate interface dmz1

465 in use, 2506 most used

PAT Global 10.50.2.32(8888) Local 10.50.2.32(8888)

PAT Global 10.50.2.33(1560) Local 10.50.2.33(1560)

PAT Global 10.10.10.2(54893) Local 10.50.2.165(3093)

Review Cisco Networking for a $25 gift card