cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1317
Views
0
Helpful
11
Replies

server mac is not in mac addresstable but i can ping its ip !!!!!!

Dr.X
Level 2
Level 2

hi  ,

i have a strange issue ,

i  have the switch ============>>>>>        

   sw2960g============server linux

as u see above , the inetrface Gi0/6  , Gi0/7  are  connected directly to linux server  by two redundent links .

i mean that Gi0/6 is connected to interface0 in linux server

    and Gi0/7 is connect to interface interface1 in linux server

Gi0/6===>vlan 1

Gi0/7===>vlan 2

each interface of linux server has a different ip and different gateway .

now  from switch , i  make ping to interface 0 of linux server and i have a reply , eevry thing is ok

but when i type the command :

#sh mac address-table  | i Gi0/6

there is no Mac addresses ,  and seems no Mac address relative to Gi0/6 !!!!!!!!!!!!!!!!!!!!!!

i mean that doest it mandatorty to learn the mac address of linux server  and write in mac table  relative beside  interface Gi0/6 ????

how i could ping the server but no mac beside Gi0/6 ??????/

could this be a linux issue ???

could this occurs because of reduntant links to the same server ???

note that STP is enabled on both links

regards

1 Accepted Solution

Accepted Solutions

Hi,

so

ip default-gateway z.z.z.z

in your switch is

ip default-gateway z.z.64.1

in fact?

I.e., you are using the Linux server VLAN1 IP address as the default gateway on your switch?

Then everything is correct:

When Pinging to the Linux server VLAN2 IP address (x.x.150.104) the switch forwards the packet to its default gateway MAC address. The Linux server receives the packet on its VLAN1 interface. It realizes the destination address is its own one (assigned to the VLAN2 interface though) and replies with Echo Reply ICMP packet. As it knows the best routing path to the switch IP address is via interface VLAN1, the Echo Reply packet is sent from the Linux VLAN1 interface again.

So no communication from the Linux interface VLAN2 in fact.

That's why you don't see any packets and no MAC address on the switch port connected to the Linux VLAN2 interface.

The MAC address detected on the Gi0/6 port finally might be a result of some other communication in VLAN2 and probably not related to Pings/traceroutes sent from your switch at all.

HTH,

Milan

View solution in original post

11 Replies 11

cadet alain
VIP Alumni
VIP Alumni

Hi,

what does sh mac address-table dynamic vlan 1 outputs?

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

SW1#sh mac address-table dynamic vlan 1

          Mac Address Table

-------------------------------------------

Vlan    Mac Address       Type        Ports

----    -----------       --------    -----

   1    0008.fc76.701b    DYNAMIC     Gi0/23

   1    0018.1ad2.2324    DYNAMIC     Gi0/5

   1    0026.aaf7.c01b    DYNAMIC     Gi0/10

   1    00d0.d647.c01b    DYNAMIC     Gi0/20

   1    1cbd.b9d7.6d70    DYNAMIC     Gi0/11

   1    503d.efaf.9c40    DYNAMIC     Gi0/5

   1    782b.cb16.5da3    DYNAMIC     Gi0/1

   1    782b.cb16.5da4    DYNAMIC     Gi0/8

   1    b870.f44a.500f    DYNAMIC     Gi0/9

   1    b8ac.6f2b.07d4    DYNAMIC     Gi0/3

   1    b8ac.6f2b.07d6    DYNAMIC     Gi0/3

   1    b8ac.6f2b.0b0d    DYNAMIC     Gi0/7

Total Mac Addresses for this criterion: 12

Hi,

what is the MAC you see for gi0/7 on vlan 1 ?

Can you provide a quick diagram of the topology as well as config from the switch.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

hi sorry agian for the typo ,

agian , the interface of switch is not Gi0/7 that connetced to server , it is Gi0/18 , ive corrected it in the topology and here is the config below :

http://www12.0zz0.com/2012/10/29/14/941737303.jpg

sw1#sh run

Building configuration...

Current configuration : 5774 bytes

!

! Last configuration change at 15:37:16 UTC Sat Oct 13 2012 by xxxx

! NVRAM config last updated at 15:24:46 UTC Tue Oct 23 2012 by xxxxxx

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname sw1

!

boot-start-marker

boot-end-marker

!

enable secret 5 xxxxxxxxxxxxxxxxxxxxxxx

!

username xxxxxxxxxxx password 7 xxxxxxxxxxxxxxxxxxx

!

no aaa new-model

system mtu routing 1500

!

!

no ip domain-lookup

!

!

crypto pki trustpoint TP-self-signed-xxxxxxxxxxx

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-xxxxxxxx

revocation-check none

rsakeypair TP-self-signed-xxxxxxxxxxxx

!

!

crypto pki certificate chain TP-self-signed-xxxxxxxxxx

certificate self-signed 01

  xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

  quit

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

interface Loopback0

ip address 1.1.1.1 255.255.255.0

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

switchport access vlan 13

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

switchport access vlan 22

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/5

switchport mode trunk

load-interval 30

!

interface GigabitEthernet0/6

!

interface GigabitEthernet0/7

!

interface GigabitEthernet0/8

!

interface GigabitEthernet0/9

switchport mode trunk

!

interface GigabitEthernet0/10

switchport mode trunk

load-interval 30

!

interface GigabitEthernet0/11

!

interface GigabitEthernet0/12

switchport access vlan 12

!

interface GigabitEthernet0/13

switchport access vlan 12

!

interface GigabitEthernet0/14

switchport access vlan 12

!

interface GigabitEthernet0/15

switchport access vlan 2

!

interface GigabitEthernet0/16

]

switchport access vlan 2

switchport mode access

load-interval 30

!

interface GigabitEthernet0/17

switchport access vlan 2

!

interface GigabitEthernet0/18

switchport access vlan 2

!

interface GigabitEthernet0/19

switchport access vlan 13

switchport mode access

!

interface GigabitEthernet0/20

switchport mode access

load-interval 30

!

interface GigabitEthernet0/21

switchport access vlan 19

switchport mode access

!

interface GigabitEthernet0/22

switchport access vlan 21

switchport mode access

!

interface GigabitEthernet0/23

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/24

switchport access vlan 22

load-interval 30

media-type sfp

spanning-tree portfast

!

interface Vlan1

ip address x.x.x.x 255.255.255.0

!

interface Vlan13

no ip address

!

interface Vlan19

no ip address

!

interface Vlan34

no ip address

!

interface Vlan90

no ip address

!

interface Vlan91

no ip address

!

ip default-gateway z.z.z.z

ip http server

ip http secure-server

!

ip sla enable reaction-alerts

logging history size 500

no cdp advertise-v2

!======================================

@alain

Hi,

how does the output of traceroute to both Linux IP addresses look like?

As your switch is L2 only having an IP in VLAN1 only configured, it's forwarding packets to the default gateway z.z.z.z.

And this device might be routing the packets with destination=Linux IP address in VLAN2 to the Linux server interface in VLAN1.

The Linux server might then be replying through the VLAN1 interface again.

So in fact, the Linux VLAN2 physical interface  might not be used at all in this topology when pinging from the switch.

HTH,

Milan

Hi,

Look at your config

!

interface GigabitEthernet0/6

!

interface GigabitEthernet0/7

!

Both of these interfaces are in VLAN 1

Also your mac table shows that G10/7 is in vlan 1

1    b8ac.6f2b.0b0d    DYNAMIC     Gi0/7

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.

hi

Alex. ,

ive coretced my typo ,

i said that inteface 0/6 & 0/18 are connected to the linux server .

=====================

@millan

look ,

the linxu server has two interfaces each one has its ip and default gateway ,

anyway ,

i can ping both ips of linux server from the swithc ,

but the traceroute is only on succed and the other is not ,

here is tracing the port in vlan 1

sw1#traceroute x.x.150.104    

Type escape sequence to abort.

Tracing the route to x.x.150.104

  1 z.z.64.1 8 msec 0 msec 0 msec

  2 x.x.150.104 0 msec 0 msec 0 msec

here tracing linux server in vlan 2

sw1#traceroute a.a.67.251

Type escape sequence to abort.

Tracing the route to a.a.67.251

  1 x.x.64.1 9 msec 0 msec 0 msec

  2  ?  ?  ?

  3  ?  ?  ?

  4  *  ?  ?

  5  ?  *  ?

  6  ?  ?  *

  7  ?  ?  ?

  8  *  ?  ?

  9  ?  *  ?

10  ?  ?  *

11  ?  ?  ?

=======================

ping results :

sw1#ping x.x.150.104

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to x.x150.104, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms

sw1#ping a.a.67.251

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to a.a.67.251, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

hi ,

after alot of pngs and traceroutes

the mac has appeared now :

   1    b8ac.6f99.94fa    DYNAMIC     Gi0/6

sw1#sh mac address-table | i Gi0/6

   1    b8ac.6f99.94fa    DYNAMIC     Gi0/6

sw1#sh mac address-table | i Gi0/18

   2    b8ac.6f99.94f9    DYNAMIC     Gi0/18

   2    b8ac.6f99.94fb    DYNAMIC     Gi0/18

sw1#

but im stranging why there are two macs on interface Gi0/18 ???!!!!!!

i mean  sw is connected only to one interface card ?? why 2 interfaces appeared ??!!!

also i dont know how the interface Gi0/6 learned finnally the mac address !!!

regards

Hi,

so

ip default-gateway z.z.z.z

in your switch is

ip default-gateway z.z.64.1

in fact?

I.e., you are using the Linux server VLAN1 IP address as the default gateway on your switch?

Then everything is correct:

When Pinging to the Linux server VLAN2 IP address (x.x.150.104) the switch forwards the packet to its default gateway MAC address. The Linux server receives the packet on its VLAN1 interface. It realizes the destination address is its own one (assigned to the VLAN2 interface though) and replies with Echo Reply ICMP packet. As it knows the best routing path to the switch IP address is via interface VLAN1, the Echo Reply packet is sent from the Linux VLAN1 interface again.

So no communication from the Linux interface VLAN2 in fact.

That's why you don't see any packets and no MAC address on the switch port connected to the Linux VLAN2 interface.

The MAC address detected on the Gi0/6 port finally might be a result of some other communication in VLAN2 and probably not related to Pings/traceroutes sent from your switch at all.

HTH,

Milan

hi  millan , thanks very much for your explanation

regards

Review Cisco Networking for a $25 gift card