cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
277
Views
20
Helpful
4
Replies
Highlighted
Beginner

Setting up EIGRP and having issues pining across networks

Hello, I last dived in to working with Cisco's quite a long time ago, and trying to get back into it, but I'm struggling with getting EIGRP working.  Both routers are seeing each other (both got the new adjacency message).  I setup two computers on each switch with static IP's just to keep it easy.  Computer on Switch 1 with Router 1, can ping Router 1 just fine, and the IP of Router 2 that is on Switch 1 as well.  Computer on Switch 2 can ping both interfaces on Router 2, but packets are not coming back from Router 1 when attempting to ping it.  Tracing the packet shows it's making it to Router 1, but it's not responding to the pings.

 

To simplify, here's the topology in packet tracer I designed, just to experiment with.

 

Here are the configurations on the routers, starting with Router 1.

Building configuration...

 

Current configuration : 633 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

ip cef

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.1.1.1 255.0.0.0

duplex auto

speed auto

shutdown

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

!

interface Vlan1

no ip address

shutdown

!

router eigrp 10

network 192.168.1.0

auto-summary

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

----------------------------------------------

Now Router 2.

Building configuration...

 

Current configuration : 627 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

ip cef

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.1.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 172.24.1.1 255.255.0.0

duplex auto

speed auto

!

interface Vlan1

no ip address

shutdown

!

router eigrp 10

network 192.168.1.0

auto-summary

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

----------------------------------------

For a bit of hands on, I'm also working with real hardware, and implimented the same thing, still getting the same issue as well, so I'm sure I'm just missing something obvious, but hopefully some fresh eyes will help me.  Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

yeah, exactly, add it in and do the same on the other router, for its subnet.  the do a sh ip route on each router and see if it learned the new route.

 

let me know how you go

Please remember to rate useful posts, by clicking on the stars below.

View solution in original post

4 REPLIES 4
Highlighted
VIP Advisor

your eigrp network statements are not including all interfaces? have you done this on purpose, for instance:

 

172.24.1.1  is not advertised out

Please remember to rate useful posts, by clicking on the stars below.

Highlighted

No, this is not on purpose..  I'm new, I don't know what to do.

 

Can you assist in helping me learn how I should be having EIGRP work on all interfaces?  I assumed it happened by default.

 

EDIT:  Wait, would that be adding "network 172.24.0.0 0.0.255.255"?

Highlighted

yeah, exactly, add it in and do the same on the other router, for its subnet.  the do a sh ip route on each router and see if it learned the new route.

 

let me know how you go

Please remember to rate useful posts, by clicking on the stars below.

View solution in original post

Highlighted

Hey, perfect!  It worked on Packet Tracer.  Oddly it didn't actually work on the real hardware we have setup, but the only difference as of right now, is the real hardware we have setup, Router 1 also is doing a NAT to my primary network.  Perhaps the NAT and EIGRP are fighting each other?  Either way, your answer is exactly what I needed, to get this ball rolling, thank you very much.

Content for Community-Ad