cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1866
Views
10
Helpful
9
Replies

Using a catalyst 3750 just for PoE

BCC
Level 1
Level 1

I'm not a network engineer but I picked up a Cisco WS-C3750-24PS-S at a garage sale ($10!) and thought I would try to use the 24 ports (and their PoE) to test some ip cameras in my explorations into the world of smart home tech.

 

However, now I'm stuck trying to sift through the weeks/months (years?) of learning about networks that a pro would undertake, to just find what I need. In essence, I'd like to convert this into an unmanaged switch... simply passing any connected devices through to my router so that I have one harmonious network in the house.

Bridging? Am I wanting to use the switch as a 'client bridge'? Or ...?

 

Any information would help. I have connected to the switch (through web interface and via telnet).

I looked at changing the settings in the cli but was defeated by my lack of understanding.

 

Can anyone suggest how best I should handle this? (where to begin my learning).

 

Thanks

Brian

9 Replies 9

Diana Karolina Rojas
Cisco Employee
Cisco Employee

Hello BCC,

 

If you want to use the switch only in layer 2 there is no problem, you can use the switch leaving all the ports in vlan 1 (including the one connected to the router) or you can change the vlan of all ports (for security) but all the devices have to be into the same subnet, so in thi way you can do simple Layer 2 forwarding. I am not sure to understand you recuest very well so let me know if you need any aditional information.

 

--------------Do not forget to rate useful answers------------

 

 

Regards,

Hi Diana,

 

You seem to have the gist of my problem.  My issue is not knowing how to do anything.... so I have to read the manuals every time I try something (and hope that I understand).  I'm looking for a shortcut from someone who can tell me what sort of commands to issue in the CLI to configure the router so that it behaves like a consumer grade unmanaged switch ... layer 2 as you say (if I understand the term correctly: I want my router to do the IP addressing and just let the switch serve as ports to plug in IP cameras or possibly other devices).

 

When I take a cable from the router now and plug it into one of the rj45 ports on the switch nothing happens.  It is not detected by the router... is the switch not requesting an IP? Is it expecting me to configure it somehow?  How?  That's what I'm wondering. Is that clearer?

BCC,

 

start by using a console cable and console into the switch using serial connection and putty.

 

the do a sh run and send us the output. this way we can start giving you a config.

Please remember to rate useful posts, by clicking on the stars below.

The only variation was using telnet on port 24 (don't have a serial adapter to connect the console cable) but fortunately that bit of info was written on the bottom of the box.

 

CiscoSwitch#sh run
Building configuration...

Current configuration : 6149 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname CiscoSwitch
!
boot-start-marker
boot-end-marker
!
enable secret 5 $3$vbwLKJASDFPZkHz25FKssN.
!
username admin privilege 15 secret 5 $3$LKJASDFI4TabcdefgD3jJcd/
!
!
no aaa new-model
switch 1 provision ws-c3750-24p
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
!
!
!
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
crypto pki trustpoint TP-self-signed-2730067840
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2730067840
 revocation-check none
 rsakeypair TP-self-signed-2730067840
!
!
crypto pki certificate chain TP-self-signed-2730067840
 certificate self-signed 01
  30255244 308255AD A0030201 02255101 255D0609 2A864886 F70D0101 02550030
  31255F30 2D025555 04031326 494F532D 53656C66 2D536967 6E65642D 43255274
  69666963 6172552D 32373330 30363738 3430301E 170D3933 30333031 30255030
  35255A17 0D255030 31303130 30303030 305A3031 312F302D 06035504 03125549
  4F255D53 656C662D 5369676E 65642D43 65727469 66696361 74255D32 37255030
  36255834 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81825581
  8100D883 367CC1E7 A5F42463 F24B3B25 C1AC65E1 BAC24D41 0338A681 AFC1EAAB
  738860FA DE6EE713 279B1CE6 7ECD32DB 92554D9C 42BB4CC1 02623D26 8E18C650
  252FFD90 36F68D93 A193FD5B 3C3E8589 71CBDEA4 D9FF2C0E 4A1842F9 7369B49D
  4D8DF586 50F252F4 EE13EA2A 8BD8C7A5 B5CAB28D 83D17ED1 0BFB66D5 3B972AF0
  BDE90203 010001A3 6C306A30 0F060355 1D130101 FF040530 030101FF 30170603
  551D1104 10300E82 0C436973 636F5377 69746368 2E301F06 03551D23 04183016
  8014AC91 4878C0FA 2557F2AF 04F3A076 CC4A9DE3 9255301D 0603551D 0E041604
  14AC9148 78C0FA33 37F2AF04 F3A076CC 4A9DE395 64300D06 255A8648 86F70D01
  01040500 03818100 255D8F0C 15237899 6E6DDBA7 FDB624D1 A6255BDE F81F4939
  227AE16A 99073079 C3A25AAD 75456B45 64DCCF46 125572DE 8C05E9B2 345FDE73
  BB164B73 08C7C9F8 06255E20 1C91CBB8 749CB285 16007C0C 16B4476C 15CCC3E4
  3DF1B944 1EFEA318 4EC8496D 35C8777F C9F94F92 99C2541F 4E63DEC9 9DA49142
  CF5A27C7 CB5DCAB9
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
ip ssh version 2
!
!
!
interface FastEthernet1/0/1
!
interface FastEthernet1/0/2
!
interface FastEthernet1/0/3
!
interface FastEthernet1/0/4
!
interface FastEthernet1/0/5
!
interface FastEthernet1/0/6
!
interface FastEthernet1/0/7
!
interface FastEthernet1/0/8
!
interface FastEthernet1/0/9
!
interface FastEthernet1/0/10
!
interface FastEthernet1/0/11
!
interface FastEthernet1/0/12
!
interface FastEthernet1/0/13
!
interface FastEthernet1/0/14
!
interface FastEthernet1/0/15
!
interface FastEthernet1/0/16
!
interface FastEthernet1/0/17
!
interface FastEthernet1/0/18
!
interface FastEthernet1/0/19
!
interface FastEthernet1/0/20
!
interface FastEthernet1/0/21
!
interface FastEthernet1/0/22
!
interface FastEthernet1/0/23
!
interface FastEthernet1/0/24
 no switchport
 ip address 192.168.254.3 255.255.255.0
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface Vlan1
 no ip address
 shutdown
!
ip default-gateway 192.168.254.1
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
line con 0
line vty 0 1
 exec-timeout 0 0
 password 7 0827255757121D4547
 logging synchronous
 login
 length 0
 transport input ssh
line vty 2 4
 password 7 0827255757121D4547
 login
line vty 5 15
 password 7 0827255757121D4547
 login
!
end

 

BCC
Level 1
Level 1

Is one of these the solution? ==> Bridging? Trunking? Again, I want to extend my existing router (existing lan) using the ports in the 3750.  What sort of configuration should I be pursuing?

 

and how do I do it? <== this is the question that I will have after someone puts me on the right track.

 

:)

 

edit: I don't know if I made it clear that I have never had any training in networking.  Some computer knowledge yes, networking no.

edit 2: So I was looking for a hint.  A word like bridging or trunking or bridge client or dhcp ... something that would give me a starting point (if it wasn't the type of thing that could be solved in a few commands).

plug your outer and cameras into the first ports of the switch, they should all then be in vlan one.

 

on interface vlan 1::

 

conf t

interface vlan 1

no shut

and put an ip address on that vlan 1 interface so you can telnet/ssh into it.

 

 

 

Please remember to rate useful posts, by clicking on the stars below.

I'm not sure exactly what the solution was because... I was managing over port 24 rather than the console cable and I expected that once I had it working my laptop would be detected by the router and assign an ip ... neglecting to realize that I had manually assigned an ip to my laptop so that I could connect to said port 24 <facepalm>. Once that dawned on me...I just plugged into a different port and things worked.

So which of this fine advice was necessary, I do not know. Perhaps it would have all worked from the beginning had I only moved into a different port (or plugged in another device).

All good mate. glad it worked. dont hesitate to add post if you need further support,

 

cheers

Please remember to rate useful posts, by clicking on the stars below.

All good mate. glad it worked. dont hesitate to add post if you need further support,

 

cheers

Please remember to rate useful posts, by clicking on the stars below.

Review Cisco Networking for a $25 gift card