cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
7415
Views
0
Helpful
2
Replies

Setting up Router to connect to NON-Cisco Router

jorgeflores4
Level 1
Level 1

Hello community, I am very new to using the CISCO IOS. I would greatly appreciate all recommendations and feedback from this.

Here is the situation:

I have a CISCO 851W router in the garage that I want to connect to my Linksys router in the office, which is connected to the internet.

The 851W is connected from it's WAN port to Lan port 1 of the Linksys router. Now, currently that ethernet cable is a straight-through cable. Does it have to be crossover? If so, I can fix that.

So I have no idea how to give the 851W internet access. I will leave it to you guys to recommend what IP to assign the router and subnet.

I am assuming I need to confgiure the following:

RIP

NAT

FastEthernet0

WAN

Dot11Radio0 (wireless)

default gateway

Home_Schema.jpg

Router_visual.jpg

2 Replies 2

jorgeflores4
Level 1
Level 1

Here is my show run...I have no idea what I am doing...

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Garage

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$j9BM$8Xc5hEj79he55z/eEs6wl.

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

ip cef

no ip domain lookup

login on-success

!

!

!

!

!

!

!

!

interface Loopback0

ip address 1.1.1.1 255.255.255.0

!

interface FastEthernet0

no cdp enable

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

ip address 192.168.2.1 255.255.255.0

ip nat outside

ip virtual-reassembly

ip route-cache same-interface

no ip route-cache cef

no ip route-cache

duplex auto

speed auto

no cdp enable

!

interface Dot11Radio0

ip address 192.168.3.1 255.255.255.0

!

encryption mode ciphers tkip

!

ssid GarageRouter

    authentication open

    authentication network-eap *******************

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

channel 2462

station-role root

Hi

Yes you are right in using a straight through as ports 1-4 on a linksys area esentially as switch For conectivity you will either need to have NAT on your 851W or RIP on both. Just for simplicity I'd use NAT which it looks like is already half set up. first you need an access-list to tell the router which addresses are allowed out through the NAT which you do by running

enable

configure terminal

    (to enter config mode)

then run:

ip access-list standard NAT

permit any

exit

then from here we can set the address of you wan interface which is FastEthernet4 so we run in config mode

interface fastethernet4

ip address 192.168.1.10 255.255.255.0

interface fastethernet0

ip address 192.168.10.1 255.255.255.0

ip nat inside

exit

then we create a default route so that the traffic actually gets out so we run

ip route 0.0.0.0 0.0.0.0 192.168.1.1 (or whatever the ip of the linksys is)

then the NAT by running

ip nat inside source list NAT interface fastethernet4 overload

and that should be it!

you will now have internet access from behind your 851W but you will not be able to talk to anything behind it from the linksys and looking at you picture I'm guessing you want to be able to chat with the server from the PCs off of the linksys so you'll have to do a static NAT or a port forward.

you can either run

ip nat inside source static serverip 192.168.1.11 (which will enable you to talk to the server on 192.168.1.11 as if it was just directly connected to linksys, or you could run

or

ip nat inside source static (tcp/udp) severip serverportnumber 192.168.1.10 portnumberyouwishtouse (could be the same as the server one or different)

the second is definately the most tricky of the two as you will need to know the ports you will be using but either should work.

 

Sorry about the wall of text

Hope this helps!!

Barry

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card