04-01-2013 02:00 PM - edited 03-07-2019 12:34 PM
I have a Cisco SG 300 28 port switch that I have set in Layer 3 mode. I set up a second VLAN on it (vlan 4). I also set up the scope for DHCP on a Windows server for both VLAN's. The problem I am having, is that VLAN 4 is not pulling DHCP at all. The DHCP server is connected to port 1 on the switch, and the specifics are as follows:
VLAN 1: 192.168.5.251 subnet 255.255.255.0
VLAN 4: 192.168.55.251 subnet 255.255.255.0
DHCP Server 192.168.5.1
Here is the current config:
***************************************************************************************************************************************************
config-file-header
SP-SW1
v1.2.9.44 / R750_NIK_1_2_584_002
CLI v1.0
file SSD indicator excluded
@
vlan database
vlan 4
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
ip dhcp snooping
ip dhcp snooping information option allowed-untrusted
ip dhcp relay address 192.168.5.1
ip dhcp relay enable
ip dhcp information option
bonjour mode include
bonjour interface range vlan 1
hostname SP-SW1
username cisco password encrypted d2af3f31b3af51945646942749ee1ce9019a73dc privilege 15
ip name-server 192.168.5.1
ip telnet server
!
interface vlan 1
ip address 192.168.5.251 255.255.255.0
no ip address dhcp
ip dhcp relay enable
!
interface vlan 4
name Guest
ip address 192.168.55.251 255.255.255.0
ip dhcp relay enable
!
interface gigabitethernet1
description SPDC1
ip dhcp snooping trust
spanning-tree portfast
switchport mode access
!
interface gigabitethernet2
spanning-tree portfast
switchport mode access
!
interface gigabitethernet3
spanning-tree portfast
switchport mode access
!
interface gigabitethernet4
spanning-tree portfast
switchport mode access
!
interface gigabitethernet5
spanning-tree portfast
switchport mode access
!
interface gigabitethernet6
spanning-tree portfast
switchport mode access
!
interface gigabitethernet7
spanning-tree portfast
switchport mode access
!
interface gigabitethernet8
spanning-tree portfast
switchport mode access
!
interface gigabitethernet9
spanning-tree portfast
switchport mode access
!
interface gigabitethernet10
spanning-tree portfast
switchport mode access
switchport access vlan 4
!
interface gigabitethernet11
spanning-tree portfast
switchport mode access
!
interface gigabitethernet12
spanning-tree portfast
switchport mode access
!
interface gigabitethernet13
spanning-tree portfast
switchport mode access
!
interface gigabitethernet14
spanning-tree portfast
switchport mode access
!
interface gigabitethernet15
spanning-tree portfast
switchport mode access
!
interface gigabitethernet16
spanning-tree portfast
switchport mode access
!
interface gigabitethernet17
spanning-tree portfast
switchport mode access
!
interface gigabitethernet18
spanning-tree portfast
switchport mode access
!
interface gigabitethernet19
spanning-tree portfast
switchport mode access
!
interface gigabitethernet20
spanning-tree portfast
switchport mode access
!
interface gigabitethernet21
spanning-tree portfast
switchport mode access
!
interface gigabitethernet22
spanning-tree portfast
switchport mode access
!
interface gigabitethernet23
spanning-tree portfast
switchport mode access
!
interface gigabitethernet24
spanning-tree portfast
switchport mode access
!
interface gigabitethernet25
spanning-tree guard root
switchport trunk allowed vlan add 4
!
interface gigabitethernet26
spanning-tree guard root
switchport trunk allowed vlan add 4
!
interface gigabitethernet27
spanning-tree guard root
switchport trunk allowed vlan add 4
!
interface gigabitethernet28
switchport trunk allowed vlan add 4
!
ip helper-address all 192.168.5.1 37 42 49 53 137 138
*********************************************************************************************************************************************
I have the ip helper-address set to all because I couldn't get it to take any other command. I tried attaching the ip helper-address just to the vlan 4 interface but received the following error:
SP-SW1#conf t
SP-SW1(config)#int vlan 4
SP-SW1(config-if)#ip helper-address 192.168.5.1
% missing mandatory parameter
SP-SW1(config-if)#
Solved! Go to Solution.
04-01-2013 03:04 PM
Hello
Is the dhcp scope in the windows server authorised and active?
I cannot see ip routing enable on this switch?
res
Paul
Please don't forget to rate any posts that have been helpful.
Thanks.
04-01-2013 02:21 PM
hello,
disable dhcp snopping and verify is dhcp relay is working properly
Sent from Cisco Technical Support Android App
04-01-2013 02:39 PM
Thanks for the info. I just tried disabling IP Snooping and it still does not work. When I attach a computer to port 10 (vlan4) I get no dhcp address. Here is the updated config:
*************************************************************************************************************
config-file-header
SP-SW1
v1.2.9.44 / R750_NIK_1_2_584_002
CLI v1.0
file SSD indicator excluded
@
vlan database
vlan 4
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
ip dhcp relay address 192.168.5.1
ip dhcp relay enable
ip dhcp information option
bonjour mode include
bonjour interface range vlan 1
hostname SP-SW1
username cisco password encrypted d2af3f31b3af51945646942749ee1ce9019a73dc privilege 15
ip name-server 192.168.5.1
ip telnet server
!
interface vlan 1
ip address 192.168.5.251 255.255.255.0
no ip address dhcp
ip dhcp relay enable
!
interface vlan 4
name Guest
ip address 192.168.55.251 255.255.255.0
ip dhcp relay enable
!
interface gigabitethernet1
description SPDC1
spanning-tree portfast
switchport mode access
!
interface gigabitethernet2
spanning-tree portfast
switchport mode access
!
interface gigabitethernet3
spanning-tree portfast
switchport mode access
!
interface gigabitethernet4
spanning-tree portfast
switchport mode access
!
interface gigabitethernet5
spanning-tree portfast
switchport mode access
!
interface gigabitethernet6
spanning-tree portfast
switchport mode access
!
interface gigabitethernet7
spanning-tree portfast
switchport mode access
!
interface gigabitethernet8
spanning-tree portfast
switchport mode access
!
interface gigabitethernet9
spanning-tree portfast
switchport mode access
!
interface gigabitethernet10
spanning-tree portfast
switchport mode access
switchport access vlan 4
!
interface gigabitethernet11
spanning-tree portfast
switchport mode access
!
interface gigabitethernet12
spanning-tree portfast
switchport mode access
!
interface gigabitethernet13
spanning-tree portfast
switchport mode access
!
interface gigabitethernet14
spanning-tree portfast
switchport mode access
!
interface gigabitethernet15
spanning-tree portfast
switchport mode access
!
interface gigabitethernet16
spanning-tree portfast
switchport mode access
!
interface gigabitethernet17
spanning-tree portfast
switchport mode access
!
interface gigabitethernet18
spanning-tree portfast
switchport mode access
!
interface gigabitethernet19
spanning-tree portfast
switchport mode access
!
interface gigabitethernet20
spanning-tree portfast
switchport mode access
!
interface gigabitethernet21
spanning-tree portfast
switchport mode access
!
interface gigabitethernet22
spanning-tree portfast
switchport mode access
!
interface gigabitethernet23
spanning-tree portfast
switchport mode access
!
interface gigabitethernet24
spanning-tree portfast
switchport mode access
!
interface gigabitethernet25
spanning-tree guard root
switchport trunk allowed vlan add 4
!
interface gigabitethernet26
spanning-tree guard root
switchport trunk allowed vlan add 4
!
interface gigabitethernet27
spanning-tree guard root
switchport trunk allowed vlan add 4
!
interface gigabitethernet28
switchport trunk allowed vlan add 4
!
ip helper-address all 192.168.5.1 37 42 49 53 137 138
***********************************************************************************************
04-01-2013 03:04 PM
Hello
Is the dhcp scope in the windows server authorised and active?
I cannot see ip routing enable on this switch?
res
Paul
Please don't forget to rate any posts that have been helpful.
Thanks.
04-02-2013 08:34 AM
Thank you, adding an IP route fixed it. I hadn't added the Internet route yet because I was trying to get it configured before adding it to the network, and it wouldn't let me add the route to 0.0.0.0 without the firewall connected.
The reason you did not see IP Routing enabled yet is because I was planning on putting this as the default gateway for all devices, but could not at the time because the firewall was not plugged into it yet. (Couldn't make that change while users were accessing the network), and without the firewall plugged in it was giving me an error when I tried to input the route to 0.0.0.0.
I plugged the firewall into this device and then added the following
ip route 0.0.0.0 0.0.0.0 192.168.5.254
Once I added that route, the DHCP started working on VLAN 4.
Thanks again.
04-04-2019 01:08 AM
04-01-2013 03:12 PM
Try giving command
ip-helper address (DHCP Server IP under Vlan)
Do Rate All Helpful Posts
04-02-2013 08:29 AM
I had already tried that and I received an error. The only option I was given on this switch was to do the ip helper-address x.x.x.x all parameter. See error below:
SP-SW1#conf t
SP-SW1(config)#int vlan 4
SP-SW1(config-if)#ip helper-address 192.168.5.1
% missing mandatory parameter
SP-SW1(config-if)#
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide