cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1247
Views
0
Helpful
9
Replies

SG350 can't send commands through Plink

Christie Brinker
Beginner
Beginner

I've been using a script on a BUNCH of SG300's and it works just fine. But now I have an SG350 and the script won't work. Essentially it's calling plink.exe and pointing to a TXT file telling the switch to run commands (a simple sh ver, sh run).

 

I cannot get the SG350 to run any "remote" commands via plink, openssh, or Posh-SSH. Basically when I send any kind of remote command to it, it just sits there until timeout. Anyone else experienced this? If I manually run the commands by establishing the connection via plink and manually typing sh ver and sh run, they do of course run.

9 Replies 9

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

Do you see any Logs on the device ?

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Nope. If I try to use a txt file with plink to pass through the commands I do get an error from plink that says:

Received disconnect from device.

Packet integrity error

 

It's interesting because it will receive the command and start processing it, and then it will do the packet integrity error very quickly and disconnect.

i do not believe this is an error from the switch, i believe this is Plink may have a compatibility issue with new SSH v2

 

try any other program if you can able to use it? like Linux bash with expect command.

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

I feel like you're right. Like I mentioned I've tried plink, klink, Posh-SSH, OpenSSH. So apparently none of these can work with the new SSH. I can't do linux unfortunately as this is at a customer location and they do not have resources for that.

i can understand, there is a way you can do using PowerShell scripting. (example : https://github.com/Nevets82/Posh-Cisco)

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Posh-Cisco says its for Catalyst switches, the small business switches like the SG350 don't behave the same way. Also I believe Posh-Cisco is built off Posh-SSH which I tried and didn't work. Have you used Posh-Cisco on the SG350?

I do not have any SMB switches to test, i work more on Enterprise switches.. iam afraid, i only try to help as per your problem description.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

 

are you using Plink as part of Putty ? If not, or if, make sure you are using the latest version of Putty (0.73 I think), and try again...

Stefan S
Beginner
Beginner

Hey Christie,

did you solved the issue? I have exactly the same behavior.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers