Showing results for 
Search instead for 
Did you mean: 

[Solved] Cisco UC520 Unable to connect to internet

Level 1
Level 1


I am a student and next year we get the subject Cisco. So, I was allowed to take an old Cisco router from my work and use it to practise my command line skills and learn some stuff so that next year would be easier.

Because I don't have any experience with the command line, I decided to configure the router first with the Cisco Configuration Assistant and safe a back-up from the settings and then go learning the command line and practise the command line.

So, I configured the router perfectly. a couple of vlans, wifi networks, every single thing works. If I connect a computer to it, it get's an IP adress and everything works nicely. Except for one thing, I don't have internet access.

I have the following network setup:

Modem -> Sitecom Router (this one works) -> Cisco router

I hooked up one of the lan ports from the Sitecom router to the WAN port of the Cisco router, this should work, but it doesn't.

Then I tried connecting the WAN port of the Cisco router directly to the modem, as described in the Quick Start Guide, but that doesn't work either.

Yes, the WAN Port is active and configured as DHCP not Static or PPPoE.

NAT is turned off, but that should make a difference according to my collegue (if we are wrong feel free to tell).

If I look in the Sitecom router connected computers list, I don't see the Cisco router either. It looks like it doesn't have a MAC adress. But if I go to the command line and go to the interfaces bit. I see the "$FW_OUT" or something like that with an MAC address. I put that address with a static ip in my Sitecom router, but it doesn't recognize my Cisco router, so it can't give that ip.

Does anyone know how to fix this???

It should be possible to get it working right?

Kind Regards,

38 Replies 38

Okay, I still can't get an ip address from vlan1 and with the other vlans I still can't reach the internet.

And the default data dhcp pool isn't coupled to vlan1.

But the good news is, all the vlans have ip nat inside on them and fa0/0 has still got nat outside.

I also added a new show run, so you can see if I fixed my mess.

Somehow you have removed the network statement from your data dhcp scope.

Do this:

#conf t

#ip dhcp pool data


and access-list 1 has been removed.

Do this:

#conf t

#access-list 1 permit

#access-list 1 permit

#access-list 1 permit

#access-list 1 permit

I have just one question for myself, how did I create such a mess

But it works now, for all the vlans.

I tested it, with my psp on the wifi network. Guest network and private network. It all works nicely.

There is only one thing I'm not so sure about, that's the network name.

When I connect via a lan cable, vlan2 is named "Hopeloos@Den_Helder 2" and the other vlans are named "network 6", "network 7", etc.

Is it possible to change this?

It's not a priority, but it would be cool if I could change it to Hopeloos@Cisco_Private, Hopeloos@Cisco_Gasten, etc.

By the way, hopeloos means hopeless in English, quite a suitable name for my network

And because I want to learn the CLI commands, what are the commands for saving the configuration/current settings?

Thank you so much, it now really works for all vlans!

Not really sure what you mean about the network name. Do you mean when you do an "ipconfig /all" on your PC that is what the connection is called?

To save your current config just do a "copy run start". Another useful tip is to save your config to flash. If you are experimenting with different options you may want to have a "known good" configuration that you can roll back to. For example:

#copy run start

#copy run flash:working-config-28-06-2013

That would save the current config to NVRAM and then save it to flash with the filename "working-config-28-06-2013". Then if later you break everything you can restore back to this point with:

#copy flash:working-config-28-06-2013 run

Saving to the flash card is a very very very good idea to do.

Because I plan to mess with it a bit to learn the CLI commands, so having a back-up of a working config, might become handy.

I mean when I'm in windows 7, I go to the network and sharing centre and I see uknown network for the VMware Adapters, and a Home network that is named Hopeloos@Den_Helder 2 (my Sitecom router's name, but only with a "2" added to the name) or when I'm connected to the guest vlan it says "Network 7".

If I hover my mouse over the LAN icon in windows, it also says "Connected to Hopeloos@Den_Helder 2" or "Connected to Network 7".

It's not anoing or something nor a must have, but it just looks nicer when it says "Hopeloos@Cisco_[vlan name]" (for example Hopeloos@Cisco_Private or Hopeloos@Cisco_Gasten).

I don't really care about ipconfig, I don't use that often.

I don't know where Windows gets those names from to be honest - you can add a domain suffix on the DHCP pool but I don't think that is it.

Doesn't matter, as I said, it's just a funny extra not really a must have.

By the way, I tried that copy command. And the CLI says it's succesful. But when I look in the ftp of the Configuration Assistant I don't see that file in the list.

Is there a command to show the contents of the flash card?

EDIT: Found it, it was show flash, easy, piece of cake

But the back-up was saved as Y, because when I was asked to use "working-backup" as filename I thought I had to enter Yes or No, but I was supposed to enter the filename I wanted or press enter 2 times.

So, what is the delete command?

EDIT2: I found the delete command, I just typed "del ?" and then "del flash:y" and pressed 2 times on enter. And it worked.

It won't be on the FTP server because you are saving the config to the local flash on the router.

To save to an external server (i.e. off the box) you would do:

#copy run tftp


#copy run ftp

When it asks for confirmation you can just hit enter to accept the name that it suggests.


is an easy command to see the contents of your flash.

Okay, that ftp command works, except that I need an ftp server to save the file to.
I tried the Zymic webhost where I have my webhost, but it couldn't find my domain name.

Then I tried my laptop, it sends, but my laptop doesn't receive.

The good news is, if I can find a card reader somewhere with compact flash support, I can copy the file manually.

Thank you for your help!

Review Cisco Networking for a $25 gift card