cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1970
Views
0
Helpful
5
Replies
Highlighted
Beginner

[Solved]Ghost Multicast Vs 3750G

Hi,

I manage a network with a ghost server, a 3750G, several outside access, and some vlans.

This is a very simplify view of this network:


http://img708.imageshack.us/img708/9977/simplenet.jpg

I'm facing an unusual problem for me as I build these kind of config since a long time without any problem.

The ghost server is on all vlans connected to a trunk port on the 3750G which is used as a central switch and for basic routing.

All equipements connected to vlans 1, 2 or 3 are on 2950 switchs themselves connected to the 3750G on dedicated access ports, each

in there respective vlans.

All equipements connected to vlans 1, 2 or 3 have as gateway a vlan interface on the 3750. (10.0.x.3)

All the vlan interfaces have route-maps applied on them to redirect traffic to their dedicated outside access.

The route-maps match only traffic destinated to the outside.

Everthing is working well but the multicast.

When I create a ghost session on the server, I can see computer connecting on it, but the multicast never start.

If I use directed broadcast it works with good perfs, but the CPU processes of the 3750 go high because of the IP Input (Till 99%).

If I remove the route map from the vlan interface which is on the ghosted network, the multicast works but with poor perfs.

If I shutdown the vlan interface the multicast works well with good perfs.

It seems my problems are tied with the Vlan interfaces but I don't know why.

This is a sample of the config:

switch 1 provision ws-c3750g-24ts-1u

system mtu routing 1500

vtp domain SM

vtp mode transparent

ip routing

no ip domain-lookup

ip domain-name SM-Net

no ip dhcp use vrf connected

ip dhcp excluded-address 10.0.1.1 10.0.1.200

!

ip dhcp pool Salle-1

   network 10.0.1.0 255.255.255.0

   default-router 10.0.1.3

   dns-server 10.0.1.1

!

errdisable recovery cause channel-misconfig (STP)

errdisable recovery interval 30

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan 101

name Net-1

!

interface GigabitEthernet1/0/25

description Connected_to-Switch-Net-1

switchport access vlan 101

switchport mode access

switchport nonegotiate

!

interface Vlan101

description Net-1

ip address 10.0.1.3 255.255.255.0

ip access-group Network-Rules in

ip policy route-map Network-Balancer

!

ip access-list extended Outside_1

deny   pim any any

deny   igmp any any

deny   ip 10.0.0.0 0.0.255.255 10.0.0.0 0.0.255.255

permit ip 10.0.1.0 0.0.0.255 any

!

ip access-list extended Network-Rules

deny   ip any host 10.0.1.255 log

deny   pim any any

deny   igmp any any

deny   ip host 10.0.1.2 any

deny   udp any 224.77.0.0 0.0.255.255 eq 2446

deny   udp any 224.77.0.0 0.0.255.255 eq 5355

deny   udp any 224.77.0.0 0.0.255.255 eq 7777

deny   udp any 224.77.0.0 0.0.255.255 eq 6666

deny   udp host 10.0.1.2 any (10.0.1.2 = Ghost Server)

deny   tcp host 10.0.1.2 any

permit icmp any any

permit ip any any

permit gre any any

permit esp any any

!

route-map Network-Balancer permit 20

match ip address Outside_1

set ip next-hop 11.0.0.1

!

End

This is a very simplify sample of the config but all needed is in.

If someone could help it would be great.

Thx by advance for your help

Regards

FB

5 REPLIES 5
Highlighted
Beginner

I have run in to this same situation in the past with a Ghost server in a school system with many layer 3 routes and switches.

My solution was to remove the Ghost server from the trunk and make it part of just one Vlan. Then use ip pim sparse-dense mode on all the vlan interfaces.

It would look like this.

Int Vlan1

ip pim sparse-dense mode

int vlan2

ip pim sparse-dense mode

int vlan3

ip pim sparse-dense mode

With pim sparse-dense mode enabled on each vlan when the multicast starts it will listen to see who is actually subscribed to the stream and then send only to those port that need the stream.

Highlighted

Hi,

thx for your answer.

So if I understand what you mean, the multicast will be routed through the 3750?

Usually with the config I explained in my first post I have a throughput which goes till 2500MB/min sometimes more. (except for this time)

With the multicast routed will I have the same throughputs?

Thx again for your help.

FB

Highlighted

yes the pim command will allow multicast traffic to be routed over a layer 3 interface.

Highlighted
Beginner

Hi,

I still have the problem.

Before move the Ghost server in a separate Vlan I want to be sure that will be the solution.

Because even if I move the Ghost server in a separate vlan, the route maps will still there as

users un vlan 1,2,3 has their own internet access.

I Tried several solutions but none really helped.

The best I had was to put a deny ip 224.77.0.0 0.0.255.255 int the ACL match by the route-map, but this make the ghost

multicast work with very low perf because of a High loading CPU.

I updated the  IOS but it did not helped.

What is very strange is that config work very well on an another switch (3750-X)

Thx for your future help and comment.

F.B.

Highlighted
Beginner

Finally!! I found the solution.

No need to disable the trunk on the server.

This paper lead me to the solution: http://www.cisco.com/en/US/products/hw/switches/ps708/products_tech_note09186a008059a9df.shtml

Quickly it explain that the edge switchs don't inform their backbone SW about their multicast receivers if an mrouter is not configured on the edge switchs.

A way to do it is to activate Multicast distributed switching:

ip multicast-routing distributed 

In global config mode

then

ip pim sparse-dense mode

directly on the vlan interfaces.

This way the backbone switch inform the edge switchs that it is the querier, so they informe their backbone switch about their receiver.

Sorry for my bad english, I hope that is clear enough.

Bye

F.B.

Content for Community-Ad