06-01-2015 08:29 AM - edited 03-08-2019 12:17 AM
I got an error message from syslog server that SSH login failed on a switch:
000168: May 30 09:09:44: %SEC_LOGIN-4-LOGIN_FAILED: Login failed [user: deadmin] [Source: 10.100.6.20] [localport: 22] [Reason: Login Authentication Failed] at 09:09:44 EDT Sat May 30 2015
Now it appears that the switch is reachable but SSH is not working. I am getting the password authentication failed message regardless of the credentials used. It seems like the switch cannot reach the radius server to authenticate. The cause is not obvious. Here is the most recent running config:
version 15.0
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
service sequence-numbers
!
hostname XXXXXXX
!
boot-start-marker
boot-end-marker
!
!
username ITadmin privilege 15 password 7 15115A181D0A2F29213D67760B50
aaa new-model
!
!
aaa authentication login default group radius local
aaa authentication login CONSOLE local
aaa authorization exec default if-authenticated
!
!
!
!
!
!
aaa session-id common
clock timezone EST -5 0
clock summer-time EDT recurring
system mtu routing 1500
!
!
ip domain-name XXXXXXXXXX
ip name-server 10.100.5.2
ip name-server 10.100.5.5
login on-failure
login on-success
!
!
crypto pki trustpoint TP-self-signed-213778432
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-213778432
revocation-check none
rsakeypair TP-self-signed-213778432
!
!
crypto pki certificate chain TP-self-signed-213778432
certificate self-signed 01
30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 32313337 37383433 32301E17 0D393330 33303130 30303130
345A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3231 33373738
34333230 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
A7F562A5 5A0712CC A0908E72 1D688300 732910DD 54A0184D 887919D9 E58F4F6B
21ED7C96 30C11CCB 9812ADAC 0100B36A 61AAED41 0925CBCB 4EE497F8 378DAF1B
FC4C290D 76E0F6A6 3401517D 8B0BFF17 FE50511E 471162CB D372D207 519C1ACE
3F65A34F 18A8F626 8AF3B606 D346B882 55050BBF 5E9582D2 2D7EF7CE A84F5B97
02030100 01A35330 51300F06 03551D13 0101FF04 05300301 01FF301F 0603551D
23041830 16801496 DBEEA5BD CD6A05CF C875280A 6F3074B5 D374C030 1D060355
1D0E0416 041496DB EEA5BDCD 6A05CFC8 75280A6F 3074B5D3 74C0300D 06092A86
4886F70D 01010505 00038181 004556AB A012D79B 6F733B0A DC6544C4 DF80DECD
A50F8DE1 2840D7E4 EC0059D1 C49219EA D58A48EF BBFF8587 048A6B67 5B796AEA
10A879B8 7855E3BF DEFA5805 644C298D ED7E5A4A 6284D2C0 096AEB31 58AA3068
516A3750 55B62950 378904CE AC57025F EA936C6D D161A580 9CF24DD0 E0069DA7
D5892040 9B811332 76C15101 84
quit
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface FastEthernet0/1
switchport access vlan 160
!
interface FastEthernet0/2
switchport access vlan 160
!
interface FastEthernet0/3
switchport access vlan 160
shutdown
!
interface FastEthernet0/4
switchport access vlan 160
shutdown
!
interface FastEthernet0/5
switchport access vlan 160
shutdown
!
interface FastEthernet0/6
switchport access vlan 160
shutdown
!
interface FastEthernet0/7
switchport access vlan 160
shutdown
!
interface FastEthernet0/8
switchport access vlan 160
shutdown
!
interface GigabitEthernet0/1
description XXXXXXXXXX
switchport mode trunk
media-type sfp
spanning-tree bpduguard disable
spanning-tree cost 51
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 10.100.2.36 255.255.255.0
!
no ip http server
ip http access-class 5
ip http authentication local
ip http secure-server
ip radius source-interface Vlan2
logging trap notifications
logging origin-id hostname
logging host 10.100.6.56
access-list 5 permit 10.100.5.114
access-list 5 permit 10.100.5.40
access-list 5 permit 10.100.6.11
access-list 5 permit 10.100.6.30
access-list 5 permit 10.100.6.20
access-list 5 permit 10.100.6.23
access-list 5 permit 10.100.2.0 0.0.0.255
access-list 5 permit 10.100.95.0 0.0.0.255
snmp-server community cw2000anyone RO
radius-server host 10.100.6.50 key 7 130B3701031924182A20212626
!
radius server RADIUS
key 7 06082F32445B292B04131B1E1F
!
!
!
banner login ^C
XXXXXXXXXXXXXX
'^C
!
line con 0
login authentication CONSOLE
line vty 0 4
access-class 5 in
privilege level 15
transport input ssh
line vty 5 15
transport input none
!
ntp server 10.100.2.253
end
06-01-2015 03:48 PM
Can you ping the radius server ?
Is this switch meant to be a L2 switch ie. it is not doing any L3 routing between vlans ?
If so and this is the full configuration you need a default gateway because the radius server is in a different subnet than the vlan 2 SVI.
So if it is L2 only then you need to add -
"ip default-gateway x.x.x.x"
where x.x.x.x is the IP address of the SVI for vlan 2 on your L3 switch so it will be 10.100.2.x.
Jon
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide