cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

1540
Views
10
Helpful
8
Replies
Beginner

Stack reboot a standalone switch

Hi:

I have a Cisco WS-C2960S-48TD-L with 12.2(55)SE2.

This is a standalone switch, not in stack, and with no order it reboots itself looking for a new master election. On logging i have nothing, but connected with console cable i see the following after 2 minutes of not showing anything:

Waiting for Stack Master Election...

...

The switch reboots and:

...

*Mar  1 00:00:12.289: Read env variable - LICENSE_BOOT_LEVEL =

*Mar  1 00:00:12.949: %IOS_LICENSE_IMAGE_APPLICATION-6-LICENSE_LEVEL: Module name = c2960s_lanbase Next reboot level = lanbase and License = lanbase

*Mar  1 00:02:02.342: %STACKMGR-4-SWITCH_ADDED: Switch 1 has been ADDED to the stack   <<<<<<<<<<<<<<<<<<

*Mar  1 00:02:03.674: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down

*Mar  1 00:02:04.686: %SPANTREE-5-EXTENDED_SYSID: Extended SysId enabled for type vlan

I have no stack-cable connected, because it´s not going to have any other switch on stack. The previous state of the default configuration of the stack was:

SW_OSIATIS_SERVERS#sh switch detail

Switch/Stack Mac Address : b8be.bfcd.2b80

                                           H/W   Current

Switch#  Role   Mac Address     Priority Version  State

----------------------------------------------------------

*1       Master b8be.bfcd.2b80     1      1       Ready

         Stack Port Status             Neighbors

Switch#  Port 1     Port 2           Port 1   Port 2

--------------------------------------------------------

  1       Down       Down             None     None

After searching online i have no seeing nothing about disable the feature of the stack so i configure the priority for the "switch 1" to 15 and configure it the switches 2, 3 and 4 to no provision, although this switches don´t exist:

SW_ACCESS(config)#switch 1 priority 15

Changing the Switch Priority of Switch Number 1 to 15

Do you want to continue?[confirm]

New Priority has been set successfully

SW_ACCESS(config)#no switch 2 provision

SW_ACCESS(config)#no switch 3 provision

SW_ACCESS(config)#no switch 4 provision

The state of the stack is the next right now:

SW_OSIATIS_SERVERS#sh switch detail

Switch/Stack Mac Address : b8be.bfcd.2b80

                                           H/W   Current

Switch#  Role   Mac Address     Priority Version  State

----------------------------------------------------------

*1       Master b8be.bfcd.2b80     15     1       Ready

         Stack Port Status             Neighbors

Switch#  Port 1     Port 2           Port 1   Port 2

--------------------------------------------------------

  1       Down       Down             None     None

With this new configuration the switch has rebooted again.

Why on a standalone switch the stack is rebooting my system?

Is it any feature to disable the stack?

Thanks in advance

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Community Legend

Stack reboot a standalone switch

SW_ACCESS uptime is 35 minutes

System returned to ROM by power-on

Looks like it's power.

View solution in original post

8 REPLIES 8
Beginner

Stack reboot a standalone switch

hello,

Can you paste a show version and a show run so we can take a look at the config?

Joel

_______________________________
Please rate helpful posts and answered questions!

Joel _______________________________ Please rate helpful posts and answered questions!
Beginner

Stack reboot a standalone switch

Hi:

SW_ACCESS#sh ver

Cisco IOS Software, C2960S Software (C2960S-UNIVERSALK9-M), Version 12.2(55)SE2, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2011 by Cisco Systems, Inc.

Compiled Tue 11-Jan-11 02:23 by prod_rel_team

Image text-base: 0x00003000, data-base: 0x01B00000

ROM: Bootstrap program is Alpha board boot loader

BOOTLDR: C2960S Boot Loader (C2960S-HBOOT-M) Version 12.2(53r)SE, RELEASE SOFTWARE (fc3)

SW_ACCESS uptime is 35 minutes

System returned to ROM by power-on

System image file is "flash:/c2960s-universalk9-mz.122-55.SE2/c2960s-universalk9-mz.122-55.SE2.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

cisco WS-C2960S-48TD-L (PowerPC) processor (revision D0) with 131072K bytes of memory.

Processor board ID FOC1510Y5DU

Last reset from power-on

3 Virtual Ethernet interfaces

1 FastEthernet interface

50 Gigabit Ethernet interfaces

2 Ten Gigabit Ethernet interfaces

The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address       : B8:BE:BF:CD:2B:80

Motherboard assembly number     : 73-11905-08

Power supply part number        : 341-0327-03

Motherboard serial number       : FOC150851UR

Power supply serial number      : DCA1505P5EK

Model revision number           : D0

Motherboard revision number     : A0

Model number                    : WS-C2960S-48TD-L

Daughterboard assembly number   : 73-11933-04

Daughterboard serial number     : FOC15095KQW

System serial number            : FOC1510Y5DU

Top Assembly Part Number        : 800-30925-03

Top Assembly Revision Number    : A0

Version ID                      : V03

CLEI Code Number                : COMGD00ARC

Daughterboard revision number   : A0

Hardware Board Revision Number  : 0x01

Switch Ports Model              SW Version            SW Image

------ ----- -----              ----------            ----------

*    1 52    WS-C2960S-48TD-L   12.2(55)SE2           C2960S-UNIVERSALK9-M

Configuration register is 0xF

SW_ACCESS#sh run

Building configuration...

Current configuration : 4695 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname SW_ACCESS

!

boot-start-marker

boot-end-marker

!

enable secret 5

!

username osiatis privilege 15 password 0

!

!

no aaa new-model

switch 1 provision ws-c2960s-48td-l

!

!

!

!

crypto pki trustpoint TP-self-signed-3217894272

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3217894272

revocation-check none

rsakeypair TP-self-signed-3217894272

!

!

crypto pki certificate chain TP-self-signed-3217894272

certificate self-signed 01

  3082024B 308201B4 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33323137 38393432 3732301E 170D3933 30333031 30303033

  31375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 32313738

  39343237 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100BA1A 82B44523 A7DD07A3 5F1717DD 5B5D863C D51FFCE8 02CCE139 F03CB668

  1D6D8795 25C83CED 0B1060FD A5D50A9B 35D1F3C9 EA1F6AAC 09548878 FA298833

  9F553C75 43B67058 200CE6B8 B5024EED 0A303F0A 496C7682 7F9D1089 CBC4AA07

  38335AAD 24082E47 5421B39A CAAD00A8 4BFD051F 90DF4211 9A9F8094 7BA8ACD1

  BB3B0203 010001A3 73307130 0F060355 1D130101 FF040530 030101FF 301E0603

  551D1104 17301582 1353575F 4F534941 5449535F 53455256 4552532E 301F0603

  551D2304 18301680 140B2EB1 13F4E22C EE8F468C 49B96639 A03C8BAF 3C301D06

  03551D0E 04160414 0B2EB113 F4E22CEE 8F468C49 B96639A0 3C8BAF3C 300D0609

  2A864886 F70D0101 04050003 8181002F 7FCD9F44 9E4405CA F0168D7D 81CA9DC9

  C1D47128 9251A9A7 284087A9 85245A14 929259A7 8CEE6F7F B60CD3CA 49B339A6

  E8DCA79B 62B03EDA 8D677F95 C413F345 B487FE89 169B38B9 0F1C7CFF E13A2A5B

  A05A1870 DD123BF4 1F0E89FE 910E91FD E5665F6A 5D17EB4F CAFBEDBE 77F46EB8

  B1B3F4F1 870F4F30 CA63899E DE3720

  quit

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

vlan internal allocation policy ascending

!

!

!

interface Port-channel1

description PO1 SERVIDORES - PO1 CORE

switchport mode trunk

!

interface FastEthernet0

no ip address

shutdown

!

interface GigabitEthernet1/0/1

switchport mode access

!

interface GigabitEthernet1/0/2

!

interface GigabitEthernet1/0/3

!

interface GigabitEthernet1/0/4

!

interface GigabitEthernet1/0/5

!

interface GigabitEthernet1/0/6

!

interface GigabitEthernet1/0/7

!

interface GigabitEthernet1/0/8

!

interface GigabitEthernet1/0/9

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

!

interface GigabitEthernet1/0/12

!

interface GigabitEthernet1/0/13

!

interface GigabitEthernet1/0/14

!

interface GigabitEthernet1/0/15

!

interface GigabitEthernet1/0/16

!

interface GigabitEthernet1/0/17

!

interface GigabitEthernet1/0/18

!

interface GigabitEthernet1/0/19

!

interface GigabitEthernet1/0/20

!

interface GigabitEthernet1/0/21

!

interface GigabitEthernet1/0/22

!

interface GigabitEthernet1/0/23

!

interface GigabitEthernet1/0/24

!

interface GigabitEthernet1/0/25

!

interface GigabitEthernet1/0/26

!

interface GigabitEthernet1/0/27

!

interface GigabitEthernet1/0/28

!

interface GigabitEthernet1/0/29

!

interface GigabitEthernet1/0/30

!

interface GigabitEthernet1/0/31

!

interface GigabitEthernet1/0/32

!

interface GigabitEthernet1/0/33

switchport access vlan 3

!

interface GigabitEthernet1/0/34

switchport access vlan 3

!

interface GigabitEthernet1/0/35

switchport access vlan 3

!

interface GigabitEthernet1/0/36

switchport access vlan 3

!

interface GigabitEthernet1/0/37

switchport access vlan 2

!

interface GigabitEthernet1/0/38

!

interface GigabitEthernet1/0/39

!

interface GigabitEthernet1/0/40

!

interface GigabitEthernet1/0/41

!

interface GigabitEthernet1/0/42

!

interface GigabitEthernet1/0/43

!

interface GigabitEthernet1/0/44

!

interface GigabitEthernet1/0/45

!

interface GigabitEthernet1/0/46

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet1/0/47

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet1/0/48

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet1/0/49

!

interface GigabitEthernet1/0/50

!

interface TenGigabitEthernet1/0/1

!

interface TenGigabitEthernet1/0/2

!

interface Vlan1

ip address 192.168.2.17 255.255.255.0

!

interface Vlan2

ip address 172.16.0.2 255.255.255.0

!

interface Vlan3

ip address 172.16.3.2 255.255.255.0

!

ip http server

ip http authentication local

ip http secure-server

ip sla enable reaction-alerts

!

line con 0

line vty 0 4

login

line vty 5 15

login

!

end

THANK YOU SO MUCH FOR YOUR HELP!!

Beginner

Stack reboot a standalone switch

The config looks ok. Not sure if its anything within it thats causing the switch to do that. I checked the IOS version for bugs, none that relate to stacking are present.

Do you have a stacking module in the switch by chance? I know you said you dont have a stacking cable but does it have a stacking module in it? if so remove it and reboot, see if it still happens.

If no module, do you have smartnet on the switch so you can call on Cisco for assistance?

Joel

_______________________________
Please rate helpful posts and answered questions!

Joel _______________________________ Please rate helpful posts and answered questions!
Beginner

Stack reboot a standalone switch

The switch hasn´t a stacking module.

I have no smartnet but i can download a new IOS and i´m going to prove it.

Many thabnks for your help. I´ll update the case with more info

Kind regards

Hall of Fame Community Legend

Stack reboot a standalone switch

SW_ACCESS uptime is 35 minutes

System returned to ROM by power-on

Looks like it's power.

View solution in original post

Beginner

Stack reboot a standalone switch

No, we have to powercyvle the switch because i wasn´t at the office and a partner reboot the switch.

Beginner

Stack reboot a standalone switch

Thank you so much for your help. Finnally it´s a problem with the hardware. I put the switch on my desk for upload the IOS and i´ve seen that the switch it´s powering off and on.

It´s under guaarantee so, hell yeah!!!

Beginner

Stack reboot a standalone switch

No problem man. Glad to help. Have a good one.

Joel

_______________________________
Please rate helpful posts and answered questions!

Joel _______________________________ Please rate helpful posts and answered questions!
CreatePlease to create content
Content for Community-Ad