cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

210
Views
0
Helpful
3
Replies
Highlighted
Beginner

strecthing a vlan router on a stick

Hi All

 

I currently have a router on a stick and I want to create a sub interface 

 

int g0/0/0.49

encapsulation dot1q 49

ip address 192.168.1.1 255.255.255.0

!

 

on the switch this port connects to I have 

 

switchport mode trunk

switchport trunk allowed vlan 49

!

now on the same switch there is another port that goes off to another switch. (this is an isolated network with one vlan needed only)

!

vlan 49

!

switchport mode trunk

switchport trunk allowed vlan 49

!

this is then connect to a stack of 2 3750's 

!

vlan 49

!

int g2/1/14

switchport mode trunk

switchport trunk allowed vlan 49

!

int g1/1/14

Description connectionto 2960

switchport mode trunk

switchport trunk allowed vlan 49

 

!

 

This now goes down 

 

to a lonesome 2960

 

!

vlan 49

 

int g1/0/24 

switchport mode trunk

switchport trunk allowed vlan 49

!

interface vlan 49

ip address 192.168.1.254

!

 

laptop connects to

 

int g1/0/24

switchport mode acces

switchport access vlan 49

!

IP default-gateway 192.168.1.1

 

Naturally you would expect destination host unreachable 

!

 

My theory is should all the ports (except the ones between the router and the switch) be configured as access ?

 

If not what would be the solution to get the laptop hanging off the access port on the 2960 talking

 

ip address 192.168.1.5 255.255.255.0 gateway 192.168.1.1

 

 

Thanks in advance 

 

 

 

Everyone's tags (4)
3 REPLIES 3
Highlighted
Hall of Fame Guru

Re: strecthing a vlan router on a stick

 

Not sure I follow.

 

If you set default gateway for the laptop to be 192.168.1.1, you have vlan 49 created on all the switches and you allow it on all the trunk links then it should work. 

 

Is it not ? 

 

Jon

Highlighted
Beginner

Re: strecthing a vlan router on a stick

No it doesn't, I removed access-list rules off the 2960 aswell

Highlighted
Hall of Fame Guru

Re: strecthing a vlan router on a stick

 

It should work as you have it. 

 

So like I say, vlan 49 must exist in the vlan database on all switches, your trunk links must be up and you must allow vlan 49 on all the trunk links. 

 

Then as long as the access port for the laptop is in vlan 49 and you have set the default gateway to be 192.168.1.1 you should be able to ping it. 

 

Jon

CreatePlease to create content
Content for Community-Ad