cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
991
Views
5
Helpful
1
Replies

Switch not handling network traffic.

rubeste
Level 1
Level 1

Hello reader,

 

Recently I have acquired some old Cisco switches that I want to give to my school for learning. But I am struggling in setting it up.

 

System Info

Model: ME-3400-24TS-A.

Physical:

fa0/1 is connected to my LAN (192.168.178.0/24)

fa0/23 is connected to my PC as a SPAN port for monitoring of interface fa0/1

On my LAN the gateway is located at (192.168.178.1)

Cisco switch has this IP (192.168.178.254)

Config:

!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
system mtu routing 1500
no ip subnet-zero
!
!
!
no file verify auto
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
!
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
port-type nni
!
interface GigabitEthernet0/2
port-type nni
!
interface Vlan1
ip address 192.168.178.254 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.178.1
ip http server
ip http secure-server
!
line con 0
line vty 0 4
no login
line vty 5 15
no login
!
!
monitor session 1 source interface Fa0/1
monitor session 1 destination interface Fa0/23
end

Problem

When I try to ping the gateway I get this:

 

Sending 5, 100-byte ICMP Echos to 192.168.178.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

But according to my SPAN port that I monitor via Wireshark I see that my gateway actually replies.

 

 

192.168.178.1	192.168.178.254	ICMP 114 Echo (ping) reply    id=0x0003, seq=4/1024, ttl=64
192.168.178.254	192.168.178.1	ICMP 114 Echo (ping) request  id=0x0003, seq=0/0, ttl=255
192.168.178.1	192.168.178.254	ICMP 114 Echo (ping) reply    id=0x0003, seq=0/0, ttl=64
192.168.178.254	192.168.178.1	ICMP 114 Echo (ping) request  id=0x0003, seq=1/256, ttl=255
192.168.178.1	192.168.178.254	ICMP 114 Echo (ping) reply    id=0x0003, seq=1/256, ttl=64
192.168.178.254	192.168.178.1	ICMP 114 Echo (ping) request  id=0x0003, seq=2/512, ttl=255
192.168.178.1	192.168.178.254	ICMP 114 Echo (ping) reply    id=0x0003, seq=2/512, ttl=64
192.168.178.254	192.168.178.1	ICMP 114 Echo (ping) request  id=0x0003, seq=3/768, ttl=255
192.168.178.1	192.168.178.254	ICMP 114 Echo (ping) reply    id=0x0003, seq=3/768, ttl=64
192.168.178.254	192.168.178.1	ICMP 114 Echo (ping) request  id=0x0003, seq=4/1024, ttl=255

 

It is my belief that this problem is the root cause of several other problems (not being able to download IOS via TFTP).

If anyone knows the solution or needs more info I am happy to provide it.

1 Accepted Solution

Accepted Solutions

rubeste
Level 1
Level 1

After some more googling I eventually found a post with this answer. This solved the problem I was having. Sorry for posting a duplicate, but I hope that others will have a higher chance of figuring this problem out.

Explanation

3400 switch is a Metro Ethernet switch. By default, all the ports are in uni mode, except 2 uplinks which are in nni.

#Normal port in default more (uni)
interface FastEthernet0/24 !
#Uplink port in nni mode. interface GigabitEthernet0/1 port-type nni
!

Uni means user network interface and it is isolated (can only communicate with itself and devices on nni ports).

nni is network node interface. NNI is used to connect to routers or another switch.

by default on every cisco switch all the ports are in nni. but metro Switches like 34xx and 24xx are uni ports.

Solution

To solve this problem all we need to do is switch those ports from default (uni mode) to nni mode. To do this use the following commands:

Switch>en

Switch#conf t

Switch(config)#int fa0/1

Switch(config-if)#port-type nni

If it still doesn't work try saving the configuration and reloading the switch.

View solution in original post

1 Reply 1

rubeste
Level 1
Level 1

After some more googling I eventually found a post with this answer. This solved the problem I was having. Sorry for posting a duplicate, but I hope that others will have a higher chance of figuring this problem out.

Explanation

3400 switch is a Metro Ethernet switch. By default, all the ports are in uni mode, except 2 uplinks which are in nni.

#Normal port in default more (uni)
interface FastEthernet0/24 !
#Uplink port in nni mode. interface GigabitEthernet0/1 port-type nni
!

Uni means user network interface and it is isolated (can only communicate with itself and devices on nni ports).

nni is network node interface. NNI is used to connect to routers or another switch.

by default on every cisco switch all the ports are in nni. but metro Switches like 34xx and 24xx are uni ports.

Solution

To solve this problem all we need to do is switch those ports from default (uni mode) to nni mode. To do this use the following commands:

Switch>en

Switch#conf t

Switch(config)#int fa0/1

Switch(config-if)#port-type nni

If it still doesn't work try saving the configuration and reloading the switch.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: