cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1075
Views
10
Helpful
15
Replies

switch to switch vlans

pkroetsch
Level 1
Level 1

Hello,

I have separate cisco 3750 switches one is a 48 port and one is a 24 port switch.

I have the 48 port switch setup on a vlan.

interface Vlan95

ip address 192.168.95.1 255.255.255.0

!

then i have another 24 port switch setup as

interface Vlan55

description EMS DMZ

ip address 192.168.55.254 255.255.255.0

!

I want everything on vlan 55 to be able to talk to the 95 network on switch 1...the 48 port switch.

what is the best way going about doing this.

should i create another vlan on the 24 port switch as a 95 network to be able to talk to ether other.

interface GigabitEthernet1/0/18

switchport access vlan 55

switchport mode access

thanks for the help

2 Accepted Solutions

Accepted Solutions

ALIAOF_
Level 6
Level 6

Connect the two switches using a trunk port.  Something like this:

3750 48 port

interface gi1/0/24

switchport trunk encap dot1q

switchport mode trunk

speed 1000

duplex full

!

ip routing

3750 24 port

interface gi1/0/24

switchport trunk encap dot1q

switchport mode trunk

speed 1000

duplex full

!

ip routing

View solution in original post

vishal vyas
Level 1
Level 1

you need to type command # ip routing.. command in order to run inter vlan traffic.

View solution in original post

15 Replies 15

ALIAOF_
Level 6
Level 6

Connect the two switches using a trunk port.  Something like this:

3750 48 port

interface gi1/0/24

switchport trunk encap dot1q

switchport mode trunk

speed 1000

duplex full

!

ip routing

3750 24 port

interface gi1/0/24

switchport trunk encap dot1q

switchport mode trunk

speed 1000

duplex full

!

ip routing

ok then i don't need to assign a vlan to each since they on trunked together...

sorry I am new.

Yes trunk port will carry the VLAN's unless you restrict certain VLAN's in your case it sounds like a pretty simple setup.  You will need to assign the ports to the specific VLAN when you connect end devices though.

InayathUlla Sharieff
Cisco Employee
Cisco Employee

Hi Phil,

Since you are using different vlans that subnets needs to be preset if you want it to be communicated between each other.

If you just configure the vlans and apply to the access ports and allowed it over the trunk ports it will not get communicated between each other.

1- Configure the Vlans and allow it on the trunk interface.

2- Assign the vlans to the respective access ports.

3- Have the following subnets range on both the switches. (For example you need to have both the vlans on 2 switches with respective ip subnet ranges.)

4- Once you have them you should be good to go.

I have setup this on Packettracer let me know if you would like to have a look.

HTH

REgards

Inayath

*Plz rate all usefull posts.

Ok so I have the packet tracer up. Now I need to create new vlans on each switch?

Hi Phil,

I have configured everything on this devices on the pkt tracer file attached.You can check the configuration and connectivity.

HTH

Regards

Inayath

*Plz rate al uesfull posts.

I cannot ping each device... 95.10 cannot ping 55.10 and vise versa.

Thank you for the rating Phil were you able to get this up and running? 

No Problem. I plan to give it a try this week.

HI Phil,

Were you able to use the Pkt tracer file?

Regards

Inayath

yes I opened it up but could not ping the computers. the 55.10 could not ping 95.10

Phil

Hi Phil.,

I just tested again and its all working end to end. Kindly open the file login to all the devices.

192.168.95.10 PC0----Switch 0=========Switch 1--PC1( 192.168.55.10 )

'PC0>ping 192.168.55.10 ----------------> PC to PC is pinging.

Reply from 192.168.55.10: bytes=32 time=4ms TTL=128

PC1>ping 192.168.55.10       ----------------> PC to PC is pinging.

Reply from 192.168.55.10: bytes=32 time=4ms TTL=128

PC0>

Switch0>

Vlan55                 192.168.55.253  YES manual up                    up

Vlan95                 192.168.95.1    YES manual up                    up

Switch0>

Switch1#

Vlan55                 192.168.55.254  YES manual up                    up

Vlan95                 192.168.95.2    YES manual up                    up

Switch1#

Kindly check the same and revert back if you face any issue.

HTH

Regards

Inayath

Thanks Inayath for the Pkt tracer, I just tested for myself and its working fine.

Was looking for somthing but this got some help for me.

Regards

Fari.

vishal vyas
Level 1
Level 1

you need to type command # ip routing.. command in order to run inter vlan traffic.

Review Cisco Networking for a $25 gift card