cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
638
Views
0
Helpful
7
Replies
Highlighted
Beginner

switching or routing between two switches?

hi,

i would like to know what is the best to use switching or routing in the following scenario:

SW A1 ----------SW A2

|            (Trunk)

|

|

SW B1-----------SW B2

Switch A!1 and Switch A2 are trunked (l2) and so as B1 and B2. assume both has its own set of vlans (say SW A1 and SW A2 has 100,101,102 and SW B1 and SW B2 has 200,201,202)

Now i know that we trunk sw a1 and swb2 or we can use routed link...

say if i do this:

on switch A1

int vlan 254

desc transit vlan to sw b

ip address 10.10.10.1

int gi0/1

switchport mode trunk

switchport access vlan 254

on switch B1

int vlan 254

desc transit vlan to sw A

ip address 10.10.10.2

int gi0/1

switchport mode trunk

switchport access vlan 254

will the above work? if it does which is the best routed or this config ? what will be the difference ?

Thanks

Everyone's tags (5)
7 REPLIES 7
Frequent Contributor

switching or routing between two switches?

Are these L3 switches I am assuming?  Enable IP Routing and trunk the ports between SWA1 and SWB1 like you said, take out "switchport access vlan 254" and "interface vlan 254" command you don't need to create another VLAN.  Just a trunk between two switches is fine.  Make sure VLAN's from switch B are in switch A's database and vice versa.

Beginner

switching or routing between two switches?

thanks for this but i would like to use a dedicatiated vlan as transit vlan and hence the question

i know both these ports can be trunked instead of going through the above config but would like to know if you use a interface vlan and apply a port to that vlan will it work ? also is routing preferred to this method ?

Frequent Contributor

switching or routing between two switches?

You still would leave the port as trunk and not add the access command.  Here is a great article that will guide you:

http://packetlife.net/blog/2011/feb/9/hybrid-access-layer-design-revisited/

Beginner

switching or routing between two switches?

thanks but in order to use a vlan as transit vlan how do i do this ? basically i am trying to dedicate a vlan just for transit between two switches

Thanks

Rising star

Re: switching or routing between two switches?

Hi,

There are two options:

1. As Mohammad said you can configure them as a trunk port. And add vlans to switchA1/switchA2 200,201,202 and to switchB1/switchB2 100,101,102.

For redundancy:

Configure switchA1 STP primary root bridge for 100,101,102 vlans and secondary root bridge for 200,201,202 vlans.

Configure switchB1 STP primary root bridge for 200,201,202 vlans and secondary root bridge for 100,101,102 vlans. And connect switchA2 to switchB1, switchB2 to switchA1.

2. Or just configure ports between them as routed ports and EIGRP between them in order to exchange routes.

If you would use first option on large network there will be a lot of broadcasts. So I think it's better to use routed ports to eliminate broadcasts.

Hope it will help. Best regards, Abzal
Beginner

switching or routing between two switches?

ok thanks

but in which instance would you use the config below ? ( i have seen these on trunk ports)

int fa0

switchport mode trunk

switchport access vlan998

switchport native vlan 998

Rising star

switching or routing between two switches?

As I said you can connect switchA1 and switchB1 each other and configure between them with command like above

native vlan need to be the same. No need switchport access vlan 998

SwitchA1

int g0/1

switchport mode trunk

switchport trunk native vlan 998

SwitchB1

int g0/1

switchport mode trunk

switchport trunk native vlan 998

But make sure that native VLAN is on both switches database.

Please rate helpful posts.

Hope it will help. Best regards, Abzal
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards