cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
2130
Views
10
Helpful
6
Replies
Jason Flory
Beginner

Tagging traffic by IP source and destination

Hello Everyone,

I want to know if there is way to tag traffic with DCSP tags without having to do all the other requirments of QOS setup.  All i want to do is just tag traffic at different DCSP values via source and destination IPs.  We do not have a need to be priortizing traffic on out internal switches.  We just want to tag the traffic so our MPLS provider can distinguish the different types of traffic.

Our environments is primarily 3750s in all offices.

Thanks

6 REPLIES 6
cadet alain
Advisor

Hi,

of course, just use an extended ACL for matching traffic you want to tag and set dscp for the corresponding class in your Policy-map then apply this policy to your router

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

I am kind of a novice with QOS. Can you give me an example of what it would look like to tag all traffic coming from 10.5.5.5. to DSCP 46 and going to 10.4.4.4

Also to be clear of what we are doing.  We are using cisco 3750s as layer 3 switches so no actual routers involved.  Also we are tagging at the application layer which means i need to be very careful not to remove existing tags.

Thanks

Hi,

QoS tagging is at L3 or L2  only,  look here for Qos on the 3750.

access-list 101 permit ip host 10.5.5.5 host 10.4.4.4

class-map 5_To_4

match access-group 101

policy-map SET_DSCP

class 5_To_4

set dscp 46

int x/x

service-policy input SET_DSCP

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_58_se/configuration/guide/swqos.html

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Hi,

If you are tagging at the application layer then i suggest u configure ports on which these servers are connected to trust the DSCP vlaues in this way you will avoid playing with QOS stuff.Just enable (mls qos trust dscp) under the ports on the switch and enable trusting on all the deivces upto your router.

Thanks

We are runnign softphones which have video and voice tagged which are coming from client machines and going to our server (lync) so i should enable QOS trust on all ports that may have tagged traffic on.

The next thing we want to do is tag traffic for our "scavenger plane" which is for our backups and replication traffic.  Which is the set of commands that cadet alain said to use.  Which interface should the tagging for this plane be enabled?  At the source where the servers are are?  Or should this be where the traffic leaves the network and is handed off to our provider?

Are these all run at the interface level or do i create this in config mode then apply them to the interface level.  Can you explain what each one of these commands does?

access-list 101 permit ip host 10.5.5.5 host 10.4.4.4

class-map 5_To_4

match access-group 101

policy-map SET_DSCP

class 5_To_4

set dscp 46

Thanks alot for everyone's help. 

Hi,

Yes u need to enable QOS trust on all the ports where systems with softphones are connected and on trunk ports leading all the way to your edge router.

Under which DSCP value you want your scavenger traffic to be marked..?.If u dont mark this scavenger traffic it will be put in default class n forwarded.

access-list 101 permit ip host 10.5.5.5 host 10.4.4.4=====Identifies the traffic.

class-map 5_To_4=======================create the classification.

match access-group 101================puts the identified traffic in the classification.

policy-map SET_DSCP=================Applies the policy to the classified traffic.

class 5_To_4=========================class is called here

set dscp 46=====================set the dscp value

All these command are done in global config,u need only the policy map to be applied under the interface.

Thanks