cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
821
Views
0
Helpful
2
Replies
Highlighted
Beginner

transmit discards

Hi, I am receiving high discards on a 6509. There is low utilisation of the link & it looks like bursts. I've posted some config & diagnostic info below. Can anyone help explain what could be causing it or suggest a solution.





GigabitEthernet2/16 is up, line protocol is up (connected)
Hardware is C6k 1000Mb 802.3, address is 001a.6dbb.8d47 (bia 001a.6dbb.8d47)
Description: Connected to NPTNG01-C-5
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 16/255, rxload 12/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is SX
input flow-control is off, output flow-control is on
Clock mode is auto
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:52, output 00:00:11, output hang never
Last clearing of "show interface" counters 12w3d
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 1140857
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 47236000 bits/sec, 4927 packets/sec
5 minute output rate 63903000 bits/sec, 7495 packets/sec
48655453943 packets input, 64052166528408 bytes, 0 no buffer
Received 6130099 broadcasts (655299 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
0 input packets with dribble condition detected
52159337513 packets output, 61155176249634 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out




interface GigabitEthernet2/16
description Connected to NPTNG01-C-5
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
wrr-queue bandwidth 90 5 5
wrr-queue queue-limit 90 5 5
wrr-queue random-detect min-threshold 3 50 60 70 80 90 100 100 100
wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100
wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100
wrr-queue random-detect max-threshold 3 60 70 80 90 100 100 100 100
mls qos statistics-export
mls qos trust dscp
flowcontrol send on
channel-group 9 mode desirable
end


Connected to interface


GigabitEthernet4/2 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet Port, address is 0007.7dd3.a25e (bia 0007.7dd3.a25e)
Description: Connected to NPLYG28-C-1
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 11/255, rxload 16/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseSX
input flow-control is on, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:01, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 132
Queueing strategy: Class-based queueing
Output queue: 0/40 (size/max)
5 minute input rate 64612000 bits/sec, 7557 packets/sec
5 minute output rate 43892000 bits/sec, 4831 packets/sec
189300696533 packets input, 228699738233979 bytes, 0 no buffer
Received 112764821 broadcasts (9694747 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected
166236421303 packets output, 226261597966378 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out


!
interface GigabitEthernet4/2
description Connected to NPLYG28-C-1
switchport mode trunk
qos trust device cisco-phone
channel-group 2 mode desirable
service-policy output VOIP-2
end


NPLYG28-C-1#sh queueing in gi 2/16
Interface GigabitEthernet2/16 queueing strategy: Weighted Round-Robin
Port QoS is enabled
Trust state: trust DSCP
Extend trust state: not trusted [COS = 0]
Default COS is 0
Queueing Mode In Tx direction: mode-cos
Transmit queues [type = 1p3q8t]:
Queue Id Scheduling Num of thresholds
-----------------------------------------
01 WRR 08
02 WRR 08
03 WRR 08
04 Priority 01

WRR bandwidth ratios: 90[queue 1] 5[queue 2] 5[queue 3]
queue-limit ratios: 90[queue 1] 5[queue 2] 5[queue 3] 15[Pri Queue]

queue tail-drop-thresholds
--------------------------
1 70[1] 100[2] 100[3] 100[4] 100[5] 100[6] 100[7] 100[8]
2 70[1] 100[2] 100[3] 100[4] 100[5] 100[6] 100[7] 100[8]
3 100[1] 100[2] 100[3] 100[4] 100[5] 100[6] 100[7] 100[8]

queue random-detect-min-thresholds
----------------------------------
1 40[1] 70[2] 70[3] 70[4] 70[5] 70[6] 70[7] 70[8]
2 40[1] 70[2] 70[3] 70[4] 70[5] 70[6] 70[7] 70[8]
3 50[1] 60[2] 70[3] 80[4] 90[5] 100[6] 100[7] 100[8]

queue random-detect-max-thresholds
----------------------------------
1 100[1] 100[2] 100[3] 100[4] 100[5] 100[6] 100[7] 100[8]
2 100[1] 100[2] 100[3] 100[4] 100[5] 100[6] 100[7] 100[8]
3 60[1] 70[2] 80[3] 90[4] 100[5] 100[6] 100[7] 100[8]

WRED disabled queues:

queue thresh cos-map
---------------------------------------
1 1 0
1 2 1
1 3
1 4
1 5
1 6
1 7
1 8
2 1 2
2 2 3 4
2 3
2 4
2 5
2 6
2 7
2 8
3 1 6 7
3 2
3 3
3 4
3 5
3 6
3 7
3 8
4 1 5

Queueing Mode In Rx direction: mode-cos
Receive queues [type = 1q8t]:
Queue Id Scheduling Num of thresholds
-----------------------------------------
01 WRR 08

WRR bandwidth ratios: 100[queue 1]
queue-limit ratios: 100[queue 1]

queue tail-drop-thresholds
--------------------------
1 100[1] 100[2] 100[3] 100[4] 100[5] 100[6] 100[7] 100[8]

queue thresh cos-map
---------------------------------------
1 1 0 1 2 3 4 5 6 7
1 2
1 3
1 4
1 5
1 6
1 7
1 8


Packets dropped on Transmit:

queue dropped [cos-map]
---------------------------------------------
1 1141395 [0 1 ]
2 29 [2 3 4 ]
3 0 [6 7 ]
4 0 [5 ]

Packets dropped on Receive:
BPDU packets: 0

queue dropped [cos-map]
---------------------------------------------
1 0 [0 1 2 3 4 5 6 7 ]





NPLYG28-C-1#remote com sw sh qm-sp port-data 2 16

-----------------------------------------------------------------------------
* Queuing Mode [COS]
* Type: Tx[COS to Q - 1p3q8t] Rx[COS to Q - 1q8t]
* Per-Port: Trust[DSCP] Default COS[0] Override[0] [VLAN based]
-----------------------------------------------------------------------------
* Cos Mutation Map : 0 1 2 3 4 5 6 7
-----------------------------------------------------------------------------
* Queue Config TX:
QueueNum[1] PriQueue[N] QueueType[2] Thresh[8]
QueueNum[2] PriQueue[N] QueueType[2] Thresh[8]
QueueNum[3] PriQueue[N] QueueType[2] Thresh[8]
QueueNum[4] PriQueue[Y] QueueType[2] Thresh[8]
* Queue Config RX:
QueueNum[1] PriQueue[N] QueueType[2] Thresh[8]
-----------------------------------------------------------------------------
* COSMAP(C[Q/T]) TX: 0[1/1] 1[1/2] 2[2/1] 3[2/2] 4[2/2] 5[4/1] 6[3/1] 7[3/1]
* RX: 0[1/1] 1[1/1] 2[1/1] 3[1/1] 4[1/1] 5[1/1] 6[1/1] 7[1/1]
-----------------------------------------------------------------------------
* Bandwidth TX: Q[1-WRR]:234496 Q[2-WRR]:12288 Q[3-WRR]:12288
* Bandwidth RX: Q[1-WRR]:65536
-----------------------------------------------------------------------------
* Queue Limit TX: Q[1]:932160 Q[2]:56896 Q[3]:56896 Q[4]:175168

* Queue Limit RX: Q[1]:173504
-----------------------------------------------------------------------------
* TD/WRED TX: Q[1]/T[1]:[WRED] 372900/932160 Q[1]/T[2]:[WRED] 652530/932160
Q[1]/T[3]:[WRED] 652530/932160 Q[1]/T[4]:[WRED] 652530/932160
Q[1]/T[5]:[WRED] 652530/932160 Q[1]/T[6]:[WRED] 652530/932160
Q[1]/T[7]:[WRED] 652530/932160 Q[1]/T[8]:[WRED] 652530/932160

Q[2]/T[1]:[WRED] 22816/56896 Q[2]/T[2]:[WRED] 39856/56896
Q[2]/T[3]:[WRED] 39856/56896 Q[2]/T[4]:[WRED] 39856/56896
Q[2]/T[5]:[WRED] 39856/56896 Q[2]/T[6]:[WRED] 39856/56896
Q[2]/T[7]:[WRED] 39856/56896 Q[2]/T[8]:[WRED] 39856/56896

Q[3]/T[1]:[WRED] 28496/34176 Q[3]/T[2]:[WRED] 34176/39856
Q[3]/T[3]:[WRED] 39856/45536 Q[3]/T[4]:[WRED] 45536/51216
Q[3]/T[5]:[WRED] 51216/56896 Q[3]/T[6]:[WRED] 56896/56896
Q[3]/T[7]:[WRED] 56896/56896 Q[3]/T[8]:[WRED] 56896/56896


* TD/WRED RX: Q[1]/T[1]:[TD] 173504 Q[1]/T[2]:[TD] 173504
Q[1]/T[3]:[TD] 173504 Q[1]/T[4]:[TD] 173504
Q[1]/T[5]:[TD] 173504 Q[1]/T[6]:[TD] 173504
Q[1]/T[7]:[TD] 173504 Q[1]/T[8]:[TD] 173504


-----------------------------------------------------------------------------



Sent from Cisco Technical Support iPhone App

2 REPLIES 2
Highlighted
Beginner

Try increasing the "hold-queue out".

Highlighted

Seriously? This is not a solution & could make things worse. Increasing the hold queue out could cause the TCP timers to expire which would result in re-transmits, the re-transmits would inevitably fill the queue & cause even more discards.

Content for Community-Ad