cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
213
Views
0
Helpful
1
Replies

troubles setting up Vlan with 2 switches

flora.giannone1
Level 1
Level 1

Hi Guys

I need to create a vlan  "2303" with these specifics in Solaris:

FIRST SWITCH:

  • create vlan N2303
  • configure "N2303" tag 2303
  • configure "N2303" add port 1 tagged
  • configure "N2303" add port 3 tagged
  • configure "N2303" add port 21 tagged

SECOND SWITCH:

  • create vlan N2303
  • configure "N2303" tag 2303
  • configure "N2303" add port 21 tagged
  • configure "N2303" add port 4 tagged
  • configure "N2303" add port 3 tagged
  • configure "N2303" add port 2 tagged
  • configure "N2303" add port 1 tagged

The configuration of this vlan on the first switch is :

#show vlan id 2303

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
2303 2303                             active    Gi1/0/1, Gi1/0/3, Gi1/0/21

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
2303 enet  102303     1500  -      -      -        -    -        0      0   

Remote SPAN VLAN
----------------
Disabled

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

 

Vlan2303 is up, line protocol is up
  Hardware is EtherSVI, address is 3c5e.c332.e242 (bia 3c5e.c332.e242)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:03:27, output 01:37:21, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     19617 packets input, 1386644 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     18 packets output, 1692 bytes, 0 underruns
     0 output errors, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
FastEthernet0 is administratively down, line protocol is down
  Hardware is PowerPC FastEthernet, address is 3c5e.c332.e237 (bia 3c5e.c332.e237)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Auto-duplex, Auto Speed, MII
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters neverInput queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

 

#show interface GigabitEthernet1/0/1 trunk

Port        Mode             Encapsulation  Status        Native vlan
Gi1/0/1     on               802.1q         trunking      2303

Port        Vlans allowed on trunk
Gi1/0/1     2303

Port        Vlans allowed and active in management domain
Gi1/0/1     2303

Port        Vlans in spanning tree forwarding state and not pruned
Gi1/0/1     2303

 

#sh run  
Building configuration...

Current configuration : 3658 bytes
!
version 12.2
service config
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption

!
boot-start-marker
boot-end-marker
!


!
no aaa new-model

switch 1 provision ws-c2960s-24ts-l
!         
!         
ip domain-name
vtp mode transparent
!         
!         
!         
!         
spanning-tree mode pvst
spanning-tree extend system-id
no spanning-tree vlan 1-3000
!         
!         
!         
!         
vlan internal allocation policy ascending

vlan 126  
!         
vlan 2303
 name 2303
!         
ip ssh version 1
!         
!         
interface FastEthernet0
 no ip address
 shutdown
!         
interface GigabitEthernet1/0/1
 switchport access vlan 2303
 switchport trunk native vlan 2303
 switchport trunk allowed vlan 2303
 switchport mode trunk
 switchport nonegotiate
 spanning-tree portfast
 spanning-tree bpduguard disable

interface GigabitEthernet1/0/2
 switchport mode access
 spanning-tree portfast
 spanning-tree guard none
!         
interface GigabitEthernet1/0/3
 switchport access vlan 2303
 switchport trunk native vlan 2303
 switchport trunk allowed vlan 2303
 switchport mode trunk
 switchport nonegotiate
 spanning-tree portfast
 spanning-tree guard none
!         

interface GigabitEthernet1/0/4
 switchport mode access
 spanning-tree portfast
 spanning-tree guard none
!         
interface GigabitEthernet1/0/5
 switchport mode access
 spanning-tree portfast
 spanning-tree guard none
!         


.......

interface GigabitEthernet1/0/21
 switchport access vlan 2303
 switchport trunk native vlan 2303
 switchport trunk allowed vlan 2303
 switchport mode trunk
!         
interface GigabitEthernet1/0/22
!         
interface GigabitEthernet1/0/23
 switchport access vlan 126
 switchport mode access
!         
interface GigabitEthernet1/0/24
 switchport access vlan 126
 switchport mode access
!         

interface Vlan1
 no ip address
 shutdown
!         
interface Vlan126
 ip address 10.16.126.26 255.255.254.0
!         
interface Vlan2303
 no ip address
!         
ip http server
ip http secure-server
!         
line con 0
line vty 0 4

 

 

On the second switch:

#show vlan id 2303

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
2303 VLAN2303                         active    Gi1/0/1, Gi1/0/2, Gi1/0/3, Gi1/0/4, Gi1/0/21

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
2303 enet  102303     1500  -      -      -        -    -        0      0   

Remote SPAN VLAN
----------------
Disabled

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

Vlan2303 is up, line protocol is up
  Hardware is EtherSVI, address is 547c.69dd.d142 (bia 547c.69dd.d142)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:36, output 01:39:30, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     21454 packets input, 1470272 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     2051 packets output, 132260 bytes, 0 underruns
     0 output errors, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out

 

On the first machine, connected to the switch, i created a vlan

#dladm create-vlan -l net1 -v 2303 vlan1
# ifconfig vlan1 plumb 10.0.0.1/24 up

second machine:

#dladm create-vlan -l net1 -v 2303 vlan1
# ifconfig vlan1 plumb 10.0.0.2/24 up

Unfortunately, if i try to ping 10.0.0.2, it doesn't work:

# ping -s 10.0.0.2

PING 10.0.0.3: 56 data bytes

Have i missed something in the configuration on the vlan2303?

 

Cheeeers

1 Reply 1

Markus Benz
Level 1
Level 1

Hi Flora,

it is difficult to understand what the physical topology is from what you write.

But here is what you should look at:

  • It looks like you configure the vlan 2303 as tagged on the solaris side and native on the cisco side. Try to configure it as either tagged or native on both sides.
     
  • How many physical links do you have between the server and the switches?
    If there are multiple connections, are the teaming configurations correct? Or is there maybe a port-channel config missing?

 

Regards,

Markus

Review Cisco Networking for a $25 gift card