cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1167
Views
0
Helpful
6
Replies
Highlighted
Beginner

Trying to set embedded-service-engine IP add, says it overlaps. HELP!

Hi all,

I'm configuring my very first 2nd Generation 2901 Cisco ISR, and trying to set it up with CIMC-E. However, when I set up an IP address of 10.5.128.200 for the embedded-services-engine0/0 interface, it returns this error:

% 10.5.128.0 overlaps with GigabitEthernet0/0.128

% 10.5.128.0 overlaps with GigabitEthernet0/0.128

Here is the embedded service engine interface config:

interface Embedded-Service-Engine0/0

ip address 10.5.128.200 255.255.255.0

shutdown

service-module ip address 10.5.128.201 255.255.255.0

service-module ip default-gateway 10.5.128.1

end

Here is the config of gi0/0.128

interface GigabitEthernet0/0.128

description cadiz-data

encapsulation dot1Q 128

ip address 10.5.128.1 255.255.255.0

ip helper-address 10.5.128.10

no ip proxy-arp

ip pim sparse-dense-mode

no ip route-cache

end

Any help would be greatly appreciated!

6 REPLIES 6
Highlighted
Rising star

Trying to set embedded-service-engine IP add, says it overlaps.

Hi,

The Service Module interfaces you are trying to configure should follow the basic addressing rule, ie. come from a different subnet with regards to other (routing) interfaces. This remains true even if these interfaces are internal (ie. invisible). So you should choose another subnet than 10.5.128.0/24 (and of course a different subnet than that used for other interface addesses). Within that choosen (new) subnet you can assign one address to the router side of the Service Module and another to the module side. Service Module default gateway address is the router side of the Service Module ip address under normal circumstances.

Having said that I feel a bit surprised that you are trying to configure CIMC-E. To my knowledge your box (Cisco 2901 router) can only house internal SRE module (ISM-SRE-300-K9) and according to Cisco Documentation CIMC-E is not supported on the ISM-SRE-300-K9.

Best regards,

Antonin

Highlighted
Beginner

Trying to set embedded-service-engine IP add, says it overlaps.

This router has sub-interfaces for the 128 - 135 networks.

Are you saying I have to place it on a different network than ALL of those? I'm confused. Can you help elaborate?

Highlighted
Rising star

Trying to set embedded-service-engine IP add, says it overlaps.

Hi,

Will you please try these commands:

interface Embedded-Service-Engine0/0

ip address 10.5.136.1 255.255.255.0

no shutdown

service-module ip address 10.5.136.2 255.255.255.0

service-module ip default-gateway 10.5.136.1

Best regards,

Antonin

Highlighted
Beginner

Trying to set embedded-service-engine IP add, says it overlaps.

I'm confused. Why would I give it an IP address of a network it doesn't know about?

Highlighted
Hall of Fame Cisco Employee

Trying to set embedded-service-engine IP add, says it overlaps.

Hello,

What Antonin is trying to explain you is that the  Embedded-Service-Engine0/0 represents an internal connection to the CIMC  module within the router itself. In other words the Em0/0 is an  internal and standalone network interface that connects your router to  the CIMC module. It is independent of the externally-accessible  GigabitEthernet interfaces or any other network interfaces your router  might have. The Em0/0 interface is not in any way tied or bridged to the  Gi0/x interfaces, just like the Gi0/x interfaces are not tied or  bridged to each other. The Em0/0 is basically a separate, individual  point-to-point link inside your router that connects the router and the  CIMC together and that needs to be addressed using a separate and unique  network. Keep in mind that the CIMC is a separate and standalone  device, not really a part of your router. Therefore, as Antonin suggested, the Em0/0 interface is placed into a unique non-overlapping subnet, while the CIMC is configured to have another IP address from the same subnet.

It is also not true that the router does not know  about this network. This network will appear in the routing table as a  directly connected network to the Em0/0 interface. You will have to make  sure that this network is reachable by other stations that require  communication with the CIMC - possibly by advertising this route in a  routing protocol or by setting the devices to use your router as the  default gateway.

Best regards,

Peter

Highlighted
Rising star

Trying to set embedded-service-engine IP add, says it overlaps.

Hi,

My approach was to use a separate subnet for the Service Module. Should you prefer to use the same subnet as one of your already configured subnets you have the option of configuring the "ip unnumbered" interface, e.g. you can alternatively try this configuration:

interface Embedded-Service-Engine0/0

ip unnumbered gigabitethernet 0/0.128

no shutdown

service-module ip address 10.5.128.201 255.255.255.0

service-module ip default-gateway 10.5.128.1

There are pros and cons of configuring either way.

Best regards,

Antonin

CreatePlease to create content
Content for Community-Ad