cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
16585
Views
1
Helpful
6
Replies

TWO INTERFACES SAME SUBNET(R)

isaaco001
Level 3
Level 3

Dear Community,

I would like to have my router 2911 to have two interfaces with the same ip for the LAN,however, i have limited L3 devices so its just one router and two L2 switches. vrrp,glbp or hsrp or subif's is not to be used.What can be done?Thank you all.

Regards,

Isaac.

2 Accepted Solutions

Accepted Solutions

Hi

You cannot have 2 interface at the same subnet on the same router because they will overlap each other, but you can create a bridge group and associate your interfaces to it and you will have only 1 IP on the router. 

Example:

Router


interface Fa0/0
no ip address
bridge-group 2
!

interface Fa0/1
no ip address
bridge-group 2
!

!
interface BVI2
ip address 10.10.2.1 255.255.255.0
!

!

bridge irb
bridge 2 protocol ieee
bridge 2 route ip

Switch 1

vlan 2

interface Vlan2
ip address 10.10.2.2 255.255.255.0
end

Switch#ping 10.10.2.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Switch 2

vlan 2

interface Vlan2
ip address 10.10.2.3 255.255.255.0
end

Switch2#ping
*Feb 13 13:06:47.111: %SYS-5-CONFIG_I: Configured from console by console
Switch2#ping 10.10.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Switch2#ping 10.10.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
Switch2#ping 10.10.2.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/5/5 ms
Switch2#

Please rate the comment if it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

View solution in original post

Hi Isaac,

You are welcome, Yes this IP can be used on routing processes like any IP on a router.  

 :-) 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

View solution in original post

6 Replies 6

Hi

You cannot have 2 interface at the same subnet on the same router because they will overlap each other, but you can create a bridge group and associate your interfaces to it and you will have only 1 IP on the router. 

Example:

Router


interface Fa0/0
no ip address
bridge-group 2
!

interface Fa0/1
no ip address
bridge-group 2
!

!
interface BVI2
ip address 10.10.2.1 255.255.255.0
!

!

bridge irb
bridge 2 protocol ieee
bridge 2 route ip

Switch 1

vlan 2

interface Vlan2
ip address 10.10.2.2 255.255.255.0
end

Switch#ping 10.10.2.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Switch 2

vlan 2

interface Vlan2
ip address 10.10.2.3 255.255.255.0
end

Switch2#ping
*Feb 13 13:06:47.111: %SYS-5-CONFIG_I: Configured from console by console
Switch2#ping 10.10.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Switch2#ping 10.10.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
Switch2#ping 10.10.2.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/5/5 ms
Switch2#

Please rate the comment if it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Julio,

Thanks for your response. However, i have concerns that need to be settled.This bvi ip should act like any other ip i.e routable with no glitches(caveats),right?Its just odd..

Regards,

Isaac.

Hi Isaac,

You are welcome, Yes this IP can be used on routing processes like any IP on a router.  

 :-) 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Jubei
Level 1
Level 1

I know this is an older post but, I was working on a lab using VRF; in that specific instance, you can have the same IP address on two separate interfaces within the same router. Without VRF running it won't work. 





boot-end-marker
!
!
vrf definition Client-A
!
address-family ipv4
exit-address-family
!
vrf definition Client-B
!
address-family ipv4
exit-address-family
!
!
no aaa new-model
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!

!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
vrf forwarding Client-A
ip address 10.10.2.3 255.255.255.0
!
interface Ethernet0/1
vrf forwarding Client-B
ip address 10.10.2.3 255.255.255.0

!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown

True, but it may be unknown, to OP or some readers, such identical IPs cannot be within the same IP domain.

Ricky Sandhu
Level 1
Level 1

Currently working on my CCIE EI lab in GNS3 and I noticed on a given router, I can have two serial interfaces using the same IP configuration.  Is it because serial interfaces are point-to-point and theoretically can be connected to different networks using the same IP schema?

Serial1/0 10.1.10.10 YES NVRAM up up
Serial1/1 10.1.10.20 YES manual up up

 

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card