Showing results for 
Search instead for 
Did you mean: 
Join Customer Connection to register!

UCS Server NICs only work when port set to Access?

Hi All,


We have a UCS server that has 3 NIC - 1 Management (CIMC) and 2 10Gb NICs. One of those 10Gb interfaces is using a static VLAN6 (10.10.6.x) address and the other a static VLAN7 (10.10.7.x) address. 

Each of those uses an Ethernet cable and connects directly to the Core switch stack (2960XR). 

We have other servers connected to the same switch, although not Cisco UCS, and the port configuration for those is set to trunk, with a bunch of allowed vlans.

This time, when I did the same config for this server, it looks like any traffic is blocked to and from the NICs. I can't ping the gateway on any of the VLANs.

My workaround is to set the switchports to access and limit each NIC to what it can access.


Does anyone have any idea why this is?


Kind Regards,

Emanuil Svetlinski

VIP Collaborator

if you change the switchport from access to trunk, you need to do this on the UCS side too!

the way how, depends on the rest  of the environment.

if this ucs server is used as VMWare host than you need to configure within VMWare the virtual switch connected as a vlan trunk to the outside.

You may also need to enable the UCS server to use both ports as a port-channel to the same switch.


read this link for starters

Thank you for your reply. I wasn't able to see where to configure the settings on the server itself.

I spoke to TAC, however, and they advised that we have to configure the VLAN (6) as a native in the port that was previously changed as an access port on the same VLAN. They said "This was done because, by default, Windows OS doesn't use any kind of VLAN tagging."

I can't argue with the Windows side of things, but what doesn't make sense is how we have other, HP, servers on the same switch stack that do not require this configuration and are able to deal with tagged VLANs without any issues... 



on a side note, depending on your NIC, in Windows, you can assign a Vlan ID:


1. Press Windows key + R
2. Type devmgmt.msc
3. Click OK.
4. In Device Manager, open Network adapters.
5. Right-click on the NIC and choose Properties.
6. Click the Advanced tab.
7. Scroll down to VLAN ID.
8. Set the ID that you would like the NIC to have and click OK.



Thank you for the advice, I had a look on the server and I can see those options (see attached/below image).

I have tried to use every single one, and when I did, I also removed the native VLAN or changed the native VLAN statement on the switch, but that didn't help.


I guess it must be something specific for those NICs and there's no way around it? I checked a couple of our other servers and they don't seem to have this option/setting. The switch config for the other servers' ports currently changes the native VLAN to another VLAN that is not being used.



it may be you have the server LAN interface combined with the integrated management port?

you may need to assign the vlan according to:

Cisco UCS C-Series Servers Integrated Management Controller GUI Configuration Guide


or configure the IMC on a dedicated port and the server interface on another.

The CIMC port is set to Dedicated and separate from the other 2 NICs...