cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
708
Views
0
Helpful
11
Replies

UDLD shutting down a port

wwwillster07
Beginner
Beginner

I have a 6807 VSS core switch, and connected to that core are 2 IDF switches which are 4506.  The 10Gig ports on the sups of the 4506 are set up as a port channel, one leg goes back to one module on the VSS and the other to the secondary.

 

One 6807-4506 connection/port channel have no issue, and both links are up and works as expected, here is the 4506 relevant config that's working:

 

udld enable
!
interface Port-channel31
description Core-VSS EtherChannel
switchport
switchport trunk native vlan 199
switchport trunk allowed vlan 91,94,101,104,105,120,553-555,620,801,802
switchport mode trunk
mtu 9198
service-policy output VOIP_EC_Out_Pmap
ip dhcp snooping trust
!
interface TenGigabitEthernet1/1
switchport trunk native vlan 199
switchport trunk allowed vlan 91,94,101,104,105,120,553-555,620,801,802
switchport mode trunk
mtu 9198
channel-group 31 mode active
service-policy output VOIP_Phy_Out_Pmap
ip dhcp snooping trust
!
interface TenGigabitEthernet1/2
switchport trunk native vlan 199
switchport trunk allowed vlan 91,94,101,104,105,120,553-555,620,801,802
switchport mode trunk
mtu 9198
channel-group 31 mode active
service-policy output VOIP_Phy_Out_Pmap
ip dhcp snooping trust
!

 

And the debugs:

UDLD events debugging is on

Apr 27 20:05:25.713: (udld_send_ager), Message interval = 15000 (Te1/1)
Apr 27 20:05:25.713: (udld_send_ager), Message timer = 15000 (Te1/1)
Apr 27 20:05:25.713: Adv. transmit interval for Te1/1 = 15000
Apr 27 20:05:26.213: (udld_send_ager), Message interval = 15000 (Te1/2)
Apr 27 20:05:26.213: (udld_send_ager), Message timer = 15000 (Te1/2)
Apr 27 20:05:26.214: Adv. transmit interval for Te1/2 = 15000
Apr 27 20:05:28.740: Neighbor advertised transmit interval is = 15000
Apr 27 20:05:28.740: Neighbor cache entry expiration time is = 45000
Apr 27 20:05:28.740: New_entry = 5E4D0B08 (Te1/2)
Apr 27 20:05:28.740: Found an entry from same device (Te1/2)
Apr 27 20:05:28.740: Cached entries = 3 (Te1/2)
Apr 27 20:05:28.740: Entry (0x5D341358) deleted: 2 entries cached
Apr 27 20:05:28.740: Cached entries = 2 (Te1/2)
Apr 27 20:05:28.740: Checking if multiple neighbors (Te1/2)
Apr 27 20:05:28.740: Single neighbor detected (Te1/2)
Apr 27 20:05:28.740: Checking if link is bidirectional (Te1/2)
Apr 27 20:05:28.740: Found my own ID pair in 2way conn list (Te1/2)
Apr 27 20:05:31.740: Neighbor advertised transmit interval is = 15000
Apr 27 20:05:31.740: Neighbor cache entry expiration time is = 45000
Apr 27 20:05:31.740: New_entry = 5D341358 (Te1/1)
Apr 27 20:05:31.740: Found an entry from same device (Te1/1)
Apr 27 20:05:31.740: Cached entries = 3 (Te1/1)
Apr 27 20:05:31.740: Entry (0x5B675590) deleted: 2 entries cached
Apr 27 20:05:31.740: Cached entries = 2 (Te1/1)
Apr 27 20:05:31.740: Checking if multiple neighbors (Te1/1)
Apr 27 20:05:31.740: Single neighbor detected (Te1/1)
Apr 27 20:05:31.740: Checking if link is bidirectional (Te1/1)
Apr 27 20:05:31.740: Found my own ID pair in 2way conn list (Te1/1)

 

 

Now look at the 4506 that's not working:

!
udld enable

!
interface Port-channel30
description Core-VSS EtherChannel
switchport
switchport trunk native vlan 199
switchport trunk allowed vlan 92,93,100,102,103,105-107,110,552-555,620,692
switchport trunk allowed vlan add 802
switchport mode trunk
mtu 9198
load-interval 30
service-policy output VOIP_EC_Out_Pmap
ip dhcp snooping trust
!
!
interface TenGigabitEthernet1/1
description TO Core-VSS Te2/1/6
switchport trunk native vlan 199
switchport trunk allowed vlan 92,93,100,102,103,105-107,110,552-555,620,692
switchport trunk allowed vlan add 802
switchport mode trunk
mtu 9198
ip device tracking maximum 0
udld port
channel-group 30 mode active
service-policy output VOIP_Phy_Out_Pmap
ip dhcp snooping trust
!
interface TenGigabitEthernet1/2
description TO Core-VSS Te1/1/17
switchport trunk native vlan 199
switchport trunk allowed vlan 92,93,100,102,103,105-107,110,552-555,620,692
switchport trunk allowed vlan add 802
switchport mode trunk
mtu 9198
ip device tracking maximum 0
channel-group 30 mode active
service-policy output VOIP_Phy_Out_Pmap
ip dhcp snooping trust
!

 

And the debugs:

UDLD events debugging is on


switch#udld reset
Apr 27 20:10:50.090: (udld_send_ager), Message interval = 15000 (Te1/2)
Apr 27 20:10:50.090: (udld_send_ager), Message timer = 15000 (Te1/2)
Apr 27 20:10:50.090: Adv. transmit interval for Te1/2 = 15000set
1 ports shutdown by UDLD were reset.
switch#
Apr 27 20:10:51.754: Neighbor advertised transmit interval is = 15000
Apr 27 20:10:51.755: Neighbor cache entry expiration time is = 45000
Apr 27 20:10:51.755: New_entry = 5F219E90 (Te1/2)
Apr 27 20:10:51.755: Found an entry from same device (Te1/2)
Apr 27 20:10:51.755: Cached entries = 2 (Te1/2)
Apr 27 20:10:51.755: Entry (0x56D50140) deleted: 1 entries cached
Apr 27 20:10:51.755: Cached entries = 1 (Te1/2)
Apr 27 20:10:51.755: Checking if multiple neighbors (Te1/2)
Apr 27 20:10:51.755: Single neighbor detected (Te1/2)
Apr 27 20:10:51.755: Checking if link is bidirectional (Te1/2)
Apr 27 20:10:51.755: Found my own ID pair in 2way conn list (Te1/2)
Apr 27 16:10:52: %UDLD-6-UDLD_PORT_RESET: UDLD reset interface Te1/1
Apr 27 16:10:52: %PM-4-ERR_RECOVER: Attempting to recover from udld err-disable state on Te1/1
Apr 27 20:10:52.674: Port UDLD clear error disabled (was_disabled = TRUE) (Te1/1)
Apr 27 20:10:54.284: Phase set to udld_link_up from udld_link_down (Te1/1)
Apr 27 20:10:54.285: Timeout timer set to 8000 ms (Te1/1)
Apr 27 20:10:54.285: Adv. transmit interval for Te1/1 = 7000
Apr 27 20:10:54.292: timeout timer = 7900 ms (Te1/1)
Apr 27 20:10:54.390: timeout timer = 7800 ms (Te1/1)
Apr 27 20:10:54.489: timeout timer = 7700 ms (Te1/1)
Apr 27 20:10:54.588: timeout timer = 7600 ms (Te1/1)
Apr 27 20:10:54.688: timeout timer = 7500 ms (Te1/1)
Apr 27 20:10:54.754: Neighbor advertised transmit interval is = 7000
Apr 27 20:10:54.755: Neighbor cache entry expiration time is = 21000
Apr 27 20:10:54.755: New_entry = 5EE23190 (Te1/1)
Apr 27 20:10:54.755: Device Index = 1 (Te1/1)
Apr 27 20:10:54.755: First entry (Te1/1)
Apr 27 20:10:54.755: Zero IDs in 2way conn list (Te1/1)
Apr 27 20:10:54.755: Udld entering detection phase. (Te1/1),port_waiting_activation: 0
Apr 27 20:10:54.755: Adv. transmit interval for Te1/1 = 7000
Apr 27 20:10:54.755: Timeout timer set to 5000 ms (Te1/1)
Apr 27 20:10:54.755: Zero IDs in 2way conn list (Te1/1)
Apr 27 20:10:54.755: Zero IDs in 2way conn list (Te1/1)
Apr 27 20:10:54.755: UDLD FSM updated port, bi-flag udld_empty_echo, phase udld_detection (Te1/1)
Apr 27 20:10:54.788: timeout timer = 4900 ms (Te1/1)
Apr 27 20:10:54.889: timeout timer = 4800 ms (Te1/1)
Apr 27 20:10:54.988: timeout timer = 4700 ms (Te1/1)
Apr 27 20:10:55.089: timeout timer = 4600 ms (Te1/1)
Apr 27 20:10:55.188: timeout timer = 4500 ms (Te1/1)
Apr 27 20:10:55.290: timeout timer = 4400 ms (Te1/1)
Apr 27 20:10:55.388: timeout timer = 4300 ms (Te1/1)
Apr 27 20:10:55.489: timeout timer = 4200 ms (Te1/1)
Apr 27 20:10:55.588: timeout timer = 4100 ms (Te1/1)
Apr 27 20:10:55.688: timeout timer = 4000 ms (Te1/1)
Apr 27 20:10:55.688: (udld_send_ager), Message interval = 7000 (Te1/1)
Apr 27 20:10:55.688: (udld_send_ager), Message timer = 1000 (Te1/1)
Apr 27 20:10:55.689: Adv. transmit interval for Te1/1 = 7000
Apr 27 20:10:55.754: Neighbor advertised transmit interval is = 7000
Apr 27 20:10:55.755: Neighbor cache entry expiration time is = 21000
Apr 27 20:10:55.755: New_entry = 56D78248 (Te1/1)
Apr 27 20:10:55.755: Found an entry from same device (Te1/1)
Apr 27 20:10:55.755: Cached entries = 3 (Te1/1)
Apr 27 20:10:55.755: Entry (0x5EE23190) deleted: 2 entries cached
Apr 27 20:10:55.755: Cached entries = 2 (Te1/1)
Apr 27 20:10:55.755: Zero IDs in 2way conn list (Te1/1)
Apr 27 20:10:55.755: Zero IDs in 2way conn list (Te1/1)
Apr 27 20:10:55.755: UDLD FSM updated port, bi-flag udld_empty_echo, phase udld_detection (Te1/1)
Apr 27 20:10:55.788: timeout timer = 3900 ms (Te1/1)
Apr 27 20:10:55.888: timeout timer = 3800 ms (Te1/1)
Apr 27 20:10:55.989: timeout timer = 3700 ms (Te1/1)
Apr 27 20:10:56.090: timeout timer = 3600 ms (Te1/1)
Apr 27 20:10:56.188: timeout timer = 3500 ms (Te1/1)
Apr 27 20:10:56.291: timeout timer = 3400 ms (Te1/1)
Apr 27 20:10:56.388: timeout timer = 3300 ms (Te1/1)
Apr 27 20:10:56.488: timeout timer = 3200 ms (Te1/1)
Apr 27 20:10:56.588: timeout timer = 3100 ms (Te1/1)
Apr 27 20:10:56.688: timeout timer = 3000 ms (Te1/1)
Apr 27 20:10:56.688: (udld_send_ager), Message interval = 7000 (Te1/1)
Apr 27 20:10:56.688: (udld_send_ager), Message timer = 1000 (Te1/1)
Apr 27 20:10:56.688: Adv. transmit interval for Te1/1 = 7000
Apr 27 20:10:56.755: Neighbor advertised transmit interval is = 7000
Apr 27 20:10:56.755: Neighbor cache entry expiration time is = 21000
Apr 27 20:10:56.755: New_entry = 5F2EC650 (Te1/1)
Apr 27 20:10:56.755: Found an entry from same device (Te1/1)
Apr 27 20:10:56.755: Cached entries = 3 (Te1/1)
Apr 27 20:10:56.755: Entry (0x56D78248) deleted: 2 entries cached
Apr 27 20:10:56.755: Cached entries = 2 (Te1/1)
Apr 27 20:10:56.755: Zero IDs in 2way conn list (Te1/1)
Apr 27 20:10:56.755: Zero IDs in 2way conn list (Te1/1)
Apr 27 20:10:56.755: UDLD FSM updated port, bi-flag udld_empty_echo, phase udld_detection (Te1/1)
Apr 27 20:10:56.788: timeout timer = 2900 ms (Te1/1)
Apr 27 20:10:56.888: timeout timer = 2800 ms (Te1/1)
Apr 27 20:10:56.988: timeout timer = 2700 ms (Te1/1)
Apr 27 20:10:57.089: timeout timer = 2600 ms (Te1/1)
Apr 27 20:10:57.188: timeout timer = 2500 ms (Te1/1)
Apr 27 20:10:57.296: timeout timer = 2400 ms (Te1/1)
Apr 27 20:10:57.389: timeout timer = 2300 ms (Te1/1)
Apr 27 20:10:57.490: timeout timer = 2200 ms (Te1/1)
Apr 27 20:10:57.588: timeout timer = 2100 ms (Te1/1)
Apr 27 20:10:57.688: timeout timer = 2000 ms (Te1/1)
Apr 27 20:10:57.688: (udld_send_ager), Message interval = 7000 (Te1/1)
Apr 27 20:10:57.688: (udld_send_ager), Message timer = 1000 (Te1/1)
Apr 27 20:10:57.689: Adv. transmit interval for Te1/1 = 7000
Apr 27 20:10:57.755: Neighbor advertised transmit interval is = 7000
Apr 27 20:10:57.755: Neighbor cache entry expiration time is = 21000
Apr 27 20:10:57.755: New_entry = 56D78248 (Te1/1)
Apr 27 20:10:57.755: Found an entry from same device (Te1/1)
Apr 27 20:10:57.755: Cached entries = 3 (Te1/1)
Apr 27 20:10:57.755: Entry (0x5F2EC650) deleted: 2 entries cached
Apr 27 20:10:57.755: Cached entries = 2 (Te1/1)
Apr 27 20:10:57.755: Zero IDs in 2way conn list (Te1/1)
Apr 27 20:10:57.755: Zero IDs in 2way conn list (Te1/1)
Apr 27 20:10:57.755: UDLD FSM updated port, bi-flag udld_empty_echo, phase udld_detection (Te1/1)
Apr 27 20:10:57.788: timeout timer = 1900 ms (Te1/1)
Apr 27 20:10:57.891: timeout timer = 1800 ms (Te1/1)
Apr 27 20:10:57.988: timeout timer = 1700 ms (Te1/1)
Apr 27 20:10:58.089: timeout timer = 1600 ms (Te1/1)
Apr 27 20:10:58.188: timeout timer = 1500 ms (Te1/1)
Apr 27 20:10:58.290: timeout timer = 1400 ms (Te1/1)
Apr 27 20:10:58.388: timeout timer = 1300 ms (Te1/1)
Apr 27 20:10:58.488: timeout timer = 1200 ms (Te1/1)
Apr 27 20:10:58.592: timeout timer = 1100 ms (Te1/1)
Apr 27 20:10:58.688: timeout timer = 1000 ms (Te1/1)
Apr 27 20:10:58.688: (udld_send_ager), Message interval = 7000 (Te1/1)
Apr 27 20:10:58.689: (udld_send_ager), Message timer = 1000 (Te1/1)
Apr 27 20:10:58.689: Adv. transmit interval for Te1/1 = 7000
Apr 27 20:10:58.755: Neighbor advertised transmit interval is = 7000
Apr 27 20:10:58.755: Neighbor cache entry expiration time is = 21000
Apr 27 20:10:58.755: New_entry = 5F2EC650 (Te1/1)
Apr 27 20:10:58.755: Found an entry from same device (Te1/1)
Apr 27 20:10:58.755: Cached entries = 3 (Te1/1)
Apr 27 20:10:58.755: Entry (0x56D78248) deleted: 2 entries cached
Apr 27 20:10:58.755: Cached entries = 2 (Te1/1)
Apr 27 20:10:58.755: Zero IDs in 2way conn list (Te1/1)
Apr 27 20:10:58.755: Zero IDs in 2way conn list (Te1/1)
Apr 27 20:10:58.755: UDLD FSM updated port, bi-flag udld_empty_echo, phase udld_detection (Te1/1)
Apr 27 20:10:58.788: timeout timer = 900 ms (Te1/1)
Apr 27 20:10:58.888: timeout timer = 800 ms (Te1/1)
Apr 27 20:10:58.988: timeout timer = 700 ms (Te1/1)
Apr 27 20:10:59.089: timeout timer = 600 ms (Te1/1)
Apr 27 20:10:59.188: timeout timer = 500 ms (Te1/1)
Apr 27 20:10:59.290: timeout timer = 400 ms (Te1/1)
Apr 27 20:10:59.388: timeout timer = 300 ms (Te1/1)
Apr 27 20:10:59.489: timeout timer = 200 ms (Te1/1)
Apr 27 20:10:59.588: timeout timer = 100 ms (Te1/1)
Apr 27 20:10:59.691: timeout timer = 0 ms (Te1/1)
Apr 27 20:10:59.691: (udldGoToExtendedDetection), Entering phase = extended detection
Apr 27 20:10:59.691: (udldGoToExtendedDetection), Message interval = 7000 ms
Apr 27 20:10:59.691: (udldGoToExtendedDetection), Message timer = 7000 ms
Apr 27 20:10:59.691: Phase set to EXT. (Te1/1)
Apr 27 20:10:59.755: Neighbor advertised transmit interval is = 7000
Apr 27 20:10:59.755: Neighbor cache entry expiration time is = 21000
Apr 27 20:10:59.755: New_entry = 5EE23190 (Te1/1)
Apr 27 20:10:59.755: Found an entry from same device (Te1/1)
Apr 27 20:10:59.755: Cached entries = 3 (Te1/1)
Apr 27 20:10:59.755: Entry (0x5F2EC650) deleted: 2 entries cached
Apr 27 20:10:59.755: Cached entries = 2 (Te1/1)
Apr 27 20:10:59.755: Zero IDs in 2way conn list (Te1/1)
Apr 27 20:10:59.755: Zero IDs in 2way conn list (Te1/1)
Apr 27 20:10:59.755: UDLD disabled port, packet received in extended detection (Te1/1)
Apr 27 20:10:59.755: Adv. transmit interval for Te1/1 = 7000
Apr 27 16:10:59: %UDLD-4-UDLD_PORT_DISABLED: UDLD disabled interface Te1/1, unidirectional link detected
Apr 27 16:10:59: %PM-4-ERR_DISABLE: udld error detected on Te1/1, putting Te1/1 in err-disable state
Apr 27 20:10:59.759: Port UDLD set error disabled (Te1/1)

 

As a test I disabled UDLD on int te 1/1 and it joins the port channel no issue and stays up.  I've only left it for 15 minutes at a time and re-enable it as I'm not leaving udld disabled.  But i have not seen an issue with it disabled, and the port channel comes up correctly each time with it disabled.   I've swapped SFPs between Ten 1/1 and Ten 1/2 and 1/1 always err disables.  I've swapped the fiber pairs so 1/1 is running over the pair that 1/2 is working correctly on, and sure enough 1/1 err disables, so I know it can't *possibly* be the fiber, but it's 12 strands and I've gone through and used all of them and 1/1 always disables.

 

TAC determined it was the sup and RMA'd a new sup, same issue is still happening so I highly doubt it's the sup now.

 

I'm kind of at my wits end on this and about ready to just disable it for int ten 1/1 and see how long it goes before i have an issue with the switch.  There's one thing I noticed, but this timer may be simply because it's down:

 

sh udld

Interface Te1/1
---
Port enable administrative configuration setting: Enabled
Port enable operational state: Enabled
Current bidirectional state: Unidirectional
Current operational state: Disabled port
Message interval: 7000 ms
Time out interval: 5000 ms

Port fast-hello configuration setting: Disabled
Port fast-hello interval: 0 ms
Port fast-hello operational state: Disabled
Neighbor fast-hello configuration setting: Disabled
Neighbor fast-hello interval: Unknown

No neighbor cache information stored

Interface Te1/2
---
Port enable administrative configuration setting: Follows device default
Port enable operational state: Enabled
Current bidirectional state: Bidirectional
Current operational state: Advertisement - Single neighbor detected
Message interval: 15000 ms
Time out interval: 5000 ms

 

 

7000/5000 vs 15000/5000?

 

Unsure if that matters but it's the only difference i'm seeing in the ports....there's a lot there crammed into a little space, but any guidance sure would be appreciated

 

 

1 Accepted Solution

Accepted Solutions

Figured it out.  It was in fact that int ten 2/1/6 on the core...it's bad.

 

Had a maintenance window for something else and started to mess with this and pulled the fiber off one leg of another port channel and defaulted that interface and put this config in, came right up now issue and been stable an hour now.

 

So it's the actual 2/1/6 port on the Core.  Doesn't really buy me much as the ports are fully populated so I have no spare, but at least I know for sure what the issue is.  That card is end of life we have a 3rd party that supports it, have to see if they can replace that card!

 

Thank you again!!!!

View solution in original post

11 Replies 11

MHM Cisco World
Advisor
Advisor

Aggressive UDLD may config in one side or the cable is damage