ATTENTION: We are currently working an issue with posting. Thank you for your patience while we work on a resolution.
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
590
Views
15
Helpful
4
Replies

Unable to route between routers

gguenther29
Level 1
Level 1

I have been pulling my hair out trying to figure this out and I can't seem to figure it out.  R1 can ping R2 and vice versa.  I had to add static routes for this to work properly.  PC1 can ping R1's G0/0 & G0/1.  PC2 can ping R2's G0/0 and G0/1.  PC1 cannot ping R2 or PC2.  PC2 cannot ping R1 or PC1.  What am I missing here?

 

See my topology and router configs below.

network config.png

 

 

 

 

R1 Config

 

Current configuration : 975 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

ip cef

no ipv6 cef

!

!

!

!

license udi pid CISCO2911/K9 sn FTX1524R40X-

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface GigabitEthernet0/0

ip address 10.17.10.254 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.7.1.253 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0/0

no ip address

clock rate 2000000

shutdown

!

interface Serial0/0/1

no ip address

clock rate 2000000

shutdown

!

interface Vlan1

no ip address

shutdown

!

interface Vlan2

mac-address 00e0.b073.2401

no ip address

!

router rip

!

ip classless

ip route 10.107.2.0 255.255.255.0 10.7.1.254

!

ip flow-export version 9

!

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

 

R2 Config

 

Current configuration : 777 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

ip cef

no ipv6 cef

!

!

!

!

license udi pid CISCO2911/K9 sn FTX1524836Y-

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface GigabitEthernet0/0

ip address 10.107.2.10 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.7.1.254 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

shutdown

!

interface Vlan1

no ip address

shutdown

!

router rip

!

ip classless

ip route 10.107.1.0 255.255.255.0 10.107.1.253

!

ip flow-export version 9

!

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

 

PC1 settings

IP - 10.17.10.10

Netmask - 255.255.255.0

Gateway - 10.17.10.254

 

PC2 settings

IP - 10.107.2.12

Netmask - 255.255.255.0

Gateway - 10.107.2.10

 

Thanks in advance, I'm sure I'm missing something stupid I'm a total noob.

 

-G

1 Accepted Solution

Accepted Solutions

Hello,

 

you could just enable RIP version 2 and advertise all networks (marked in bold). You wouldn't need any static routes:

 

R1 Config

Current configuration : 975 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
license udi pid CISCO2911/K9 sn FTX1524R40X-
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 10.17.10.254 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.7.1.253 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
mac-address 00e0.b073.2401
no ip address
!
router rip
version 2
network 0.0.0.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

 

R2 Config

Current configuration : 777 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
license udi pid CISCO2911/K9 sn FTX1524836Y-
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 10.107.2.10 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.7.1.254 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 0.0.0.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

View solution in original post

4 Replies 4

Hello

 

On r2 -
no ip route 10.107.1.0 255.255.255.0 10.107.1.253
ip route 10.17.10.0 255.255.255.0 10.1.7.253


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hello,

 

you could just enable RIP version 2 and advertise all networks (marked in bold). You wouldn't need any static routes:

 

R1 Config

Current configuration : 975 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
license udi pid CISCO2911/K9 sn FTX1524R40X-
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 10.17.10.254 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.7.1.253 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
mac-address 00e0.b073.2401
no ip address
!
router rip
version 2
network 0.0.0.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

 

R2 Config

Current configuration : 777 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
license udi pid CISCO2911/K9 sn FTX1524836Y-
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 10.107.2.10 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.7.1.254 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 0.0.0.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

Hello

Just like to add if you an IGP ( rip/eigrp/ospf) as suggested by Georg make sure you remove the static routes


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Thanks for the help I added eigrp for the 10.0.0.0 network and it now seems to be working. Thanks for all the help guys, I may update some more as I add more devices into the network. I still have 2 more routers to add into my configuration.

thanks again!
Review Cisco Networking for a $25 gift card