08-23-2017 08:29 AM - edited 03-08-2019 11:48 AM
I'm new to routing/switching and using Todd Lammle's study guide. After entering the ip and mask for a router-router connection I am getting 2 subnets and 2 masks where he gets a single subnet and mask. I know I must be missing something very obvious but I literally copied his steps from a fresh router config and yet we are getting different results.
Input:
Router1(config-if)#int s0/0/0
Router1(config-if)#ip address 172.16.10.1 255.255.255.252
Router2(config-if)#int s0/1/0
Router2(config-if)#ip address 172.16.10.2 255.255.255.252
His output from router1:
172.16.0.0/30 is subnetted, 1 subnets
C 172.16.10.0 is directly connected, Serial0/0/0
L 172.16.10.1/32 is directly connected, Serial0/0/0
My output from router1:
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.10.0/30 is directly connected, Serial0/0/0
L 172.16.10.1/32 is directly connected, Serial0/0/0
His output from router2:
172.16.0.0/30 is subnetted, 1 subnets
C 172.16.10.0 is directly connected, Serial0/0/0
L 172.16.10.2/32 is directly connected, Serial0/0/0
My output from router2:
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.10.0/30 is directly connected, Serial0/1/0
L 172.16.10.2/32 is directly connected, Serial0/1/0
Both .1 and .2 should be within the same /30 subnet so I am confused as to how I could have 2 subnets and 2 masks on each router? I see that my output shows the /30 mask I entered but also shows a /16?
Thank you!
Solved! Go to Solution.
08-23-2017 11:02 AM - edited 08-23-2017 11:20 AM
Hi
It is a normal behavior on IOS 15. You will see 2 subnets because it is representing the real subnet mask (C = Connected) and showing the IP as host (L = Local). Remember you are using classless on the router so it will be keeping a line for 172.16.0.0/16
Hope it is useful
:-)
08-23-2017 08:36 AM - edited 08-23-2017 08:37 AM
Hello
May you send here the rest of config ?
you will get it with " show running-config "
Regards
Yashar
08-23-2017 08:45 AM
Yes, see below thanks.
Right now I only have the two routers connected and router2(SF) connected to a switch. Though the config I entered from the book calls for an additional router(LA) I kept it as barebones as possible in order to attempt to figure this out.
From Router1(Corp):
Current configuration : 1679 bytes
!
! Last configuration change at 15:16:38 UTC Wed Aug 23 2017
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Corp
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$SgMA$L47fD6h2JztgqB0zm8jM20
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 192.168.10.1
ip dhcp excluded-address 192.168.20.1
!
ip dhcp pool SF_LAN
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 4.4.4.4
!
ip dhcp pool LA_LAN
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
dns-server 4.4.4.4
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FTX1224A1YM
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description Connection to Lan Backbone
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
description WAN Connection to SF
ip address 172.16.10.1 255.255.255.252
!
interface Serial0/1/0
description WAN Connection to LA
ip address 172.16.10.5 255.255.255.252
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!
!
banner motd ^C This is my Corp Router ^C
!
line con 0
password console
logging synchronous
line aux 0
line vty 0 4
password telnet
login
transport input all
line vty 5 988
password telnet
login
transport input all
!
scheduler allocate 20000 1000
end
From Router 2(SF):
Current configuration : 1256 bytes
!
! Last configuration change at 14:39:13 UTC Wed Aug 23 2017
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SF
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$J8OU$DtAMFshuAtRxsigzvcyWg0
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
!
!
!
ip cef
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO1841 sn FHK114250X9
!
redundancy
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description SF LAN
ip address 192.168.10.1 255.255.255.0
ip helper-address 172.16.10.1
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
description WAN Connection to Corp
ip address 172.16.10.2 255.255.255.252
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging esm config
!
!
!
!
!
!
control-plane
!
banner motd ^CThis is the SF Branch router^C
!
line con 0
password console
logging synchronous
login
line aux 0
line vty 0 4
password telnet
login
transport input all
line vty 5 807
password telnet
login
transport input all
!
scheduler allocate 20000 1000
end
08-23-2017 11:02 AM - edited 08-23-2017 11:20 AM
Hi
It is a normal behavior on IOS 15. You will see 2 subnets because it is representing the real subnet mask (C = Connected) and showing the IP as host (L = Local). Remember you are using classless on the router so it will be keeping a line for 172.16.0.0/16
Hope it is useful
:-)
08-23-2017 02:35 PM
One question about that because I looked back and it seems that he is using IOS 15. I've also seen others say it's a version 12 vs 15 issue but according to the book and other things I've read the 'L' routes shown in the table are a new feature of version 15 so he couldn't possibly be using 12.x right?
I'll quote the book:
"what about that 'L' in the routing table-that's new, isn't it? Yes it is, because in the new Cisco IOS 15 code, Cisco defines a different route, called a local host route. Each local route has a /32 prefix, defining a route just for the one address."
So why we are getting different output's is still unclear.
08-23-2017 08:50 PM
Hi,
I agree with you but we don't know the exact IOS file he is using, it could be one of the first releases of IOS 15. Usually using IOS 12 we should see something like:
Gateway of last resort is not set
172.16.0.0/30 is subnetted, 1 subnets
C 172.16.10.0 is directly connected, FastEthernet0/0
Although we are using classless by default it is not displaying 172.16.0.0/16 and 2 subnets like we see on version 15.
:-)
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide