01-20-2021 11:32 PM
Hi,
Here is the the configuration
** Router **
interface gigabitEthernet 0/1.1
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface gigabitEthernet 0/1.2
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!
**Switch1**
vlan 10
name 10
!
interface fastEthernet 0/1
switchport access vlan 10
!
switchport mode trunk
switchport trunk allowed vlan 10
!
**Switch2**
vlan 20
name 20
!
interface fastEthernet 0/1
switchport access vlan 20
!
switchport mode trunk
switchport trunk allowed vlan 20
!
**Switch3**
interface range fastEthernet 0/1-3
switchport mode trunk
switchport trunk allowed vlan 10,20
!
I can't ping pc to pc. Could you tell me what i did wrong?
01-20-2021 11:46 PM
Hello,
Packet Tracer has some quirks. Change the subinterfaces to:
interface gigabitEthernet 0/1.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface gigabitEthernet 0/1.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
If that doesn't work, post the zipped Packet Tracer project (.pkt) file.
01-20-2021 11:58 PM - edited 01-20-2021 11:59 PM
01-21-2021 12:22 AM
Hello,
the problem was that Vlan 10 did not exist on Switch 1, and Vlan 20 did not exist on Switch 2. When you assign a Vlan to a port in access mode, the Vlan is automatically created. Since you have configured the links between the PCs and the switches as trunks, you have to manually create the Vlans.
Attached the working file.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide