cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
7736
Views
0
Helpful
22
Replies

VLAN Extend on L3 link

shahulhameed
Level 3
Level 3

Hi

I have a CORE switch, the access switches are connected to that in Layer 3 link. I want to extend one of VLAN which is for server, configured in CORE to one access location. 

Please advise how can I extend to a access switch? 

 

Thanks and Regards,

Shahul Hameed.

 

 

 

1 Accepted Solution

Accepted Solutions

Yes, However the services connected via access switch will be disrupted during the migration.

access:
 
global config commands

vlan 10
vlan 20
vlan 555

default interface TenGigabitEthernet1/1/2

interface config:

interface TenGigabitEthernet1/1/2
 description *** Link to MDBM-DC-CS1 ***
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport noneg
 switchport trunk allowed vlan 10,555
 no shut

interface Vlan20
 description MDBM-DRS-Petro-App
 ip address 172.16.21.1 255.255.255.224

interface Vlan555
 description for_routing
 ip address 172.16.225.162 255.255.255.252

routing:

router ospf 1
 netw 172.16.225.162 0.0.0.0 a 0
 netw 172.16.21.1 0.0.0.0 a 0

 

 

crore:

global config:

vlan 10
vlan 555

default interface TenGigabitEthernet1/7/5

interface config:

interface TenGigabitEthernet1/7/5
 description MDBM-F-DRS
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport noneg
 switchport trunk allowed vlan 10,555
 no shut

interface Vlan555
 description for_routing
 ip address 172.16.225.161 255.255.255.252

routing:

router ospf 1
 netw 172.16.225.161 0.0.0.0 a 0

 

 

note: rip does not advertise ospf learned routes, you either need to do redistribution between rip and ospf or migrate from rip to ospf (I strongly recommend to use ospf)

 

Please, rate useful answer.

 

Br,

István

View solution in original post

22 Replies 22

Jon Marshall
Hall of Fame
Hall of Fame

You are limited in your options with switches.

The easiest way is to make the link between the switches a trunk.

So at the moment you probably have the ports between the switches configured as L3 ports with IP addresses.

What you do is -

1) create a new vlan just for this and create SVIs on each switch.

2)  move the IPs from the routed ports to the SVIs.

3) on the trunk only allow the new vlan and the server vlan you want to extend.

With the above all vlans on the access switch are still routed locally and the new vlan is used to route to remote vlans but at the same time the server vlan is extended.

Jon

Hi Jon

Please can you send any sample configuration?

 

Thanks and Regards,

Shahul Hameed.

What exactly do you need in terms of configuration ?

It's not clear because from the steps I gave it should be pretty simple.

Which bit are you not sure about ?

Jon

Vlan 30 is the extended vlan for servers

Vlan 31 is for routing

 

Access Switch

ip routing

vlan 10,20,30,31

interface GigabitEthernet0/1
 description UPlink to core
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 30,31
 switchport mode trunk
 switchport nonegotiate

interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access

interface FastEthernet0/2
 switchport access vlan 20
 switchport mode access

interface FastEthernet0/3
 switchport access vlan 30
 switchport mode access

interface Vlan31
 ip address 10.0.0.2 255.255.255.252

router ospf 1
 network 172.16.10.0 0.0.0.255 area 0
 network 172.16.20.0 0.0.0.255 area 0
 network 10.0.0.0 0.0.0.3 area 0

interface vlan 10
 ip address 172.16.10.1 255.255.255.0

interface vlan 20
​ ip address 172.16.20.1 255.255.255.0

Core Switch

 

ip routing

vlan 30,31

interface Vlan31
 ip address 10.0.0.1 255.255.255.252

interface GigabitEthernet0/1
 description Downlink to Access
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 30,31
 switchport mode trunk
 switchport nonegotiate

interface FastEthernet0/1
 switchport access vlan 30
 switchport mode access

router ospf 1
 network 172.16.30.0 0.0.0.255 area 0
 network 10.0.0.0 0.0.0.3 area 0

 

Feel free, to ask questions and please rate helpful answers.

Just to clarify that configuration won't work as intended.

You would need a new vlan for the routing which you need to allow on the trunk link and you don't have an SVI for the server vlan on the access switch because you are extending that vlan not routing it.

Jon

Ah, now I understand what he wants to achieve.

My requirement is extend server VLAN to one of access location. My LAN setup is like this, we are using RIP V2 routing protocol to connect all access switches with L3 link.

The servers are connected to the CORE. The server VLANs are 10, 12, 14, 16, 18,20 and 22.

The access switch have only one VLAN configured. I want to extend one VLAN from CORE to the access switch.I have attached CORE and access switch configuration for more information.

I tried to configure access switch 3750 with trunk port but it gives error and not communicate the server VLAN.

Please advise how can trunk configured and what are test command and trouble shoot methods?

I have looked into the configuration.

 

You have RIP running on the access switch, but it is not advertising anything.

There is no 10.0.0.0 network on the access switch.

You are using default routes on the core switch, and as well as RIP with 10.0.0.0.

It make no sense. I would recommend to use OSPF and only OSPF to keep the configuration simple.

 

Which vlan do you want to extend from core to access and what are the existing vlans on the access switch?

 

If you want to extend vlan X and the access switch has only vlan X and no other vlans, you can either use an access port between the switches or a trunkport allowing only vlan X on both sides of the trunk.

 

If you want to have multiple vlans (A,X,Y,Z) on the access switch, then you will need a trunkport with all the required vlans allowed on it. One which is the extended vlan from the core(X), one for routing(A). SVI's on both core and access switch mapped to vlan A and you can route subnets from local vlans via vlan A (layer3) and pass vlan X via layer2.

For the second scenario, please refer to the given example.

 

Additionally, please make a little diagram to make sure I understand what you do want.

I need only one VLAN extend to the access location. There is one vlan configured in the access switch. Both device VTP mode is Transparent. Will it impact any service if I change the VTP mode Transparent to server in core switch will it effect any service? because already Nexus switch are connected to the core.

I try to configure trunk between these device but all services went down in access switch so i revert back the configuration.

 

 

 

We can't tell you what to do because your configuration doesn't make sense.

The access layer switch has a 172.16.21.0 255.255.255.224 IP subnet but you are not advertising that under your RIP configuration.

As it's not clear how your setup is currently working it's difficult to say what to change.

Jon

There is route for 172.16.0.0 by mistake its removed in the text file.

 

I want to extend VLAN 10 to the access switch. I have created only one VLAN(20) in the access switch. 

The link is 

Core SW interface TenGigabitEthernet1/7/5 

goest to

Access SW interface TenGigabitEthernet1/1/2

 

Thanks and Regards,

Shahul Hameed.

 

Do you want to keep vlan20 as a local (routed vlan) on the access switch?

Yes I want to keep VLAN 20 on local switch and want to extend only one VLAN from core to the access switch.

I am afraid to do any changes in that core. Because Nexus are connected and some important servers are connected on that Nexus.

Is VLAN can be extend while both core and access switches are in transparent mode?

Please send any sample configuration.

Yes, However the services connected via access switch will be disrupted during the migration.

access:
 
global config commands

vlan 10
vlan 20
vlan 555

default interface TenGigabitEthernet1/1/2

interface config:

interface TenGigabitEthernet1/1/2
 description *** Link to MDBM-DC-CS1 ***
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport noneg
 switchport trunk allowed vlan 10,555
 no shut

interface Vlan20
 description MDBM-DRS-Petro-App
 ip address 172.16.21.1 255.255.255.224

interface Vlan555
 description for_routing
 ip address 172.16.225.162 255.255.255.252

routing:

router ospf 1
 netw 172.16.225.162 0.0.0.0 a 0
 netw 172.16.21.1 0.0.0.0 a 0

 

 

crore:

global config:

vlan 10
vlan 555

default interface TenGigabitEthernet1/7/5

interface config:

interface TenGigabitEthernet1/7/5
 description MDBM-F-DRS
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport noneg
 switchport trunk allowed vlan 10,555
 no shut

interface Vlan555
 description for_routing
 ip address 172.16.225.161 255.255.255.252

routing:

router ospf 1
 netw 172.16.225.161 0.0.0.0 a 0

 

 

note: rip does not advertise ospf learned routes, you either need to do redistribution between rip and ospf or migrate from rip to ospf (I strongly recommend to use ospf)

 

Please, rate useful answer.

 

Br,

István

Review Cisco Networking for a $25 gift card