12-28-2010 01:44 AM - edited 03-06-2019 02:43 PM
Hi
Is it doable to forward VLAN 4 over a WAN Link in my scenario.
My requirement is to have one PC in S2 to be on VLAN 4 and use IP 192.168.4.25
S1 -------------------- S2
S1 connects to S2 over Private circuit
OSPF is the routing protocol
*****************
**On S1 Site**
*****************
VTP domain S1
VTP moder server
vlan 1
vlan 2
vlan 3
vlan 4
vlan 10
interface Vlan 4
ip address 192.168.4.254 255.255.255.0
interface vlan 10
ip address 192.168.100.1 255.255.255.252
interface Giga 1/1
Description Connected to S2
switchport mode access
switchport access vlan 10
router OSPF 1
network 192.168.4.254 0.0.0.255 area 0
network 192.168.100.1 0.0.0.0 area 0
******************
**On S2 Site**
*****************
VTP domain S2
VTP Mode server
vlan 1
vlan 2
vlan 3
vlan 10
interface vlan 10
ip address 192.168.100.2 255.255.255.252
interface Giga 1/1
Description Connected to S1
switchport mode access
switchport access vlan 10
router OSPF 1
network 192.168.100.2 0.0.0.0 area 0
At S2 if I do show IP route 192.168.4.0 its reachable via vlan 10 ( 192.168.100.2 )
Solved! Go to Solution.
12-28-2010 03:24 AM
Keven,
We know too little about your network so any hints given to you may break some things we do not know about yet.
In any case, if your private line connecting S1 and S2 supports transporting 802.1Q-tagged frames then you could actually convert it to trunk with two VLANs allowed: 4 and 10, as follows:
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4,10 ! May also require adding VLAN1
swichport mode trunk
This way, you will effectively allow the VLAN4 to span both sites. Note that the conversion of the interconnection to the trunk may result into break of connectivity until both ends are configured for trunking. You may perform the transition in two steps: first, move the ports into dynamic desirable mode:
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4,10 ! May also require adding VLAN1
swichport mode dynamic desirable
and after both are configured in the similar way, you may replace the "switchport mode dynamic desirable" with "switchport mode trunk". This will allow for graceful transition from access to trunk mode. Please bear in mind that for the trunking negotiation to work properly, the VTP domain name must match on both switches. That has another consequence: by creating a trunk connection between your two switches, you will effectively join them in the same VTP domain - I don't know if this is what you want.
Once again, take care when implementing this.
Best regards,
Peter
12-28-2010 03:10 AM
Why you need to do that?
What exactly prevents the PC to work with an address belonging to it's site ?
12-28-2010 03:13 AM
Hi,
As I see this you have two options:
1. Make the link between the sites a trunk and transport VLAN 4 along with vlan 10 over it.
2. Use a L2 tunneling protocol like L2TPv3 or Atom.
Regards,
Adrian
12-28-2010 03:24 AM
Keven,
We know too little about your network so any hints given to you may break some things we do not know about yet.
In any case, if your private line connecting S1 and S2 supports transporting 802.1Q-tagged frames then you could actually convert it to trunk with two VLANs allowed: 4 and 10, as follows:
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4,10 ! May also require adding VLAN1
swichport mode trunk
This way, you will effectively allow the VLAN4 to span both sites. Note that the conversion of the interconnection to the trunk may result into break of connectivity until both ends are configured for trunking. You may perform the transition in two steps: first, move the ports into dynamic desirable mode:
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4,10 ! May also require adding VLAN1
swichport mode dynamic desirable
and after both are configured in the similar way, you may replace the "switchport mode dynamic desirable" with "switchport mode trunk". This will allow for graceful transition from access to trunk mode. Please bear in mind that for the trunking negotiation to work properly, the VTP domain name must match on both switches. That has another consequence: by creating a trunk connection between your two switches, you will effectively join them in the same VTP domain - I don't know if this is what you want.
Once again, take care when implementing this.
Best regards,
Peter
12-28-2010 04:25 AM
Peter thanks for the input. We are group of companies and S1,S2 are Units of these groups.
Both Sites are running in different VTP domains ; and changes to VTP domain is not possible.
Not sure still this config is helpful
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4,10 ! May also require adding VLAN1
swichport mode trunk
12-28-2010 06:27 AM
Hello Keven,
Okay, the VTP domains should remain separate, then. In such case, we cannot rely on DTP.
You wrote: Not sure still this config is helpful - can you be more specific about your concerns?
Best regards,
Peter
12-28-2010 08:46 AM
Peter Thanks again. Here are the details again
S1--------------------------S2
With Current configuration all Subnets on S2 is reachable via S1 and vice-versa.
After I change the configuration on S1 and S2 to
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4,10 ! May also require adding VLAN1
swichport mode trunk
My concern<>
Will S1 all subnet be reachable via S2 and vice-versa
+
one host in S2 to be on VLAN 4 and reachable via S1
regards
Keven
12-28-2010 09:38 AM
Keven,
If you implement my suggestion then everything will stay the same, with one exception: the VLAN4 on both sites will merge together and become one IP subnet. All stations in VLAN4 will be expected to be placed in a single IP subnet and will be able to communicate directly without needing any routing, only switching.
If this is not what you need then please try to specify your requirements more closely.
Best regards,
Peter
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide