vlan switch to switch via fa port switchport settings?
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-15-2008 10:17 AM - edited 03-05-2019 10:24 PM
We are getting ready for a voip implementation and have our data vlan and voice vlan created. We go from a stack of 6 switches via fiber module to location in plant to a 3560ps works great there, but I need to setup a temp switch (poe) in training room just above this area. So I need to go via a fa port on the 3560 to this poe switch and be able to plug in a phone for training. settings that I have for the fa port are currently
interface GigabitEthernet3/0/35
switchport access vlan 33
switchport trunk encapsulation dot1q
switchport trunk native vlan 33
switchport trunk allowed vlan 1,33,50,330,1002-1005
switchport mode trunk
spanning-tree portfast
where 30 is data and 330 is voice
not having any luck getting phone to work off of the other poe switch. If you plug phone directly into the cable that comes out of the 3560ps works fine, but not out of the other poe switch using this port. thanks for any heads up, it has to be something simple I would think
- Labels:
-
LAN Switching
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-15-2008 10:28 AM
The switchport must be either an access port or a trunk port. In this case you want it to trunk so your configuration should be:
int gig3/0/35
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk native vlan 1
switchport trunk allowed vlan 1,33,50,330,1002-1005
spanning-tree portfast
Please also make sure that the port on the poe switch is also configured in the same manner. Also make sure you add the vlan's to the vlan database of the poe switch. Good Luck!
If you just want access to the voice vlan, you can configure like this:
int gig3/0/35
switchport mode access
switchport access vlan 330
spanning-tree portfast
This will connect the other switch to vlan 330 for voice with no additional configuration required on the poe switch.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-15-2008 10:41 AM
the phones will be connected to pc's so I assume I will need the data and voice vlans. The native vlan for data is 33 and for voice 330.
I tried this:
int gig3/0/35
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk native vlan 33
switchport trunk allowed vlan 1,33,50,330,1002-1005
spanning-tree portfast
but I lose my connection to the network from that port, I do not have the other poe configured. I was hoping that information would pass to it "magicaly" ahah so I need the port on the other poe trunked with same settings as the port on the 3560, correct?
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-15-2008 11:54 AM
Hi Mark,
You mentioned you have a connection between the switches on a Fastethernet port. Why are you configuring a gig port then?
First, you need to configure the trunk between the 3560ps and the new PoE switch.
I don't see your trunk config on the 3560ps, but the config on the new switch should be similar to this:
interface fax/y/z
switchport trunk encapsulation dot1q
switchport trunk native vlan 33
switchport trunk allowed vlan 1,33,50,330,1002-1005
switchport mode trunk
Then, you need to configure the access port where the IP phone is connected:
Interface fax/y/w
switchport access vlan 33
switchport mode access
switchport voice vlan 330
Cheers:
Istvan
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-15-2008 11:56 AM
you either need to configure all your vlans on the temp switch or configure VTP for your vlans to pass "magically" as you said. Also, typically you do not configure portfast on a trunk port as it prevents from participating in spanning tree, however, since this is a single temp point to point link with no chance for a loop, you should be ok.
